OpenGL not working after system update

Hi there,
Yesterday I’ve installed a new system update via the package manager, as usual.
I believe it included a new plasma update as well as a linux update, among many other things.

Upon restarting, my framerate was about 1fps.
The PC resources wasn’t in intense use, and the tasks seems to happen at regular speed, it’s just that the frame rate is a constant slideshow - not in the login screen, only after login to user, and also not including the cursor movement.

after some tinkering I’ve arrived to the compositor settings, and realised that the the problem exists when “Rendering backend” is set to OpenGL, either 2.0 which it was on, or 3.1.
Upon using the XRender option the frame rate instantly bounces back up to normal, but now I have a serious Tearing issue (horizontal cuts along frames), so system is only partially usable.

The laptop model is Dell Inspiron 15 5567 from aroud 2017.
According to specs the Grapichs Proccessor is “AMD Radeon R7 M445”, PC does have a “Radeon Graphics” sticker on it.
This is the state of the Display Drivers, to the best of my knowledge -

Edit: if it is somewhat relevant - I still have this issue also persisting.
Also, I am using both laptop monitor and an external one.

Thanks in advance for any help!

1 Like

I’ve got the same issue on an Intel UHD 620. According to the latest update thread, it seems to be related to the new xorg version.

can you link it?
also - have you managed to solve it?

The forum doesn’t allow me to add links. :frowning:

No solution yet except downgrading or using XRender.

Thanks for the info!
just got to downgrading both xorg-server and xorg-server to 1.20.13-1 and system as back to normal.

Just out of curiosity - how did you find out it’s xorg?

Just from the other thread:

I had similar issue with the xorg-server and xorg-server-common update and the inability to use my external monitor on a Dell laptop with Intel integrated graphics (i915). I was able to fix it by downgrading xorg-server and xorg-server-common. I believe that the issue here is the Debian patches that were added because I built xorg-server without the Debian patches and all was fine again. On another laptop with no external monitor, it worked fine with the official release, but my Desktop background was lost and had to be re-applied.

Please read this first:

and then that:

Today’s update - not yet announced went smoothly except :
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
A restart is required for the changes to take effect.
can’t see the announcement for today’s update so posted here instead.

Happened to me too,
Also, hasn’t fixed this exsisting issue.

1 Like

In the meantime, I found out it’s somehow related to using multiple screens in a certain configuration. I get the performance bug in my normal configuration:

But I don’t have it if I change it to this:

Really weird…

Well… As long as we don’t get an inxi --admin --verbosity=7 --filter --no-host --width which would be the minimum required information for us to be able to help you, we can’t progress as there is nothing to base the Root Cause Analysis on…


There is a bug in the kde bug tracker:
The title doesn’t mention multi monitor involvement, but the comments do read exactly like the alignment issue you discovered.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.