Cannot type foregn characters in terminal

Hello there, after the last update I can not type characters such as ö in my terminal. When I press such characters terminal gives the output of .

I tried this with konsole and alacritty both gave the same result however tty seems to work correctly.

Another problem I have which I think is connected to this one is when I try to open a odt files with foreign characters in them gives me the error of “~/G??t.odt does not exist.”

Hi @xanrer, and welcome!

  1. Please, see [HowTo] Provide System Information.
    1.2. If applicable, please see [HowTo] post screenshots and links

  2. How are you trying to type said characters? Do you have another keyboard attached?

  3. Please post the output of:

cat /etc/locale.conf

As well as:

  1. Please, see Locale - Manjaro

Hope this helps!


While I might not be able to help, this info will still be neccessary for anyone else trying to be of assistance.

Well, if you don’t have any idea, we, trying to help, have even less of an idea. So please look at the links provided and provide the requested information.


After seeing this reply

by what looks like the same user on a different topic even very close to the same wording, I’m going to say it’s a good thing you’ve got no idea, since this wasn’t directed at you.

Hello! I read the HowTo Provide System Info however I would like to keep most of the stuff there private. That being said there was instant red flags when I entered the command:

~ $ inxi --admin --verbosity=7 --filter --width
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MONETARY = "en_US.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.

I thought giving the info in the registry form would be enough.

“cat /etc/locale.conf” gives:


And “locale” gives:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Thank you.

The --filter flag in the command

inxi --admin --verbosity=7 --filter --width

does already filter out any personal identifiable information.

But it’s your information. Thank you for proving what you provided, though.

It seems as if your locale isn’t set up properly, and I suspect that might be thee cause of, or at least contribute to your issue.

To add a locale, edit /etc/locale.gen:

sudo micro /etc/locale.gen

and uncomment all settings/locales/whateveritscalled you want on your pc, followed by generating the correct settings:

sudo locale-gen

NOTE: I am completely unsure if this’ll work, but it’s worth a shot…I think…

Hello, i checked locale.gen sadly my language/keyboard is already enabled, so that’s not the issue, thank you for the suggestion.

1 Like

But have you run,

sudo locale-gen

as that is also required.

Oh yeah, i did that too, sorry I forgot to mention it.

Well, if you did, then I don’t know if I can help you further, except point you here: Locale - Manjaro

Sorry for the late response, I checked the link sadly nothing helped.

Urgh. Sorry, then!

So hey, this is kind of off-topic but since it’s been two days I gotta ask, where else can I find support? I checked manjarolinux subreddit but it seems a little inactive.