[Stable Update] 2020-09-11 - Kernels, Gnome 3.36.6, MHWD, Pamac, VirtualBox

Super nice 20.1
Working perfectly
Great job
Thanks for the hard work

I create a post for my issue:

Thanks in advance for the help

From the announce above:

I got this error:

sudo usermod --append --groups virtualbox $USER
usermod: group 'virtualbox' does not exist

@bogdancovaciu is helping me there…

And this is the solution :trophy: (Thanks to @bogdancovaciu):

I’m not able to get to the login screen after this update. could it be my old 340 nvidia driver?
I’m able to ctrl+alt f2, but going back to f1, it’s just a black screen

Did you try ctrl+alt+F7?

Yeah. Not working.
Trying to remove nvidia drivers

Yeah, remove nvidia drivers solved it… guess i cant use 340 drivers no more?

1 Like

Nope, 340 series is still supported:

mhwd --listall | grep 340
video-hybrid-intel-nvidia-340xx--bumblebee            2019.10.25               false            PCI
    video-nvidia-340xx            2019.10.25               false            PCI

Open a new issue for this here and link to this post.

1 Like

Got an error messages and didn’t upgrade
but after again run upgrade process everything went OK

error: lib32-util-linux: signature from "Christian Hesse <eworm@archlinux.org>" is invalid
:: File /var/cache/pacman/pkg/lib32-util-linux-2.36-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: libpgm: signature from "Kyle Keen <keenerd@gmail.com>" is invalid
:: File /var/cache/pacman/pkg/libpgm-5.3.128-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)

Errors occurred, no packages were upgraded.

Cannot boot after update. Getting Failed to Load Kernel Extensions error during boot and get put into Emergency Mode command line.

Edit: Booted into alternate kernel 5.7, which booted fine. Then proceeded to reinstall kernel 5.8. Rebooted into 5.8 fine afterwards. Issue resolved.

1 Like

No issues here. XFCE via TTY.

Had some issues with this one, video stopped working, lost network, and lm_sensors.service fails.

adapter is a Realtek RTL8111H gigabit ethernet controller. The kernel driver wasn’t being loaded, fixed by:

modprobe r8169  

Then reinstalled drivers later via the GUI once graphics were re-established (this seems to have installed r8168).

Prior to this update, I had already installed nvidia 450xx. It seems like the cause of this issue was that linux58-nvidia-450xx was not installed in the update from kernel 57 to kernel 58, I fixed this by running

sudo mhwd -f -i pci video-nvidia-450xx  

haven’t solved the lm_sensors issue yet, since it is less critical, I will do that when I get the time, if anyone has any suggestions, the error is:

systemd[1]: Starting Initialize hardware monitoring sensors...
sensors[590]: No sensors found!
sensors[590]: Make sure you loaded all the kernel drivers you need.
sensors[590]: Try sensors-detect to find out which these are.
systemd[1]: lm_sensors.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: lm_sensors.service: Failed with result 'exit-code'.
systemd[1]: Failed to start Initialize hardware monitoring sensors.  

I have run sensors-detect, and it made no difference.
Edit: fixed, linux58-headers was not installed and so the zenpower module was not updated.

Clean the cache:

pamac clean --keep 0
pamac clean --build-files

and try again.

1 Like

Try removing lm_sensors and purging the configuration files:

pamac remove --no-save lm_sensors

reboot, reinstall and detect again:

sudo reboot
pamac install lm_sensors

If that doesn’t do the trick, open a new issue here and link to this post.

1 Like

My WiFi signals got really weak after the update, how do I fix it ?

[manjaro@manjaro ~]$ inxi -F
System:    Host: manjaro Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 Desktop: i3 4.18.2 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: H71M-DGS serial: <superuser/root required> BIOS: American Megatrends v: P1.50 
           date: 01/31/2013 
CPU:       Topology: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1596 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1596 4: 1597 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel 
           Display: x11 server: X.org 1.20.8 driver: intel unloaded: modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa 20.1.7 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Device-2: SAVITECH type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.4.64-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: eth0 state: down mac: bc:5f:f4:ba:39:b8 
           Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB driver: r8188eu 
           IF: wlan0 state: up mac: 98:de:d0:18:23:0a 
Drives:    Local Storage: total: 465.76 GiB used: 123.03 GiB (26.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000AZLX-60K2TA0 size: 465.76 GiB 
Partition: ID-1: / size: 200.72 GiB used: 31.04 GiB (15.5%) fs: ext4 dev: /dev/sda5 
Swap:      ID-1: swap-1 type: partition size: 255.0 MiB used: 0 KiB (0.0%) dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 35.0 C mobo: 33.0 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 2125 fan-3: 0 fan-4: 0 fan-5: 0 
Info:      Processes: 190 Uptime: 11h 41m Memory: 7.49 GiB used: 2.46 GiB (32.9%) Shell: Bash inxi: 3.1.05 
[manjaro@manjaro ~]$ 


iw wlan0 set txpower fixed 1300

If that doesn’t help, please open a new issue here.

1 Like


Can’t update because linux58-ndiswrapper doesn’t exist… what must i do ?


1 Like

A small blockage during the update and installation of packages. I had errors like:

https://mirrors.shuosc.org/manjaro/stable/core/x86_64/core.db: Error resolving “mirrors.shuosc.org”: Name or service unknown http: / /pet.inf.ufsc.br/mirrors/manjarolinux/stable/core/x86_64/core.db: Unable to connect: I / O timed out on the connector https://mirrors.shu.edu.cn/manjaro/ stable / core / x86_64 / core.db: Unable to connect: Connection refused https://repo.rhindon.net/manjaro/stable/core/x86_64/core.db: Error resolving “repo.rhindon.net” : Name or service unknown

But I was able to solve them by changing the mirrors of the official repositories from “whole world” to “France”.

1 Like

I can’t boot due to mysterious issues with LightDM

Posted more details in this issue.

Hi @kraNG,

I seem to have the same problem.
Could you please explain a noob how to do this from tty2? (I mean, removing the drivers)

Thank you so much, I was just about to reinstall all the system from scratch…

After noticing last night that I couldn’t use Vulcan with the 440xx driver I was able to use the GUI tool to switch it out for the 450xx driver and when I rebooted it worked probably because I had already uninstalled cuda.

The above refers to the pervious stable update. I’m not sure I ever actually got this one. I remeber getting a small update of 27 packages. Maybe that was it? All went fine so I’ll mark that :slight_smile:
Even updated my mirror list and ran -Syyu but got nothing else.

I have the same problem: linux58-ndiswrapper is a required dependency of linux-latest-ndiswrapper, but linux58-ndiswrapper does not exist. Even upgrading the kernel from Linux 5.7.19 to Linux 5.8.6 does not help, because the upgrade does not supply linux58-ndiswrapper, and it’s not in the repos. I have linux57-ndiswrapper on my computer, but not linux58-ndiswrapper.

This problem was already noted here:

However, a solution to the problem was not provided.