No Wifi Connenctions Available

I can connect to Internet through phone USB connection but there’s no Wifi available for me to choose, even after pacman -Syyu. I’ve tried several methods in the forum and Arch wiki but no one worked. Thanks a lot if you can help.

inxi -Fxxxza --no-host
  Kernel: 5.15.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=2391996f-e130-409b-819d-699bf5a6282b rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux

  Device-1: Qualcomm Atheros QCNFA765 vendor: Foxconn driver: ath11k_pci
    v: kernel port: N/A bus-ID: 02:00.0 chip-ID: 17cb:1103 class-ID: 0280
  IF-ID-1: enp4s0f3u2 state: unknown speed: -1 duplex: half mac: <filter>
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0f4u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 66:09:56:e9:e8:53 brd ff:ff:ff:ff:ff:ff

sudo dmesg | grep ath11k

[    1.972762] ath11k_pci 0000:02:00.0: BAR 0: assigned [mem 0xd1000000-0xd11fffff 64bit]
[    1.972793] ath11k_pci 0000:02:00.0: enabling device (0000 -> 0002)
[    1.973214] ath11k_pci 0000:02:00.0: wcn6855 hw2.0
[    2.038287] mhi mhi0: Direct firmware load for ath11k/WCN6855/hw2.0/amss.bin failed with error -2

I’ve noticed the error -2 above but have no ideas how to solve it.

lspci -k | grep ath11k
        Kernel driver in use: ath11k_pci
        Kernel modules: ath11k_pci

Added: I found that there’s no wireless LAN in my rfkill list…

rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Make sure that your system is fully updated, especially the firmware. See post #2 here maybe it gives a hint of what may be needed:

Hi @gfzum, and welcome!

I have no, zero, zip, none, experience with wireless, so will probable not be able to help you. However, please see [HowTo] Provide System Information and [HowTo] post screenshots and links for providing the info to those trying to be of assistance.


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead off like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Thanks for the advice!

Think I’ve got my system updated after Pacman -Syyu and fwupdmgr get-updates

gfzum@gfzum-laptopH ~> fwupdmgr get-updates
Devices with no available firmware updates: 
 • System Firmware
 • WDC PC SN730 SDBPNTY-512G-1036
No updatable devices

After I tried the command in the post my system was frozen and could do nothing for about an hour (similar commands are suggested in Arch wiki but it says it will just take few minutes, odd…)


Sorry to ask if I use the code block in a wrong way?

The hardware might not be supported yet:

that may make sense! I found ath6k, ath9k, ath10k also existed in my firmware package but have no ideas how to change the driver :upside_down_face: let me keep trying it.

btw I’ve added info that there’s no wireless LAN in my rfkill list

Hi !
What a coincidence! I’m having the same problem with QCNFA765. Installing Linux on newly released hardware is a real hassle!
I installed latest stable version of manjaro(kernel 5.15) few days ago on my hp probook(zhan 66) together with the original windows11. Everything goes well except the WLAN card.
I followed the guide of installing ath11k with manually selecting ath11k support options and install the kernel. ( :sob: Why I can’t provide a hyperlink here?) But, it’s soo odd that I didn’t even find ‘Atheros ath11k PCI support’ in the menuconfig… Only the options for ath9k and ath10k are provided.
Another solution provided in Archwiki is using ndiswrapper. But another discussion in this forum said that ndiswrapper works only on 5.10 or older version of the kernel. I haven’t tried this method yet.
I’m even thinking about changing the WLAN card to an older one. :rofl: But hopefully we can solve the problem together~
I’m on windows now. If you need more detailed information about my computer, I can provide it later.

Thanks for your reply! Finally I’ve solved the problem after Kalle updated the ath11k files.
For more information, you may check out my support requests to the mailing list and these bug reports:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.