A compilation of issues that I am having/had with Manjaro

First of all, I have spent almost my entire life as a Windows user and then eventually had switched to Linux Mint for like 5 minutes (Because I didn’t set a password and didn’t know what to do), then to Ubuntu for a few months and have now settled in with Manjaro with kde Plasma. I thought Ubuntu was pretty alright but I am in love with Manjaro, although there are still a few things that annoy me (see below) and a few things I need to get accustomed with since I am not too familiar with the new distribution.

Problems are sorted from most annoying/getting in the way a lot, to least annoying/non-issues, TL;DR at the bottom.

Note: I was going to add images to this to make it a bit more understandable, but am unable to post images through both the “Upload” tool and using links to imgur images. Bear with me and perhaps message me for pictures if needed.

  1. One of the problems is that when I right click something on my (3440x1440p) monitor’s desktop, it opens the right click menu very far to the left of where I had originally clicked. Now this doesn’t occur in folders or on my secondary monitor (1920x1080p) which I find a bit strange. If I right click a file that is close to the border of the secondary monitor the right click menu gets carried over to the secondary monitor and disregards the main monitor. (Fixed)

  2. The second problem is that applications tend to open (both fullscreen and windowed) onto my secondary monitor, which I do not like since that is not my primary monitor (it’s even set that way in the settings). This was one of the reasons why I switched away from Ubuntu since it really annoyed me, but atleast Manjaro does it only sometimes with steam games and files but always when opening folders and never when opening it through the primary monitor’s taskbar. Not only that, the applications that are opening in windowed mode, like a folder, tend to open out of bounds and I am unable to drag them in. Fortunately it is solvable with the use of SHIFT+WINDOWS KEY+ARROW KEY, but unfortunately it wastes time and irritates me that I have to do that every time it happens, which it happens way WAY more commonly than it did on Ubuntu and I have never have had it happen in Windows.

  3. Now I wouldn’t count this as a problem that others might experience, but for some reason the desktop environment and more importantly the Dolphin folder application seemed to be unreasonably slow compared to Ubuntu and especially Windows. However I managed to make it less unreasonably slow by enabling TRIM on my SSD. I find this as a non-issue now but definitively mentionable since it baffled me how a new install on a SSD can be so slow to respond after opening something or moving things around on the desktop. I swear I sat there for atleast a minute just banging my head against the table because it took forever to open folders and move things around, before just pressing the restart button on my case and trying again, this time slower. I am not sure whether this is a me problem or if there actually is a solution to fix this somewhere if I look deep enough, but honestly I don’t know what to call this issue so it’s hard to determine what the cause of this was.

  4. Speaking of slow, Steam. Steam usually runs very smoothly and without any problems, although I have had this issue with Ubuntu and now with Manjaro where if Steam is left alone too long and you try to do anything with it it becomes very sluggish and doesn’t respond to clicks. I use the Manjaro version of Steam and I have used the normal Steam version on Ubuntu. I have no idea why, how or what makes it do that but the internet has suggested that the friends list is the cause of the problem, which I have disabled most of the time so that’s not the issue.

  5. Another issue that I ran across is the fact that the application Konsole (Whose name confused me for some time since I am from Germany and thought that it somehow enabled German for some applications and English for others) which seems to open in a very weird size at the start, although apparently that is a known bug or something but it’s fixable by just having the option that saves the size that the terminal was closed at disabled. But this is fine since I am going to avoid the terminal for now so I can adjust to the new distro first.

  6. Not too big of an issue, but the Windows key seems to be doing absolutely nothing (Other than the key inputs that do special things like SHIFT+WINDOWS KEY+ ARROW KEY). I am unsure whether this is a setting that I haven’t come across yet but it is a bit of an annoyance that I am unable to simply press the Windows Key to open the Pager like it did on Ubuntu or atleast open the “Simple launcher Menu” like Windows does. (Solved)

  7. Not considering this an issue since I can live without it, but it seems like I cannot make a shortcut to the trashcan onto my desktop. Although this is pretty annoying since right clicking to move something to the trashcan prompts the first (1. Problem) problem I am having. ;’) (Solved)

  8. Caps lock delay. Simple, you press caps lock and it activates instantly. You press caps lock again and it takes a few more milliseconds than it does on Windows to deactivate and makes typing a nightmare. And honestly at this point I have given up on trying to fix this back when I had Ubuntu and have switched over to Shift (I am not happy about this) but, who knows maybe the people on this forums have a very smart way of fixing this or atleast explaining why it is the way it is. (Yes I tried the “Linux-CapsLock-Delay-Fixer” script on github, yes it works on some applications and no, it does not work when you set it to run on startup.)


  1. Right click menu too far to the left from starting click on main monitor’s desktop. (Fixed)
  2. Applications open on wrong monitor/are put in top left corner in a way where they are unmovable.
  3. Manjaro Desktop and Dolphin folder (among other things) very slow to open and move.
  4. Steam very sluggish and slow.
  5. Konsole weird size on startup.
  6. Windows Key does not do anything upon pressing without a combination of other keys. (Solved)
  7. Cannot put Trashcan shortcut onto Desktop. (Solved)
  8. CAps LOck DElay.

Otherwise there aren’t many other major issues to note or report on just yet, other than the fact that the caps lock delay issue still somehow persists across all distros and will never be fixed >:( and I have had a very positive experience with the Manjaro distribution and will continue using it from now on.
I am open for questions and pray that these issues can be resolved. Because for whatever reasons I always manage to break things in ways that others have never broken before.!

Please make one thread per issue. It will be a mess to follow otherwise.

1 Like

Alright, thank you for this information.

You have to assign another key combo to the application launcher ─ common is Alt+F1. Then you can open the application launcher through the Meta (Win) key too. I know it sounds bizarre, but that’s how it works in Plasma.

The trashcan is a desktop widget. Right-click the desktop, choose “Enter edit mode”, and then right-click it again and choose “Add widgets”. You’ll see the trashcan widget in the list on the left side of the screen.

1 Like

I prefer Alt+F12 as it also works, and is less likely to conflict.

But thats also just a quirk of the plasma kicker settings.

Otherwise you can pretty happily assign ‘Super’ to just about anything you want.