How can run vpn-unlimited?

hello everyone, I installed vpn unlimited with yay -S vpn-unlimited command line, but its not runinig.

Hi @sdg, and welcome!

vpn-unlimited is in the AUR:

$ pamac search vpn-unlimited
vpn-unlimited                                                                                                                                                                                                                                    8.5-3  AUR
VPN Unlimited client application

So can be installed with:

pamac build vpn-unlimited

If that doesn’t work, please report back along with the output of above mentioned command.

There is supposed to be a systemd service installed.
The name I gleaned from the PKGBUILD should be:


You likely need to enable and start it.
systemctl enable vpn-unlimited-daemon.service
systemctl start vpn-unlimited-daemon.service

Hi, its the output of terminal : vpn-unlimited [Installed] 8.5-3
VPN Unlimited client application
But not run

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

It seems to be a Qt application, from what I see in its dependencies. Please run the application from the terminal and provide that output here, as described above, Along with the output of:

journalctl --boot=0 | grep -E --ignore-case 'vpn|unlimited'

… didn’t miss it :grinning:
On the AUR page are, in the comments, instructions to overcome that

AUR (en) - vpn-unlimited

I don’t think the OP has looked at those and followed the trail.

There is a comment from two months ago stating that this works.

Adjusting the PKGBUILD to use the recent version is probably not too difficult but I don’t think the OP is up to that.

Unfortunately, the VPN provider’s core team is in a war zone. The support is well-aware of the situation of the aur package. They are looking forward to supporting officially arch and derivatives anytime soon, but the situation in Ukraine doesn’t seem to give them any slack.

You need to patch vpn-unlimited. Follow the instructions here.


Hi, when I write this command ‘’ vpn-unlimited-daemon.service’’ , the outpot is:
zsh: command not found: vpn-unlimited-daemon.service

That is not how you use it.

This is how you use it:

Thank you for youre advise,
I enabled and started with that command line, But its not runing

What’s the output?

systemctl status vpn-unlimited-daemon.service

Do you really need this? The AUR package was updated in 2021 and is currently orphaned.

the output is: vpn-unlimited-daemon.service - VPN Unlimited daemon
Loaded: loaded (/usr/lib/systemd/system/vpn-unlimited-daemon.service; enabled; preset: disabled)
Active: failed (Result: exit-code) since Thu 2023-01-12 14:24:19 +0330; 12min ago
Duration: 89ms
Process: 2554 ExecStart=/usr/bin/vpn-unlimited-daemon (code=exited, status=127)
Main PID: 2554 (code=exited, status=127)
CPU: 24ms

Jan 12 14:24:19 manjaro-x553ma systemd[1]: Started VPN Unlimited daemon.
Jan 12 14:24:19 manjaro-x553ma vpn-unlimited-daemon[2554]: /usr/bin/vpn-unlimited-daemon: symbol lookup error>
Jan 12 14:24:19 manjaro-x553ma systemd[1]: vpn-unlimited-daemon.service: Main process exited, code=exited, st>
Jan 12 14:24:19 manjaro-x553ma systemd[1]: vpn-unlimited-daemon.service: Failed with result ‘exit-code’.
lines 1-12/12 (END)

I also suggested to look at the AUR page and read the comments there.
(it’s likely that this task is “above your pay grade”, but who knows?)

Hi, the output is: pamac build vpn-unlimited  :heavy_check_mark:  58s 
Cloning vpn-unlimited build files…
Generating vpn-unlimited information…
Checking vpn-unlimited dependencies…
Warning: vpn-unlimited-8.5-3 is up to date – reinstalling
Resolving dependencies…
Checking inter-conflicts…

To build (1):
vpn-unlimited 8.5-3 AUR

Edit build files : [e]
Apply transaction ? [e/y/N] y

Building vpn-unlimited…
==> Making package: vpn-unlimited 8.5-3 (Thu 12 Jan 2023 02:57:08 PM +0330)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
→ Found vpn-unlimited-daemon.service
→ Found vpn-unlimited_8.5+deb10-amd64.deb
==> Validating source_x86_64 files with sha256sums…
vpn-unlimited-daemon.service … Passed
vpn-unlimited_8.5+deb10-amd64.deb … Passed
==> Removing existing $srcdir/ directory…
==> Extracting sources…
→ Extracting vpn-unlimited_8.5+deb10-amd64.deb with bsdtar
==> Entering fakeroot environment…
==> Starting package()…
==> Tidying install…
→ Removing libtool files…
→ Purging unwanted files…
→ Removing static library files…
→ Stripping unneeded symbols from binaries and libraries…
→ Compressing man and info pages…
==> Checking for packaging issues…
==> Creating package “vpn-unlimited”…
→ Generating .PKGINFO file…
→ Generating .BUILDINFO file…
→ Adding install file…
→ Generating .MTREE file…
→ Compressing package…
==> Leaving fakeroot environment.
==> Finished making: vpn-unlimited 8.5-3 (Thu 12 Jan 2023 02:57:16 PM +0330)
==> Cleaning up…

Checking keyring… [1/1]
Checking integrity… [1/1]
Loading packages files… [1/1]
Checking file conflicts… [1/1]
Checking available disk space… [1/1]
==> skipping timeshift-autosnap due skipRsyncAutosnap in /etc/timeshift-autosnap.conf set to TRUE.
Reinstalling vpn-unlimited (8.5-3)… [1/1]
Restarting vpn-unlimited-daemon.service …
Running post-transaction hooks…
Reloading system manager configuration… [1/5]
Arming ConditionNeedsUpdate… [2/5]
Refreshing PackageKit… [3/5]
Updating icon theme caches… [4/5]
Updating the desktop file MIME type cache… [5/5]
Transaction successfully finished.

It’s installed correctly. Please read the comments on the AUR page.