How to disable annoying pop-up when arranging desktop icons?

I’m using Manjaro XFCE for several years now, and I never saw anything similarly mind-blowingly annoying thing in Manjaro or in any other distro, to be honest. It started happening lately.
It was always like when I was done a right-click on the desktop, and selected the “Arrange Desktop Icons” it was always just happened; arranged the icons. Without any issues, and annoying pop-ups. I never-ever had any problem because of this NORMAL BEHAVIOUR.

Not so long time ago, this incredibly annoying giant window, that covers most of screen started to pop-up, which say:
“This will reorder all desktop items and place them to different screen positions”, and have to choose “Yes” or “No”.
I swear, this is the most annoying and inexplicable thing I every encountered in anything in the past decades while using computers. It just drives me crazy.

I using this icon-arranging functon a lot. I put everything that I working on or using on the desktop, and after I finished whatever I do with them, I moving things into a different location for storage or whatsoever. Because I like the icons when they are nicely arranged, I use this arranging a lot.
I can’t even discribe how annoying this thing is for me, and how much it hinders working with anything on my computer.

How I can disable it forever, so it will never come back, even after a system update?

Open an issue with the xfce development team

Desktop Manager (xfdesktop)

Like in thunar, the ‘Delete’ menu entry in the context menu can now be hidden.

In order to don’t mess the desktop by accident on pressing ‘rearrange desktop icons’, the user is asked for confirmation now.
Xfce 4.18 tour – Xfce

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. As you’re rather new here and don’t have much reputation yet :wink: looking here on how to post screenshots is advisable too (if you think a screenshot would help).
  4. Please try to keep to the facts only, as it makes your posts easier to read without the ranting and raving. :grin: :stuck_out_tongue_winking_eye:


1 Like

Xfce developers added the user confirmation in response to a user request to hide the menus option so it could not be selected accidentally
Possibility to hide menu item "arrange desktop icons" (#128) · Issues · Xfce / xfdesktop · GitLab
Ask for confirmation before desktop icons are rearanged (Issue #128) (!23) · Merge requests · Xfce / xfdesktop · GitLab

There is a workaround to create a custom launcher in Whisker Menu:

This command should rearrange icons without asking for user confirmation

xfdesktop -A

If the command works as expected, copy/paste all of the following to terminal to create an application launcher:

tee ~/.local/share/applications/arrange-desktop-icons.desktop <<< '[Desktop Entry]
Name=Arrange Desktop Icons
Exec=/usr/bin/xfdesktop -A

The new launcher should be available in Whisker Menu > All Applications

right-click on the launcher in Whisker Menu to Add to Desktop or Add to Panel

Desktop or Panel Launchers will probably show a warning that launcher is untrusted when first executed
Click on Mark Executable and warning pop-up should not come back

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.