[Stable Update] 2020-09-08 - Kernels, Mesa, Browsers, KDE Apps 20.08.1, Systemd, LibreOffice 7.0.1, Deepin

Am I the only one?

With this update of FF, I can no longer access websites that run on flash, older websites such as
h t t p://shiporsheep.com/
I mean I am still asked if I wish to allow Flash but nothing happens afterwards. I am sad.

Chromium problem too. Randomly showing atrifacts on top left corner of screen while moving mouse.

Flash has been broken for a very long time and is finally being retired but to continue in your foolhardiness using flash, see the instructions over on the Adobe Website on how to unblock it, more specifically, here for Firefox


Just tried that, as I only got the time for it just now. Added both nvidia-418xx-utils and linux58-nvidia-418xx to IgnorePkg, pacman still insisted on replacing the former :frowning:

Do you have CUDA and / or nvtop nstalled? If yes, remove those first, then try again and feed back whenever you have the time.

1 Like

Just checked it and indeed I had cuda installed. I was able to start the update after removing it! Thanks for your help! I really appreciate it! :grin:

1 Like

Same problem with the 5.8 kernel as previous recent updates, in that my AMD based Toshiba netbook will still not boot with the 5.8 Kernel, it works fine with earlier kernels.

(I would have included links to my previous posts but I got the message “Sorry, you can’t include links in your posts” even though I was able to include links in my previous posts?)

Hi People,

Not sure if I should open a new thread for that or not. So, if moderators think that it is better, I am fine with moving to a new topic.

I have discovered few days ago something that I am not sure when started, but I have the impression that it was in some of last updates. O noticed a type of message spamming my Xorg log:

(EE) event24 - Logitech Gaming Mouse G400: client bug: event processing lagging behind by 18ms, your system is too slow

The only thing that changes is the time in the “by XXms”.

The reason is a change in libinput. The explanation and the change in the new version can be seen here:

In summary the solution was:

Thu Aug 20 22:50:55 UTC 2020
x/libinput-1.16.1-x86_64-2.txz: Rebuilt.
Don't complain about lag unless it exceeds 75ms.

Just to let people to know about that.


Edit: Fixed URL following tip from @Fabby.

1 Like

I suppose I need to bring this up now. Official KDE update went fine. The latest stable update has seemed to cause sudden bursts of RAM usage, consuming all of my available memory 40G (32G ddr4 + 8G swap). This happens in a matter of seconds with no initial cause that I know of. My guess is that it is firefox but the processes behaving badly are Web Content and some other web process. Total system lock, need to reboot manually. I will remember to take a picture of my top proc if I can next time it happens. No one else having something like this?

Edit: Found the problem with firefox on a web page groupme. Don’t visit it in case it locks you up, but that is the bad web page. I will see about where else to report this problem to. Take care.
“Owned by Microsoft” of course…

1 Like

Please read this:


1 Like

Thank you @Fabby!

Should I edit my post? Or should I leave as it is?

1 Like

update went well, Cinnamon, 5.4. Thanks again.


you may check with

$ lspci | grep -i renesas

if no result you are ok, if you have that hw you may use renesas fw from AUR

see here


Some remarks on the state of nvidia 450.66 drivers in KDE in combination with a thunderbolt dock and external monitor on the Thinkpad X1 Extreme gen 2. Previously the driver was unusable, because it would crash the compositor or xorg completely after suspend. With this update, on my system things are much better - I only had lockups caused by the kscreenlocker_greet process. Killing it from TTY after a suspend allowed to continue using the system normally.

I then did two more changes: included the option NVreg_PreserveVideoMemoryAllocations=1
to the Nvidia kernel module, and increased the size of /tmp, which is mounted to tmpfs in my system, to 6G, so that it is higher than the VRAM amount. After these changes, I don’t see any lockups of the kscreenlocker_greet, and no crashing of compositor or xorg, and even the chrome-based browser does not show any artefacts, which it used to before.

So the nvidia 450.66 driver is almost perfect now. However, I still have one issue: the systemsettings window after a suspend/resume cycle looks like this:

1 Like

Update went fine, but I’m having stability problems that don’t immediately manifest. It might have something to do with sleep/wake but I’m not sure yet as it’s only been 24 hours. Before the update, my uptime was around 17 days, so it was extremely stable – I put the system to sleep every night and wake it every morning. I have dual GPUs and run Windows with GPU passthrough and even that all worked pretty well. The first morning post update, chrome and brave are both core dumping during launch, take forever to launch, and the UI becomes unresponsive (keyboard and mouse) until they are both full up, which could take 30 seconds. Rebooting fixes the problem. Logs point to possible issues with nvidia drivers. I’m still on 440 – is 440 known to be having issues now with LTS 5.4 kernel?

Was another update pushed today?

1 Like

Looks like it.

New update pushed.