After installation I can only see one partition and its a read only

Hi, I have just started using linux and i installed manajaro xfce in my laptop. I installed manjaro in my ssd and everything was fine during installation. it was recognizing my 1 tb hdd and 120 gb ssd. When i had windows i partitioned this hdd into two drives (approx 200gb and rest). Now when manjaro is installed i can only see my single partition(approx 200gb one) and the other one is showing but i cant access it neither its showing its space.
can only access the drive labeled as “Work” and that too is read only, i mean i can see the contents of it but theres a lock icon on each folder.
This question maybe be silly but seriously idk how to resolve it, Please help

i did “sudo parted -i”, im attaching the output hope this helps.

Model: ATA ST1000LM035-1RK1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      17.4kB  1066kB  1049kB               LDM metadata partition
 2      1066kB  16.8MB  15.7MB               Microsoft reserved partition  msftres
 3      16.8MB  1000GB  1000GB  ntfs         LDM data partition

Model: RPFTJ128PDD2EWX (nvme)
Disk /dev/nvme0n1: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      2097kB  317MB  315MB  fat32              boot, esp
 2      317MB   128GB  128GB  ext4         root

Looks like a LDM “Dynamic Disks”, so called Windows Software Raid. No idea if it works, but here is a tool called ldmtool: Dynamic disks - ArchWiki

Anyway, it would better to convert it back to a Basis Partition for better support on Linux.

Hi @4rdpr3fect, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

From what it looks like, your 1TB only has 1x1TB partition. So I’m guessing it’s split into 2 logical partitions. So please also provide the output for:

sudo fdisk -l

Also, I see that it’s NTFS, which is probably the cause of it being read-only. So please also provide the output for:

sudo mount


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

What @megavolt said. *points up*

Thanks for the tip @Mirdarthos
Here’s the output for the commands you asked for

sudo fdisk -l

Disk /dev/nvme0n1: 119.24 GiB, 128035676160 bytes, 250069680 sectors
Disk model: RPFTJ128PDD2EWX                         
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 461ECDF4-F331-8646-9DD6-1DBA86BBE5F0

Device          Start       End   Sectors   Size Type
/dev/nvme0n1p1   4096    618495    614400   300M EFI System
/dev/nvme0n1p2 618496 250067789 249449294 118.9G Linux filesystem

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000LM035-1RK1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: B4EBF99C-FF3D-433D-BD79-0EE257CB5163

Device     Start        End    Sectors   Size Type
/dev/sda1     34       2081       2048     1M Microsoft LDM metadata
/dev/sda2   2082      32767      30686    15M Microsoft reserved
/dev/sda3  32768 1953525134 1953492367 931.5G Microsoft LDM data

Partition 1 does not start on physical sector boundary.
Partition 2 does not start on physical sector boundary.

sudo mount

proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=5055384k,nr_inodes=1263846,mode=755,inode64)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755,inode64)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/nvme0n1p2 on / type ext4 (rw,noatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,inode64)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursiveprot)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=11605)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
tracefs on /sys/kernel/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,size=5096556k,nr_inodes=1048576,inode64)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
/dev/nvme0n1p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1019308k,nr_inodes=254827,mode=700,uid=1000,gid=1000,inode64)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
portal on /run/user/1000/doc type fuse.portal (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sda3 on /run/media/shivamm/Work type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

Based on @megavolt’s answer, install ldmtool:

pamac build ldmtool

And see if there any disk groups:

ldmtool scan

I’ve never worked with this, so I don’t know if it’s necessary to use sudo:

sudo ldmtool scan
1 Like

I installed ldmtool


And how would i convert it back? any ideas. If there’s any thread or a link for me to follow it please attach it here.

I am not an expert here, but this should work on windows: Convert to Dynamic Disk | Convert Dynamic Disk to Basic Without Losing Data – EaseUS

Since it is a Manjaro Forum, there will be no Windows Support.

To see what disks are in the group:

ldmtool show diskgroup 12f76c3a-b649-11ea-9ef3-3c91806d25d4

As I mentioned, I’ve never done this, so this is purely based on the link @megavolt provided. His link to convert it back might also be a good link, I don’t have ANY idea!

seems like i’ll have to install windows merge both the partitions and then come back to manjaro. Is that what are you suggesting?

Here you go, It shows its empty

  "name" : "DESKTOP-3MEH3NQ-Dg0",
  "guid" : "12f76c3a-b649-11ea-9ef3-3c91806d25d4",
  "volumes" : [
  "disks" : [

Yeah, ldmtool on linux can ONLY read and write on these partitions. So yes. That must be done on Windows.


That seems like a viable option if nothing works

Well, unless you’ve got space to backup everything, restore/convert/change the partitioning, then restoring the backups, it might be your ONLY option, not just viable.

1 Like

Did read the wiki article btw?

sudo ldmtool create all
ls /dev/mapper/
sudo mkdir -pv /media/work
sudo mount -t ntfs-3g /dev/mapper/<LDM volume> /media/work

I tried it already idk why its says its unable to create volume volume 1 is disk group

Unable to create volume Volume1 in disk group 12f76c3a-b649-11ea-9ef3-3c91806d25d4: ldm_vol_DESKTOP-3MEH3NQ-Dg0_Volume1: Stacking NODE_DEL [verify_udev]
Unable to create volume Volume2 in disk group 12f76c3a-b649-11ea-9ef3-3c91806d25d4: ldm_vol_DESKTOP-3MEH3NQ-Dg0_Volume2: Stacking NODE_DEL [verify_udev]

Sorry, no idea then :man_shrugging:

1 Like

I installed gparted to check if its detecting my storage or not and it work perfectly fine

remove the space in the link below to see
imgur. com/a/K4LcDJq

@Mirdarthos @megavolt any thoughts on this?

:point_up_2: this…


1 Like