[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Hello community,

Another stable branch update with some usual updates for you. Also we wish you a very best 2021! Keep on rolling!


Thx to our partner Soft Maker we can offer 50% discount on their Office 2021! Checkout your license from their store!.. #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated. We removed linux57 and linux58 from our repositories. 5.9 kernel series is now marked EOL. Switch to newer kernels as needed.
  • We simplified Nvidia driver installation. This means we dropped legacy drivers. We recommend to switch over to Nouveau drivers as needed.
  • With the latest release of Mesa, we now should support RADEON RX 6800 out of the box.
  • Python 3.9 update rolled in. We hope that we managed to rebuild all needed packages by now. If you use AUR packages, we recommend to install rebuild-detector (now available in our repos) before applying this update.
  • A lot of KDE-git packages got updated
  • Pamac updated to v10.0.3
  • Firefox got another beta release
  • Nvidia legacy driver got updated to 390.138.
  • Some Deepin packages got renewed
  • Qt6 got added to our repos.
  • KDE Apps are now at their December Release
  • KDE Frameworks got updated to 5.77.0
  • Libreoffice is now at 7.0.4
  • More Cinnamon and Deepin updates
  • Gstreamer got updated
  • Haskell and other regular upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2.1 release! KDE, XFCE and Gnome


Our current supported kernels

  • linux44 4.4.248
  • linux49 4.9.248
  • linux414 4.14.212
  • linux419 4.19.163
  • linux54 5.4.85
  • linux59 5.9.16 [EOL]
  • linux510 5.10.2
  • linux54-rt 5.4.82_rt45
  • linux59-rt 5.9.1_rt19

Packages Changes (Mon Dec 21 23:55:35 CET 2020)

  • stable community x86_64: 3820 new and 3818 removed package(s)
  • stable core x86_64: 76 new and 91 removed package(s)
  • stable extra x86_64: 1317 new and 1437 removed package(s)
  • stable multilib x86_64: 48 new and 60 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

31 Likes
Latest update -> No nVidia -> How to install? I'm confused
Drivers removed
Manjaro KDE stable: sddm leaving system without a graphical interface
[Stable Update] 2020-12-30 and systemd 247: a new error - cgroups related - appeared in the log
Primary mouse button problem after update
Can't boot to GUI
Probleme mit Xorg?
Manjaro runs sluggish after update to kernel 5.10.2
Failed to start light display manager, tried basic forum posts
My switch to the 5.10 kernel with update 2020-12-30
No hybrid amdgpu nvidia drivers in mhwd after upgrade
Nvidia GPU does not work, only integrated graphics
New NVIDIA drivers are not available in mhwd after update
Problems with new Manjaro update and nvidia
Lots of errors when updating kernel to 5.10 (Error while configuring manjaro-system and more)
Laggy Xorg functions + High Xorg CPU Usage with DISTRIB_RELEASE=20.2.1
Dropping all legacy and older Nvidia drivers ?!?
Can't use my bash prompt powerline shell customization broken after current update
[need help] rkhunter warning: hidden file /usr/share/man/man5/.k5login.5.gz & .k5identity.5.gz
[Support/How-To] Compile old/legacy Nvidia Proprietary Drivers [2020-12-30 Update Issue]
Only partial screen update after last stable update [2020-12-30]
Only Manjaro 5.9 available after unintentional update
Shortwave 1:1.1.1-6 does not build
Stange flickering of the whole session, and periodic dimming of the display's backlight: Acer nitro 5 (ryzen 4000 + nvidia)
Ich habe ein Problem mit dem offenen Grafiktreiber
No sound after fresh install

Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


Older Issues

Please click the ► at the beginning of this line to view the older issues

CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

xf86-video-intel already exists in filesystem errors

Please click the ► at the beginning of this line to view this solution

If you get something like this:

error: failed to commit transaction (conflicting files)
xf86-video-intel: /usr/bin/intel-virtual-output exists in filesystem
xf86-video-intel: /usr/lib/libI810XvMC.so exists in filesystem
...
xf86-video-intel: /usr/share/man/man4/intel.4.gz exists in filesystem
xf86-video-intel: /usr/share/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy exists in filesystem
Errors occurred, no packages were upgraded.

Just delete the files that are in conflictand perform the upgrade again.

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

11 Likes

Just updated using pacman from latest EOL 5.8 kernel from basically a fresh stable install of Manjaro 20.2. The installer replaced my kernel with 5.9 and tossed out 450.x Nvidia drivers with newe ones. Thought it will be all fine, but now KDE Plasma does not seem to load, black screen. I can however Ctrl+Alt+F2 and access the terminal. Any suggestions? Other times when I would encounter stuff like this with Manjaro, I would just do a fresh install. But am now compelled to fix things. Suggestions are greatly appreciated. And Happy New Year!

2 Likes

I have a issue
linux-latest and linux58 are in conflict

I am running 5.9

2 Likes

We dropped support of 450xx series. Seems 455xx doesn’t support your card. What does mhwd in a terminal say?

linux-latest will remove linux58 as it got dropped from our repositories. linux-latest will also install linux510.

4 Likes

had an issue, because i had old nvidia stuff installed, i needed to manually remove the old nvidia drivers, and then install nvidia-utils (replacing nvidia-utils-455xx), and then i could install the new linux-nvidia drivers from the manjaro settings

2 Likes

I’m a little confused.

We simplified Nvidia driver installation. This means we dropped legacy drivers.

vs

Nvidia legacy driver got updated to 390.138 .

While dropping Nvidia legacy drivers, a legacy driver got updated?!
How long will this legacy driver work?

1 Like

As far as I know, this is not correct. Last time nvidia dropped support for older cards was with the transition from the 390 -> 418 driver. 418 - 455 do all support the same cards (455 supports also newer ones but also all the older ones 418 supported).

Most likely this is an issue with the transition from the old mhwd profiles to the new nvidia profile.
Also had missing packages when I did the transition on testing some while ago.

As long as the driver is supported by newer kernels. It was hard to find a patch for 5.10 kernel series. For upcoming 5.11 kernel series there is not yet a patch. So it can be weeks or few months. 5.11 will be released early Spring.

2 Likes

If I try to remove I got:
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58 breaks dependency ‘linux58’ required by linux58-nvidia-430xx

Thanks for clarification.

Keep up that good work :slight_smile:

1 Like

Remove both packages before you do the update.

3 Likes

You have to remove all modules of the old linux58 kernel with it.
In your case, try:
sudo pacman -R linux58-nvidia-430xx linux58

1 Like
mhwd-kernel -r linux58

should take care of this.

1 Like
Warning: config '/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG' is invalid!
video-nvidia 2020.11.30

Perhaps I can switch to video-linux for now? And then fix things from there?

hmm…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58-nvidia-430xx breaks dependency ‘linux58-nvidia-430xx’ required by linux-latest-nvidia-430xx
what to do now

It can be, as not all combinations are supported anymore. However for 455xx Nvidia drivers we have now these packages:

core/mhwd-nvidia 455.45.01-3
extra/linux[xxy]-nvidia 455.45.01-X
extra/nvidia-utils 455.45.01-2
extra/opencl-nvidia 455.45.01-2
multilib/lib32-nvidia-utils 455.45.01-3
multilib/lib32-opencl-nvidia 455.45.01-3

opencl is optional. manjaro-system should take care of the mhwd profiles, if it finds a valid one.

also remove the linux-latest packages with it. Try:

sudo pacman -R linux58-nvidia-430xx linux58 linux-latest-nvidia-430xx linux-latest

You can install the linux-latest metapackages after the update again if you want to use them.

1 Like

Your output can something like this:

[phil@development Schreibtisch]$ mhwd
> 0000:26:00.0 (0300:10de:0fc6) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:22:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI

The top driver should be the latest supported on your end. Also check if some packages are missing.

I’ve got this message:

Warnung: /root/.zshrc installiert als /root/.zshrc.pacnew

But /root/ is locked, so I cannot edit the /root/.zshrc. What to do?