Stange flickering of the whole session, and periodic dimming of the display's backlight: Acer nitro 5 (ryzen 4000 + nvidia)

1 Like

Internal screen is probably the AMD, so can you try 2 things:

  1. Install kernels 5.4 LTS and 5.9
  2. If the above didn’t change anything, try the same frequency as the external monitor: 60Hz and the highest resolution I can find that has the same frequency is 1440x810 60Hz.

You unplugged the external monitor from the power socket, right? (HDMI connection doesn’t matter)

This is a weird problem.

  1. On 54, sddm fails to start, systemctl status: sddm crash linux54 -
    On 59, the problems are the same as 58.
  2. when I try to set the refresh rate of the laptop display (after boot when the external display is connected it is already set to 60hz [IIRC that’s because Xorg can’t mix refresh rates? is that right?]) when I set it up to 144 nothing seems to happen, but when I set it back down to 60hz it gets messed up: Imgur: The magic of the Internet
    the second monitor is not messed up, and I can use t to set the laptop display back up to 144hz, that fixes it
    although I suspect it’s lying and when it says 144, it’s not actually 144, at least when the external monitor is connected.
    When I tried to change the resolution of the laptop display it just turned off, and I needed the second monitor to disable and then re-enable the laptop display in KDE’s Display settings.

the flickering is sill there after changing the refresh rates about.

I did unplug the second monitor from the power outlet yes.

One last favour and then I’m all out of ideas:

  • Create a new user
  • log in there
  • see if it happens there too.


Yeah that didn’t work unfortunately
It also happens there, as well as sometimes sddm.

1 Like

I’m throwing my hands in the air, my apologies I’ve been of absolutely no help…

:sob: :man_shrugging:

thanks for trying anyway.
Maybe someone else has a clue

1 Like

There has been a development

I have discovered that turning the screen off and then back on again with

xset dpms force off
xset dpms force on

fixes the issue, but this has to bee done every time it starts flickering, so after most reboots, and after closing and opening the laptop; so this is a relatively good workaround, at least no more rebooting sagas are needed to get it working.

Also, I just updated to the latest stable update ([Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin), but that did not resolve it unfortunately.

1 Like

Try setting your “close lid” action to “nothing” because that sounds like that button malfunctioning…


Hello, I just got the same laptop, and the same situation happens to me, I’m using XFCE. I noticed that, when the laptop it’s working on battery mode, the flickering and dimming stops. Does this happens to you too? maybe it’s a power management thing.

another thing off topic, did you manage to update the bios?. when it starts. the acer screen stays longer than before installing linux, sometimes in the loggin screen I type the password, hit enter, and the loggin appears again, blank. wierd.

sometimes in the loggin screen I type the password, hit enter, and the loggin appears again, blank. wierd.

Exactly the same problem on my Acer Nitro 5 AN515-44! If you can find a solution, please text it to me, too :blush:
Although if I have some free time - I’m going to create a new topic for this problem with login.

For me running from the battery does not appear to stop the blinking unfortunately.

I did not know there was a BIOS update until now, so I haven’t tried it, but as far as I know these .exe BIOS updaters don’t go down well on linux, but correct me if I’m wrong on this.

I have figured out however, that the acer screen is shown while the GRUB bootloader waits out it’s 10 second timer, and can be shown by pressing esc on the acer screen, where you can boot other installed kernels for example. you can change the 10 second wait time, I have set it ti 1 second, so if I need GRUB I can still get to it, without wasting 9 seconds doing nothing;

If I remember correctly I changed a line in /etc/default/grub




then did a

sudo update-grub

Unfortunately this didn’t work either

I have since discovered, that turning the screen on and off, like I described above, when it is working correctly, makes it not work correctly, and it exhibits the same behaviour as when I described in the first post.
Turning the screen off/on repeatedly once again, fixes it after 1-3 tries.

Hello. I tried other kernels, and the issue stays the same, sometimes the laptop is ok, but when de screen is off and then back on, or when it’s on battery, and plugged in to the charger, the flickering appears… looks like there’s nothing else to do right now.

By the bios front, the update doesn’t fix the flickering, already tried, installed the latest but nothing.

I tried turning the screen on and off, but the flickering stays the same, but I noticed that, when I press Ctrl Alt F2 for tty, the flickering stops…i dont know what it means.

I sometimes have to repeatedly turn the screen on/off, usually by the third try it stops flickering

For me switching to another tty acts like turning he screen on/off does, if it was flickering, sometimes is stops it, if it was not, the it will likely start flickering again on the tty.

Hello, I just couldn’t let this go, so I followed steps 4 and 7 of this tutorial. [HowTo] Install Manjaro on the ASUS TUF FX505DY / FX705DY with Ryzen / Radeon combo in point 7 says something about variable refresh, I applied those changes, and so far the laptop stopped showing the flickering. maybe this could work for you too.

Unfortunately for me, the the sleep / hibernation fix seems to have done nothing, but since the last (or the one before that? I can’t remember) is was not that broken, the only issue seems to be that firefox gets messed up, but that may have to do something with the custom userChrome.css I have, as well as latte-dock not behaving very well after waking up from sleep, e.g. it only shows up on the external monitor.

For the flickering, because I use optimus-manager to be able to switch between integrated and nvidia only modes, placing that file there does nothing, as optimus-manager removes it; however I did try setting triplebuffer and switching to the amdgpu driver, as well as turning on the tearfree option with optimus-manager, but neither fixed it.

The [Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1 using the 5.10 kernel seems to have resolved the flickering issue. (using 59 the flickering returns)

It took some work to get everything working though:

  • I have completely removed any nvidia related packages, then did the update, then installed the new rolling nvidia driver (with mhwd), because without uninstalling them, pacman did not let me just straight update from 455xx to the rolling driver.
  • I also had to reinstall optimus-manager (I use the AUR package, so I just cleanbuilt it with yay)
  • Also applied the fix for the black screen issue on AMD GPUs, see the above linked forum post for more details, I just followed the instructions in the forum post:

For now everything seems to be working fine, and (on kernel 510) the screen flicker and backlight blinking is gone.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.