[Stable Update] 2023-06-04 - Kernels, Gnome 44.1, Plasma 5.27.5, Python 3.11, Toolchain, Firefox

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-06-04

DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.


All initramfs builds fail with ERROR: Hook ‘zfs’ cannot be found

There was an issue with zfs-utils 2.1.11-1 package having the initcipio files wrongly installed. Please update to zfs-utils 2.1.11-1.1 and re-run mkinitcpio -P. If you have an already unbootable system, you may recover by using an install media and chroot into it to complete the update.


xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11

A bug report was opened on 468217 – xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11 and a temporary fis is also mentioned on Mouse acceleration - ArchWiki

Widgets on Plasma desktop are lost after update


GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators. You have to redo that whenever you update a kernel or call update-grub on your own. You can read more about it here
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key. This happens if you forgot to remove the dashes in /boot/grub/grub.cfg after update-grub got called.

We may add a alpm-hook to grub package to do that monkey job for you automatically. As an alternative you may reinstall grub, as the newer version can handle both cases, including the dashes.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. 217174 – Plugging in usb external drive, mount and umount causes kernel Oops Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


we have a bug with this last version 23.04.1-1 : dolphin does not remember open tabs
fixed with 23.04.1-2 in unstable

[TIPS] With this new systemd 253 :

A new LogFilterPatterns= option has been added for units. It may be used to specify accept/deny regular expressions for log messages generated by the unit, that shall be enforced by systemd-journald.
Rejected messages are neither stored in the journal nor forwarded. This option may be used to suppress noisy or uninteresting messages from units.
If the first character of the pattern is “~”, log entries matching the pattern should be discarded. This option takes a single pattern as an argument but can be used multiple times to create a list of allowed and denied patterns.

For example:

# /etc/systemd/system/user@.service.d/30-journalfilter.conf
# no save messages with :
1 Like

After applying update, my shell was BASH.
To get back with ZSH:

type -a zsh ## find path to zsh
chsh -s /usr/bin/zsh ## change bash to zsh

See https://www.cyberciti.biz/faq/change-my-default-shell-in-linux-using-chsh/.

Note that default font color is not green anymore but white.
Just switch to “Breath” profile in Konsole and set it by default to get your colors back.


Update went smoothly. I had some Python 3.10 packages that needed rebuilding. A couple of notes:

  • rebuild-detector was not installed: I have a many years old install, so I installed it
  • the python-pep517 package that was installed was not found anymore, so I uninstalled it as it had no dependencies… I’ll see if anything breaks

Starting Firefox and LibreWolf suddenly takes a very long time. Like 30 seconds to 1 minute. Used to be a couple of seconds. Chromium starts pretty much instantly as before.

Edit: Okay, so I probably really needed the coffee. The workaround mentioned above under the known issues and solutions (replacing xdg-desktop-portal-gnome with xdg-desktop-portal-gtk) worked for my Cinnamon gtk-based desktop. Thanks @philm for reminding me to read the troubleshooting post.

Previous detailed problem report

Once started Firefox and LibreWolf work normally, no slowdowns. Also, when already running, new windows/tabs are normal speed. It’s just starting the application when it is not yet running that is very slow after the update.

Update: confirmed with a second updated Manjaro install (laptop) that launching Firefox is now very slow.

Firefox gives no output when starting from the terminal, LibreWolf says:

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found. (t=25.3851) [GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
[ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0))
[Child 27338, Main Thread] WARNING: JSWindowActorChild::SendRawMessage (Conduits, ConduitClosed) not sent: !CanSend() || !mManager || !mManager->CanSend(): file /root/.local/share/bsys6/work/librewolf-113.0.2-1/dom/ipc/jsactor/JSWindowActorChild.cpp:57

No idea if that is related.

My inxi output
  Host: bliep Kernel: 6.3.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.1 Desktop: Cinnamon v: 5.6.8 tk: GTK v: 3.24.37 vt: 7 dm: LightDM
    v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: Inspiron 660 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0XR1GT v: A00 serial: <superuser required> UEFI: Dell
    v: A13 date: 05/22/2018
  Info: quad core model: Intel Core i5-2320 bits: 64 type: MCP
    smt: <unsupported> arch: Sandy Bridge rev: 7 cache: L1: 256 KiB L2: 1024 KiB
    L3: 6 MiB
  Speed (MHz): avg: 1597 min/max: 1600/3300 cores: 1: 1597 2: 1597 3: 1597
    4: 1597 bogomips: 23965
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel arch: Gen-6 ports: active: none
    empty: DP-3,HDMI-A-3,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0102
    class-ID: 0380
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-4 pcie: speed: 5 GT/s
    lanes: 16 ports: active: DP-2,HDMI-A-2 empty: DP-1,DVI-D-1,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 51.0 C
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu,modesetting
    alternate: fbdev,vesa dri: radeonsi,crocus gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1016x317mm (40.00x12.48")
    s-diag: 1064mm (41.9")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: right model: Dell E248WFP
    serial: G274H87O20CS res: 1920x1200 hz: 60 dpi: 94
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") modes: max: 1920x1200
    min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-A-1 pos: primary,left
    model: Samsung SMS24A450 serial: H4MC801052 res: 1920x1200 hz: 60 dpi: 94
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") modes: max: 1920x1200
    min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 580 Series
    (polaris10 LLVM 15.0.7 DRM 3.52 6.3.5-1-MANJARO) direct-render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  API: ALSA v: k6.3.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: sndiod v: N/A status: off
  Server-2: JACK v: 1.9.22 status: off
  Server-3: PipeWire v: 0.3.70 status: off
  Server-4: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Dell
    driver: ath9k v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 168c:0032 class-ID: 0280
  IF: wlp3s0 state: down mac: a6:6a:b9:04:60:85
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: d4:be:d9:df:1c:f4
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 2-1.1:3
    chip-ID: 0b05:17cb class-ID: fe01 serial: 5CF370A3C2BF
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: 5C:F3:70:A3:C2:BF
  Local Storage: total: 763.85 GiB used: 609.57 GiB (79.8%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s tech: SSD serial: S3Z2NB1K357906P fw-rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb vendor: Western Digital model: WD3200AAJS-56M0A0
    size: 298.09 GiB speed: 3.0 Gb/s tech: N/A serial: WD-WCAV2W546492
    fw-rev: 3E01 scheme: MBR
  ID-1: / size: 456.88 GiB used: 347.65 GiB (76.1%) fs: ext4 dev: /dev/dm-0
    mapped: cryptroot
  ID-2: /boot size: 511 MiB used: 250.8 MiB (49.1%) fs: vfat dev: /dev/sda1
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): cpu: 492 mobo: 1016 gpu: amdgpu fan: 1151
  Processes: 255 Uptime: 17m wakeups: 0 Memory: available: 15.49 GiB
  used: 3.15 GiB (20.4%) Init: systemd v: 253 default: graphical Compilers:
  gcc: 13.1.1 clang: 15.0.7 Packages: 1747 pm: pacman pkgs: 1737 pm: flatpak
  pkgs: 10 Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.27

Thanks @philm , but where is that new release 23.0 Ultima Thule? It doesn’t appear in download section?
and by the way the news in telegram channel is very poor!
Thanks again

1 Like

is in testing (xdg-desktop-portal-gnome bug) but not here ?

Update went smoothly but now my Logitech mouse is moving reaaaaly slow in plasma desktop :confused:


What is the point of a stable branch if bugs successfully reach it? :thinking: :thinking: :thinking:


zsh is broken
Since the profile has changed, have to switch to the old one

1 Like

that python guide is ridiculously complex, what are my chances if i just run the update, and re-install all packages i use?

we can easily bypass it ! we can change a package for another :wink:

for zsh is in post #4 (edit: or ok for use old profil)

1 Like

Yes, there might be slow starts of applications when a certain package got installed as dependency. See troubleshoots for help.

1 Like

It’s useful if you have too many (AUR and pip) packages to remember.

No problem.
If you have so few python (AUR and pip) packages you can remember them all, that’s the easy way.

EDIT: added “(AUR and pip)”


Will be a fix for zsh, or will stay as it is??
I dont see speed issues so far

It doesn’t fix Dolphin

1 Like

I changed the text a little to hopefully make it clear that the guide is for 3rd party packages like from the AUR. With the system update regular packages provided by use have been updated against python 3.11 already.

@philm Any chance that dolphin 23.04.1-2 will be brought in soon?

@papajoke Thanks for the warning.
I keep about 24 Dolphin windows open, across 6 desktops,
with about 10 tabs in each, and they re-open automatically when I log on.

It’s how I easily find the various things I’m working on,
coz I couldn’t figure out how to use KDE tools that say they do this kind of thing. :wink:

That is why we have the testing branch and rely on community feedback. Some issues only get detected in the stable branch as more people use it. The dolphin issue should been fixed with dolphin-23.04.1-1.1. Regarding ZSH we are still working on a proper fix.


But these are noticeable, albeit minor, bugs in popular applications :melting_face:

1 Like

I am experiencing problems with tuxedo-control-center especially its dkms kernel modules with gcc version 13:

DKMS make.log for tuxedo-keyboard-3.2.3 for kernel 5.15.114-1-MANJARO (x86_64)
So 04 Jun 2023 10:13:29 CEST
make -C /lib/modules/5.15.114-1-MANJARO/build M=/var/lib/dkms/tuxedo-keyboard/3.2.3/build modules
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 12.2.1 20230201
  You are using:           gcc (GCC) 13.1.1 20230429
  CC [M]  /var/lib/dkms/tuxedo-keyboard/3.2.3/build/./src/clevo_wmi.o
  CC [M]  /var/lib/dkms/tuxedo-keyboard/3.2.3/build/./src/tuxedo_keyboard.o
  CC [M]  /var/lib/dkms/tuxedo-keyboard/3.2.3/build/./src/clevo_acpi.o
  CC [M]  /var/lib/dkms/tuxedo-keyboard/3.2.3/build/./src/tuxedo_io/tuxedo_io.o
  CC [M]  /var/lib/dkms/tuxedo-keyboard/3.2.3/build/./src/uniwill_wmi.o
cc1: error: cannot load plugin ./scripts/gcc-plugins/structleak_plugin.so: ./scripts/gcc-plugins/structleak_plugin.so: undefined symbol: tree_code_type
cc1: error: cannot load plugin ./scripts/gcc-plugins/structleak_plugin.so: ./scripts/gcc-plugins/structleak_plugin.so: undefined symbol: tree_code_type
cc1: error: cannot load plugin ./scripts/gcc-plugins/structleak_plugin.so: ./scripts/gcc-plugins/structleak_plugin.so: undefined symbol: tree_code_type

Maybe this is related to:

I installed the previous gcc-12 and tried to install the dkms kernel modules again with:

export CC=gcc-12
dkms autoinstall

But it also failed with the same error as before.

Does anybody know how to switch the gcc-version for dkms make?