Very slow startup on some apps after update

After the last major update of Manjaro on June 4th, some of the applications in Manjaro Xfce, such as Firefox, LibreOffice, Thunderbird, etc., started up very slowly. In my case, the solution was to uninstall the package “xdg-desktop-portal-gnome”. Every time there is a major update, I tremble


Confirming. Exact same issue with Firefox and LibreOffice. Additionally, Steam failed to start at all.

Could you elaborate on how/why the package you uninstalled works (for posterity)? It did the trick for me as well.

The posterity is that its been mentioned in the release announcement.

(flagged in unstable a while ago … so technically its been in Testing Announcements, etc too)

Every release since 28 days ago.


I did other thing. I didn’t remove the file but update the whole system without it and everything works fine. Thank you for your post!

Thanks for your concise and effective solution to a very major problem. Xfce has been my DE for a long time and it usually works just fine.
I’m not a tech who wants to spend hours tinkering with my OS. However, I did spend a lot of time reading other posts, about this problem but all they did was to confuse the issue.
Curiously why do all these DE ship with gnome? And now that I have installed gtk will I have to do further manual remove and install when updating?

Thanks for this extremely useful post.

I had the same problem at Mabox. I solved it the same way

I was about to reinstall Manjaro until I noticed the same problem on another machine, which led me to this thread. Thanks for saving me a lot of time.

In my case Telegram loaded incredibly slowly (both the standalone executable and telegram-desktop).

1 Like

TQ for the tip which worked.

Before this, I noticed that LibreOffice started up quickly as normal (within 3 seconds) when launched from the Terminal, but super slow when launched from the desktop (up to 50 seconds).

Firefox load time was about 40 seconds. Using XFCE. Fixed now, thanks.

1 Like

After so many “thanks” replays I have to say that this was not the wright solution for me. The new fresh install of Manjaro 23.0.0 KDE is very slow and the command

sudo pacman -Rdd xdg-desktop-portal-gnome

returns :

"error: target not found: xdg-desktop-portal-gnome" , 

e.g. the package is even not installed on KDE and:

sudo pacman -S xdg-desktop-portal-kde 

only reinstall the package witch was properly installed before. Obviously that is not the case of fresh installed KDE and therefore not the solution.So I am still looking for an answer.

1 Like

Likely its not the same issue then.
If its a new install … let the index finish. Otherwise … gather info and create a new thread.

Thanks a ton for saving me, I’m about to give up Manjaro for Arch

I updated today
I have the same slow speed with some programs

And did you follow the instructions attached to any of these 987987 redundant posts?

1 Like

According to the related explanations, after uninstalling xdg-desktop-portal-gnome, the problem was solved

For me it was LibreOffice, went to LibreOffice, then to the gnome bug, and finally to here where there was a sensible solution.

Evince and Firefox were issues for me using XFCE4 Session with i3. This workaround fixed it. Thanks!

That’s funny–seeing how this was an upstream issue and Arch users also had the same problem…