[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

Hello community,

Another stable branch update with some usual updates for you.

Please read our Security Advisory regarding pacman signing keys!

  • Most of our Kernels got updated
  • Systemd is now at 248.3
  • Gnome Apps got updated to 40.2
  • Cutefish DE got updated to v0.2
  • Pipewire is at 0.3.30
  • Deepin got some new updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Download 21.0.7

Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)


Our current supported kernels

  • linux44 4.4.271
  • linux49 4.9.271
  • linux414 4.14.235
  • linux419 4.19.193
  • linux54 5.4.124
  • linux510 5.10.42
  • linux511 5.11.22 [EOL]
  • linux512 5.12.9
  • linux513 5.13-rc5
  • linux510-rt 5.10.35_rt39
  • linux511-rt 5.11.4_rt11

Package Updates (Tue Jun 8 14:45:36 CEST 2021)

  • stable community x86_64: 1760 new and 1752 removed package(s)
  • stable core x86_64: 40 new and 40 removed package(s)
  • stable extra x86_64: 433 new and 590 removed package(s)
  • stable kde-unstable x86_64: 384 new and 383 removed package(s)
  • stable multilib x86_64: 37 new and 44 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • You might be blocked updating when using pacman due to some libcanberra packages. Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

  • linux49 nor linux419 seems not to boot with systemd 248. We have to look into that matter. See also upstream issue and here. Update: systemd 248.3-3 is able again to boot linux419. Someone has to confirm if linux49 also boots, or if it is a total different issue. Update2: the issue with linux419 got identified and fixed in our unstable branch. It was an added AUFS4 patch by mistake with 4.14.133-2 kernel 10 months ago.

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • Some Nvidia cards don’t work with the current 465.31 drivers when used with Display Port and/or 4k Monitors. More about the issue at the Nvidia Developer Forum. We recommend to switch to Nouveau driver as needed. If you however need the Nvidia driver, you can get the PKGBUILDs of the 460.73.01 version and build your driver locally with makepkg or use the pre-compiled packages: nvida-utils, dkms and lib32 + precompiled .

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

GDM does not start (black screen when booting gnome edition)

Log into your system via tty and depending on your use of Plymouth or bootsplash-systemd choose a option from this post

Update: Pamac OR Pacman and which command?
Libcanberra related dependencies prohibit update
Can't get Manjaro to update using pacman -Syu
Update Error on System Update
Resolve dependencies conflicts using pacman
[Stable-Staging Update] 2021-06-13 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell
Can't update my os
Can't update system
Pacman fails to update manjaro due to libcanberra
Libcanberra 0.30+2
Libcanberra 0.30+2
Pacman -Syu 更新出错
System will not let me update
Having trouble updating my system
Error: Unable to prepare transaction (dependency cannot be satisfied) :: install libcanberra (0.30+2+gc0620e4-4) Depends on 'libcanberra=0.30+2+gc0620e4-3' (required by libcanberra-gstreamer)
Manjaro update/ upgrade fails
Manjaro update/ upgrade fails
Dependency issue
Version `GLIBC_2.33' not found (required by pacman)
How to fix broken KDE Desktop (Qt)
Can't get Manjaro to update using pacman -Syu
Issue with Signature from Mega. DEB_Arch_Extra fails to update
Can't update my system due to a missing PGP key
Stuck in [Stable Update] 2021-06-14 because it won't accept NO as decision
Actualización de sistema
Pamac GUI search enhancement
System upgrade breaks dependency
Can't upgrade the system
How to fix "Failed to start Load Kernel Modules" error and complete full system upgrade?
Breaking dependentcy missing libcanberra=0.30+2+gc0620e4-3 ,on new install?
Hide unwanted updates
Problem upgrading
Trying to update Manjaro but failed due to package dependency
Usual trick to fix pacman (could not satisfy dependencies)

I was wondering what those key revocations was about the other day…

Damn, seems in the past 24 months the amount of hacks, severe vulnerabilities, bugs and attacks has been out of control. Polkit was vulnerable too.

Am I right in believing that simply having manjaro-system up to date is enough and the ‘workaround’ portion of that advisory isn’t required for the end-user now?

I am getting a dep error on this update though.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

Edit: Resolved by removing lib32-libcanberra-gstreamer and libcanberra-gstreamer packages.


Yes: either you update the package or you apply the workaround.
The package update will apply the same commands as laid out in the workaround, see


I’m getting the same dependency error.

1 Like

I got this problem


@medmedin @Akezhar @BusinessOrc Simply upgrade with Pamac.

1 Like

That message is from pamac :slight_smile:


I first tried to update with sudo pacman -Syu, but it gave me a message (sadly didn’t make a note) and refused to update. I then just sudo pamac update and it updated my system properly.

If I am correct, this is the message I had (looking in my /var/log/pacman.log:

[2021-06-14T13:47:11+0200] [ALPM] removed lib32-libcanberra-pulse (0.30+2+gc0620e4-3)
[2021-06-14T13:47:11+0200] [ALPM] removed libcanberra-pulse (0.30+2+gc0620e4-3)
[2021-06-14T13:47:11+0200] [ALPM] removed libcanberra-gstreamer (0.30+2+gc0620e4-3)
[2021-06-14T13:47:11+0200] [ALPM] removed lib32-libcanberra-gstreamer (0.30+2+gc0620e4-3)

But after updating with pamac, it works.


I had the same lib32-libcanberra/libcanberra warning. Pamac suggested some changes to proceed. The update resulted in a kernel panic message on reboot.

It’s the first broken system after an update in like five or six years, so i guess it’s ok for me. Can i fix it or it’s better to format and make a new installation?

1 Like

Did you mean pamac?

1 Like

Yes, it’s a typo. I will edit the post.

Get the same dependency error:

 :: Starting full system upgrade...
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] Y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

I tried again by denying the replacement:

 :: Starting full system upgrade...
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] n
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] n
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-pulse
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-pulse

I am not able to boot my system anymore after the update to kernel 5.4.124.

See attached image.

Unfortunately it did not seem to keep my old kernel in grub’s boot menu, so I cannot resolve this by simply booting 5.4.123 from grub.

What can I do? Chroot into the system for a start? I am not too accustomed to doing those things yet, so any help is greatly appreciated.

1 Like

Also had the kernel panic issue, found the solution here.

Edit: For all the people not that familiar with this stuff:

  1. Boot a live USB Manjaro (download and “burn” that on any working computer)
  2. start terminal
  3. run sudo -s to be root
  4. run manjaro-chroot -a
  5. edit /etc/mkinitcpio.conf as shown in the link
  6. run mkinitcpio -P
  7. exit chroot and reboot

Tried pamac; not working either:

sudo pamac upgrade
Warning: Building packages as root
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...
Warning: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
Add lib32-libcanberra-gstreamer to remove
Warning: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer
Add libcanberra-gstreamer to remove
Resolving dependencies...
Checking inter-conflicts...

To upgrade (139):
  alsa-card-profiles           1:0.3.30-1         (1:0.3.28-1)         extra      32.2 kB
  alsa-topology-conf           1.2.5-1            (1.2.4-2)            extra      13.8 kB
  alsa-ucm-conf                1.2.5-1            (1.2.4-2)            extra      46.0 kB
  alsa-lib                     1.2.5-2            (1.2.4-3)            extra      483.1 kB
  alsa-plugins                 1:1.2.5-2          (1:1.2.2-2)          extra      79.5 kB
  alsa-utils                   1.2.5-3            (1.2.4-2)            extra      1.2 MB
  libxcrypt                    4.4.22-4           (4.4.20-1)           core       90.6 kB
  pambase                      20210605-2         (20200721.1-2)       core       3.1 kB
  util-linux-libs              2.37-3             (2.36.2-1)           core       421.2 kB
  systemd-libs                 248.3-2            (247.7-1)            core       573.8 kB
  libx11                       1.7.2-1            (1.7.1-1)            extra      2.2 MB
  at-spi2-core                 2.40.2-1           (2.40.1-1)           extra      266.2 kB
  boost-libs                   1.75.0-5           (1.75.0-3)           extra      2.5 MB
  ca-certificates-utils        20210529-1         (20181109-4)         core       8.1 kB
  ca-certificates              20210529-1         (20181109-4)         core       2.0 kB
  libgusb                      0.3.7-1            (0.3.6-1)            extra      66.7 kB
  cryptsetup                   2.3.6-1            (2.3.5-4)            core       
  libelf                       0.185-1            (0.184-1)            core       481.4 kB
  util-linux                   2.37-3             (2.36.2-1)           core       2.6 MB
  libnftnl                     1.2.0-1            (1.1.9-1)            core       71.1 kB
  nftables                     1:0.9.9-1          (1:0.9.8-1)          extra      343.9 kB
  systemd                      248.3-2            (247.7-1)            core       6.6 MB
  js78                         78.11.0-1          (78.10.1-1)          extra      11.0 MB
  polkit                       0.119-1            (0.118-1)            extra      476.4 kB
  colord                       1.4.5-4            (1.4.5-1)            extra      1.8 MB
  poppler                      21.06.1-1          (21.05.0-1)          extra      1.4 MB
  poppler-glib                 21.06.1-1          (21.05.0-1)          extra      261.9 kB
  colord-sane                  1.4.5-4            (1.4.5-1)            extra      8.7 kB
  dialog                       1:1.3_20210530-1   (1:1.3_20210509-1)   core       202.7 kB
  elfutils                     0.185-1            (0.184-1)            core       565.8 kB
  librsvg                      2:2.50.7-1         (2:2.50.6-1)         extra      2.6 MB
  libedit                      20210522_3.1-1     (20210419_3.1-1)     core       111.8 kB
  llvm-libs                    12.0.0-1           (11.1.0-1)           extra      25.6 MB
  mesa                         21.1.2-1           (21.1.2-0)           extra      18.4 MB
  libogg                       1.3.5-1            (1.3.4-2)            extra      204.0 kB
  libcanberra                  0.30+2+gc0620e4-4  (0.30+2+gc0620e4-3)  extra      93.7 kB
  gtk-update-icon-cache        1:4.2.1-2          (1:4.2.1-1)          extra      17.5 kB
  nettle                       3.7.3-1            (3.7.2-1)            core       434.9 kB
  gnutls                       3.7.2-1            (3.7.1-1)            core       3.0 MB
  gtk3                         1:3.24.29-2        (1:3.24.29-1)        extra      7.9 MB
  epiphany                     40.2-1             (40.1-1)             extra      5.3 MB
  gnome-desktop                1:40.1-2           (1:40.1-1)           extra      559.4 kB
  evince                       40.1-2             (40.1-1)             extra      2.5 MB
  evolution-data-server        3.40.2-1           (3.40.1-1)           extra      4.7 MB
  gnome-autoar                 0.3.3-1            (0.3.2-1)            extra      68.2 kB
  evolution                    3.40.2-1           (3.40.1-1)           extra      11.4 MB
  gsl                          2.7-1              (2.6-2)              extra      1.7 MB
  evolution-bogofilter         3.40.2-1           (3.40.1-1)           extra      12.5 kB
  evolution-spamassassin       3.40.2-1           (3.40.1-1)           extra      13.0 kB
  python-idna                  3.2-1              (3.1-1)              extra      85.5 kB
  webrtc-audio-processing      0.3.1-3            (0.3.1-2)            extra      316.7 kB
  pipewire                     1:0.3.30-1         (1:0.3.28-1)         extra      1.8 MB
  libmm-glib                   1.16.6-1           (1.16.4-1)           extra      447.0 kB
  flatpak                      1.11.1-2           (1.11.1-1)           extra      1.5 MB
  git                          2.32.0-1           (2.31.1-1)           extra      6.1 MB
  gnome-disk-utility           40.1-2             (40.1-1)             extra      1.1 MB
  grub                         2.06-1             (2.04-22)            core       15.5 MB
  gupnp                        1.2.7-1            (1.2.6-1)            extra      168.0 kB
  imagemagick                (        extra      2.7 MB
  imath                        3.0.4-1            (3.0.3-1)            extra      4.2 MB
  inetutils                    2.0-1              (1.9.4-9)            core       353.6 kB
  lib32-alsa-lib               1.2.5-2            (1.2.4-2)            multilib   396.6 kB
  lib32-alsa-plugins           1.2.5-1            (1.2.2-1)            multilib   71.4 kB
  lib32-libxcrypt              4.4.22-2           (4.4.20-1)           multilib   78.0 kB
  lib32-zstd                   1.5.0-2            (1.4.9-1)            multilib   391.1 kB
  lib32-libtirpc               1.3.2-1            (1.3.1-1)            multilib   83.3 kB
  lib32-systemd                248.3-1            (247.7-1)            multilib   587.7 kB
  lib32-util-linux             2.37-1             (2.36.2-1)           multilib   449.6 kB
  lib32-libx11                 1.7.2-1            (1.7.1-1)            multilib   644.4 kB
  lib32-at-spi2-core           2.40.2-1           (2.40.1-1)           multilib   77.4 kB
  lib32-colord                 1.4.5-3            (1.4.5-2)            multilib   109.6 kB
  lib32-gnutls                 3.7.2-1            (3.7.1-1)            multilib   883.0 kB
  lib32-libogg                 1.3.5-1            (1.3.4-2)            multilib   24.8 kB
  lib32-libcanberra            0.30+2+gc0620e4-4  (0.30+2+gc0620e4-3)  multilib   66.5 kB
  lib32-libelf                 0.185-1            (0.184-1)            multilib   485.7 kB
  lib32-libgusb                0.3.7-1            (0.3.6-1)            multilib   23.1 kB
  lib32-librsvg                2:2.50.7-1         (2:2.50.6-1)         multilib   2.6 MB
  lib32-llvm-libs              12.0.0-1           (11.1.0-1)           multilib   28.6 MB
  lib32-libva-mesa-driver      21.1.2-1           (21.1.2-0)           multilib   3.1 MB
  lib32-mesa                   21.1.2-1           (21.1.2-0)           multilib   15.0 MB
  lib32-mesa-vdpau             21.1.2-1           (21.1.2-0)           multilib   3.3 MB
  lib32-polkit                 0.119-1            (0.118-1)            multilib   50.2 kB
  lib32-vulkan-intel           21.1.2-1           (21.1.2-0)           multilib   2.2 MB
  lib32-vulkan-radeon          21.1.2-1           (21.1.2-0)           multilib   1.8 MB
  libinput                     1.18.0-1           (1.17.3-1)           extra      291.6 kB
  liblouis                     3.18.0-1           (3.17.0-1)           extra      2.1 MB
  libmbim                      1.24.8-1           (1.24.6-1)           extra      302.0 kB
  libnautilus-extension        40.2-1             (40.1-1)             extra      51.9 kB
  libnice                      0.1.18-2           (0.1.18-1)           extra      311.9 kB
  libpurple                    2.14.5-1           (2.14.4-2)           extra      5.8 MB
  libqmi                       1.28.6-1           (1.28.4-1)           extra      1.9 MB
  libreoffice-still            7.0.6-2            (7.0.6-1)            extra      140.5 MB
  libva-mesa-driver            21.1.2-1           (21.1.2-0)           extra      3.1 MB
  linux414-headers             4.14.235-1         (4.14.234-1)         core       8.5 MB
  mkinitcpio                   30-1               (29-1.0)             core       65.1 kB
  linux510                     5.10.42-1          (5.10.41-1)          core       88.2 MB
  linux510-headers             5.10.42-1          (5.10.41-1)          core       9.8 MB
  linux512                     5.12.9-1           (5.12.8-1)           core       91.1 MB
  linux512-headers             5.12.9-1           (5.12.8-1)           core       10.0 MB
  linux54                      5.4.124-1          (5.4.123-1)          core       86.0 MB
  linux54-headers              5.4.124-1          (5.4.123-1)          core       9.6 MB
  manjaro-release              21.0.7-1           (21.0.6-1)           core       18.6 kB
  mesa-vdpau                   21.1.2-1           (21.1.2-0)           extra      3.2 MB
  mhwd-db                      0.6.5-9            (0.6.5-7)            core       28.1 kB
  modemmanager                 1.16.6-1           (1.16.4-1)           extra      1.3 MB
  mousepad                     0.5.5-3            (0.5.5-2)            extra      402.9 kB
  mpg123                       1.28.0-1           (1.27.2-1)           extra      443.1 kB
  openexr                      3.0.4-1            (3.0.3-1)            extra      1.1 MB
  openmpi                      4.1.1-1            (4.0.5-3)            extra      3.5 MB
  osinfo-db                    20210531-1         (20210426-1)         community  180.0 kB
  papirus-icon-theme           20210601-1         (20210501-1)         community  20.2 MB
  pidgin                       2.14.5-1           (2.14.4-2)           extra      1.5 MB
  poppler-qt5                  21.06.1-1          (21.05.0-1)          extra      195.1 kB
  pulseaudio-alsa              1:1.2.5-2          (1:1.2.2-2)          extra      2.5 kB
  python-distlib               0.3.2-1            (0.3.1-2)            community  252.7 kB
  python-setuptools            1:57.0.0-2         (1:56.2.0-1)         extra      573.2 kB
  qt5-declarative              5.15.2+kde+r28-1   (5.15.2+kde+r26-1)   extra      5.1 MB
  re2                          1:20210601-1       (1:20210401-1)       extra      175.5 kB
  systemd-sysvcompat           248.3-2            (247.7-1)            core       7.3 kB
  tumbler                      4.16.0-3           (4.16.0-2)           extra      174.3 kB
  tuxedo-keyboard              3.0.6-1            (3.0.5-1)            extra      46.3 kB
  vte-common                   0.64.2-2           (0.64.1-1)           extra      7.1 kB
  vte3                         0.64.2-2           (0.64.1-1)           extra      367.8 kB
  vulkan-intel                 21.1.2-1           (21.1.2-0)           extra      2.3 MB
  vulkan-radeon                21.1.2-1           (21.1.2-0)           extra      1.7 MB
  wireshark-cli                3.4.6-1            (3.4.5-1)            community  21.3 MB
  wireshark-qt                 3.4.6-1            (3.4.5-1)            community  4.2 MB
  xfconf                       4.16.0-2           (4.16.0-1)           extra      188.8 kB
  xfce4-appfinder              4.16.1-2           (4.16.1-1)           extra      158.9 kB
  xfce4-panel                  4.16.3-2           (4.16.3-1)           extra      779.8 kB
  xfce4-power-manager          4.16.0-3           (4.16.0-2)           extra      556.3 kB
  xfce4-session                4.16.0-2           (4.16.0-1)           extra      337.5 kB
  xfce4-settings               4.16.2-1           (4.16.1-2)           extra      887.7 kB
  xfce4-terminal               0.8.10-2           (0.8.10-1)           extra      424.9 kB
  xfdesktop                    4.16.0-2           (4.16.0-1)           extra      1.3 MB
  xfwm4                        4.16.1-2           (4.16.1-1)           extra      499.6 kB
  yelp-xsl                     40.2-1             (40.0-1)             extra      194.0 kB
  yelp                         40.2-1             (40.0-1)             extra      851.6 kB
  zbar                         0.23.1-7           (0.23.1-6)           extra      256.7 kB
To install (2):
  libcolord                    1.4.5-4                                 extra      175.5 kB
  python-more-itertools        8.7.0-1                                 community  63.3 kB
To remove (4):
  libcanberra-gstreamer        0.30+2+gc0620e4-3                       
  lib32-libcanberra-gstreamer  0.30+2+gc0620e4-3                       
  lib32-libcanberra-pulse      0.30+2+gc0620e4-3                       
  libcanberra-pulse            0.30+2+gc0620e4-3                       

Total download size: 745.9 MB
Total installed size: 21.6 MB
Total removed size: 120.7 kB

Apply transaction ? [y/N]

Running Manjaro+Xfce kernel 5.12.8-1-MANJARO

I’m not really experienced with fixing this sort of problem myself but you really should have had two kernel versions installed just in case this sort of thing happens. I currently have 5.4 and 5.10 kernels installed. Sorry I can’t help much here.

1 Like

So just let it do its work.

i have the exact same error message.


Yeah, that makes sense. But I decided to revert to 5.4 because of that annoying graphics glitch in the i915 driver in later kernels and uninstalled all other kernels.

I thought that a system update would at least keep the last kernel that was installed before that update. But even 5.4.123 is gone – at least in grub.