[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

The Arch python package is flagged out of date, not sure why they haven’t updated to 3.9.4 yet.


Ok, I removed the “splash” word, and worked. Thanks.
Whus this happened? There is an explanation?

Alright, it seems to be an issue with the GDM package in my case.

E: Bad advice removed, see @Yochanan below instead

Only happen on the linux511 Kernel
linux510 is fine

How do I save the splash being deleted, so I don’t have to delete it every time I boot the computer?

For those having issues with GDM:

If you want to use plymouth:

  • install gdm-plymouth and libgdm-plymouth
  • requires splash kernel flag

If you want to use bootsplash-systemd or don’t want any boot logo at all:

  • install gdm and libgdm and remove plymouth
  • remove splash kernel flag

reinstall of lightdm-gtk-greeter hoppfully fixed it.:

sudo pacman -S lightdm-gtk-greeter
sudo systemctl enable lightdm
1 Like

That fixes it for me, thank you.

There is a small issue on Gnome with Dash to Dock. When the dock is set as a panel on the left or right side of the screen, either manually or by selecting the “unity” layout, the whole dock is moved a tiny bit down (The problem seems to exist even if it’s not set to expand, it’s just less noticeable). The spacing i weird at the top and the last icon on the bottom is partially of screen.
I had the same problem the last time I updated. Back then I was able to deal with the problem by changing the shell theme to adwaita. That doesn’t work anymore.

I would attach a screenshot to show the issue, but unfortunately I’m not allowed to do so.

1 Like

I updated earlier today and ever since then my application launcher won’t open, Kate won’t open, I can’t open the menus to add widgets to the desktop or panels and I can’t open the menu to show alternatives any more. I have detailed my issues in another post few hours ago in more detail: https://forum.manjaro.org/t/application-launcher-add-widgets-show-alternatives-and-others-no-longer-open-after-update/62838

This update broke my system. I has installed again and updated without problems.

Like this:

Could be a placebo but system feels noticeably snappier after this update. Well done Manjaro Team.

1 Like

I have gdm,libgdm,plymouth-theme-manjaro,plymouth installed.

To prepare fro this update I’ve removed splash kernel flag from /etc/defaul/grub after updating and rebooting. The boot proces is the same length with a bit more output on the console.

gdm-plymouth conflicts with gdm. What is the default? I’ll switch to that.

VLC still can’t play DVDs or ISOs. I can hear the sound but the screen stays black.

I had the same issue with 4.19 GNOME and removing splash Form the Boot Edit fixed it for me also… Thank you. :slight_smile:

With Kernel 5.11.14, sleep is still broken on my laptop (AMD Renoir-based with 4600U).
It’s not waking up correctly (system eventually locks up), and since 5.11.14 it’s not even going to sleep properly (power LED should pulse when in sleep, but it doesn’t).
Issue is present with latest 5.10 kernel as well now.
I could go back to 5.11.6, which works fine, but I’m getting kinda annoyed by this thing and would like to understand what’s going on.

the desktop has become a little strange, the icons have become very large

in the home folder appeared GZIP Archive “file”.
Снимок экрана от 2021-04-18 23-35-15
can I delete it?

The archive file was before the last update. I deleted it and no problem occurred in my experience.

1 Like

First of all, I use xfce with lightdm and the lightdm-gtk-greeter.

Usually everything goes well for me but after today’s update, when I try to login after booting, the screen freezes before I reach my desktop. I have to switch to a different tty, login, issue a sudo systemctl restart display-manager and switch back (which happens automatically) to be able to log in without a freeze. Any ideas?

Thank you very much.

Edit: this happens regardless of which kernel version I use, tried on 5.4, 5.10 and 5.11.

Update -Xorg:

i915 0000:00:02.0: [drm] ERROR FDI link training failed!
апр 19 00:38:56 bunker-01 kernel: i915 0000:00:02.0: [drm] ERROR uncleared pch fifo underrun on pch transcoder A
апр 19 00:38:56 bunker-01 kernel: i915 0000:00:02.0: [drm] ERROR PCH transcoder A FIFO underrun
апр 19 00:39:02 bunker-01 kernel: i915 0000:00:02.0: [drm] ERROR FDI link training failed!
апр 19 00:39:02 bunker-01 kernel: i915 0000:00:02.0: [drm] ERROR uncleared pch fifo underrun on pch transcoder A
апр 19 00:39:02 bunker-01 kernel: i915 0000:00:02.0: [drm] ERROR PCH transcoder A FIFO underrun


00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)

Fix: BusID “PCI:0:2:0” >>> BusID “PCI:0:1:0”