How to boot into my system from usb?

Hi newbi question my desktop is XFCE my pc is 64bit 60gig hardrive. I did a recent up date and now manjaro won’t boot up. I get a message saying I need to have a kernel installed first. I’ve tried advanced option but even the fallback won’t boot. I did some research that it’s possible to recover my installed system by chroot using usb but not really sure what to do after I get the message below. In the terminal I typed “manjaro-chroot -a” below is the message I got.

“Mounting (ManjaroLinux) [/dev/sda2]
“mount: [/mnt]
“mount: [/mint/boot/efi]

I really don’t want to have to do a new install as i’d loose all data on hardrive. Any help would be most welcome. Thanks in advance.

1 Like

Hello @sismian :wink:

Any chance you have an old nvidia gpu? :slight_smile:

Hi sismian

This page of the Wiki may help:

Hi thanks for the reply, i’m not sure what nvidia I have on my system, but I suspect it’s not new as my laptop is four years old. Is there a way to check this?

Thanks i’ll take a look.

@sismian Please post then which you have…

inxi -Gazy

I assume then you will need to have 340xx driver, if so then you will need to use a dkms package…

Once installed it will stay and never get updated, but have to be minor recompiled at every kernel update for adjustment.

Hi thanks for your help, I typed inxi in terminal and got message below.

CPU: Quad Core AMD A4 Micro-6400T APU + AMD Radeon R3 Graphics ( -MCP- )
speed/min/max: 789/800/1000 MHz Kernal: 5.6.15-1-MANJARO x86_64 Up: 9m
Mem: 629.9/1692.2 MiB (37.2%) Storage: 279.12 GiB (0.0% used) Procs: 173
Shell: bash 5.0.17 inxi: 3.0.37

Sorry I had to type out the info as I can’t connect to the internet at the moment using usb iso stick? otherwise i’d have posted a screenshot.

O-M-G … sorry… Kernel 5.6 is a part of history now and don’t exist on Manjaro. It seems you have never changed the kernel since your installation…

Install the latest LTS Version linux54 and you won’t have problems with upgrading it to the next major version… stable versions live not long and most features added on next major versions are not needed on older systems…

Have look also here:

sudo mhwd-kernel -i linux54

then reboot and choose kernel linux54. Then remove it:

sudo mhwd-kernel -r linux56

Do you have only this integrated Radeon Graphics or also a Nvidia Card?

Normally inxi -Gazy would only show the Graphics and Screens, nothing else.

Yeah understand, that is difficult. Sure you can post a screenshot, but please post only pictures if there is no way around this. Typing the whole output is ridicules… make screenshot if there is no internet :wink:

Hi thanks for all your help, i’m confused because when installed manjaro I have been upgrading via the system upgrade tool would that not have upgraded the kernel as well?

The problem I now have as I’m not able to boot my system so I have been using usb installation stick as a live session and cannot connect to the internet to upgrade the kernel. I did a search on the forum and it seems that I would have to reinstall manjaro to be able to connect to the internet but then that means all my data gets wiped. Inxi -Gazy didn’t work only inxi worked and only the AMD Radeon Graphics card was listed along with the rest I typed out previously.

I did inxi -N in terminal, please see the results below. Thanks again for your help.

Device-1: Broadcom and subsidiaries
BCM43142 802. 11b/g/n driver . N/A

Yes, it will upgrade within this major version, so 5.6.12 to 5.6.24, but not 5.6.12 to 5.7.22…

That is is the responsibleness of the user and the freedom to change to kernels as they like. But Manjaro follows also the releases and drops of the kernel developers. So if you don’t want to change the kernel every 2-3 Months yourself, then stick to a LTS Kernel.

Ok let me face the problem… I would help you, but without information it is just looking into a glass globe and looking for signs and guesses. You have no internet, so you can’t share logs… How did you write here? If I give you some commands, are you able to save the logs and information about your systems to an usb stick or phone or whatever and share it here? Sorry, without information… i am out here.

And yes, this chipset is not baked into the kernel and therefore a dkms package is needed. It is possible to load module (driver) manually without the need of rebooting the system, but well you will need a internet connection… :crazy_face: …or at least the downloaded package of the driver…

Ahh ok :ok_hand:t4: I understand, so it was down to me to update the kernel to the latest.

I have access to the internet via my phone data, so that’s what i’ve been using to communicate on the forum. I also use it to connect my laptop through tethering but because of the driver issue that doesn’t work anymore. Yes if you could give me the commands to load the driver manually that would be great.

I can take pictures using my phone but last time I tried to upload I got a message saying i’m not allowed to embed media in a post, is there a way around that? Thanks for all your help.

Well tethering works also via USB out-of-the-box, don’t have to be via wifi. However…

I read again your post…

If you get this message, then the kernel 5.6 has been removed, since the kernel has been removed on the repo, it has been removed from your system also at this upgrade. You will need internet access and install a kernel while chrooting into your system:

manjaro-chroot -a


mhwd-kernel -i linux54

This should solve your problem.

1 Like

Hi sorry for delayed reply, i am now able to connect to the internet. I tried both of those commands in the terminal, please see message below. Thanks for all your help.

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
==> Mounting (ManjaroLinux) [/dev/sda2]
→ mount: [/mnt]
→ mount: [/mnt/boot/efi]
[manjaro /]#