LAPTOP is not booting after installing Linux kernel 5.19 experimental

Device is not booting after installing new experimental Linux 5.19

Manjaro doesn’t boot. No keyboard working

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

How to boot from USB into live Manjaro (for repair):

Please install 2 kernels (one of them LTS)

Did you remove the other kernel? If not boot into it.

No,i have 4 kernel installed.

Good, because experimental kernels are marked experimental for a reason, they may have issues. Use an existing one that works. If you want to get the other one running because you have specific hardware requirements that need that experimental kernel, good luck.

How do I change kernel? Laptop is not accepting any input. After Turning on It just show this error screen.

Keep hitting the ESC key during boot to show the grub screen.

Once inside the system
Enter this in the terminal sudo nano /etc/default/grub change your GRUB_TIMEOUT_STYLE=hidden to GRUB_TIMEOUT_STYLE=menu then run sudo update-grub

Thanks I changed my kernel to 5.18 rt. It worked.

Remove the experimental kernel, try to stay with a LTS kernel unless you need specific support for some new hardware. I edited the way to make grub show all the time in my previous post while you were posting. Remember always keep at least two kernels so you have a good one to boot into.

can you report

sudo mhwd-kernel -li

3 kernel, 419, 515, 518-rt, currently using 518, I tried 519 , that produced the error.

ok for 4.19 , 5.15 , 5.18 ( not rt )

version 5.19 has just started , you should try next time , if not , reboot on 5.18

sudo mhwd-kernel -i linux519

last report ,only keyboard or also disk or video card ?

inxi -Fza 

Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo driver: radeon
v: kernel alternate: amdgpu arch: GCN-2 code: Sea Islands
process: GF/TSMC 16-28nm built: 2013-17 ports: active: eDP-1
empty: HDMI-A-1,VGA-1 bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300
Device-2: Chicony EasyCamera type: USB driver: uvcvideo bus-ID: 1-1.4:3
chip-ID: 04f2:b581 class-ID: 0e02 serial:
Display: wayland server: X .org v: with: Xwayland v: 22.1.3
compositor: gnome-shell driver: gpu: radeon display-ID: 0
Monitor-1: eDP-1 model: BOE Display 0x06bd built: 2016 res: 1366x768
dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: max: 1366x768 min: 640x480
OpenGL: renderer: AMD KABINI (LLVM 14.0.6 DRM 2.50 5.18.0-1-rt11-MANJARO)
v: 4.5 Mesa 22.1.4 direct render: Yes

All the kernels work fine except the new experimental one.

Kernels are mostly for hardware support. The reason to try experimental kernels is to enable specific new hardware you may have. If you dont have newer hardware and your system is working you really dont need a new experimental kernel. You can test, and run this or that, but unless you need it for hardware support, its most likely a waste of time. This is especially true if you have little tolerance for bugs or limited troubleshooting skills.
By all means test or try a new kernel if you want, but imho keep at least one other kernel installed so you can boot into it in case the experimental one doesnt work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.