System Crashed, boots to Grub Rescue prompt, unable to find Manjaro install

working on the inxi info

My desktop system is manjaro dual booted with Windows. I have the original Windows install on the original HDD, an old Manjaro install on a second partition of that HDD, and my active Manjaro install on an SSD I added later. I have been booting from the SSD via grub.

I left my desktop on sleep mode for about a week when I went out of town. When I came back it woke up normally but then crashed catastrophically. Rebooted and ended up with grub rescue prompt and the message

error: no such device: cefa683a-0faa-4e4b-a2e1-97dc28374a11.
error: unknown filesystem.
Entering rescue mode…

I have an Arch linux live usb handy so I mounted the SSD and the only data on there appears to be directories lost+found and VirtualBox\ VMs. This is an old system and honestly I cannot remember how I had the disk setup. Currently the SSD shows only one partition with only those two directories. I believe the grub error message references a UUID of the bootable partition I had setup on the SSD, but as I mentioned I cannot recall exactly.
The HDD has 3 partitions, one is bootable, all 3 are given as type HPFS/NTFS/exFAT. This is weird b/c I know that one of those partitions had the old Manjaro install on it and using the ls command in grub-rescue prompt returns Filesystem is ext2 for the third partition. The third partition of the HDD has only 3 directories, pictures and android studio related things. I did have these on a separate partition at one point as they were eating up space on the SSD.
When I try to mount the second partition from the HDD I get the error message “Windows is hibernated, refused to mount.” I haven’t booted that Windows install in years and just never saw a need to remove it completely.
I can probably just wipe everything and reinstall, but I have a lot of work I don’t want to lose on the Manjaro install. Any suggestions?

When rescuing data, you should use an “up to date” live manjaro with an LTS-kernel

How to boot from USB into live Manjaro (for repair):

These are not the best circumstances

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
1 Like

Yeah, I know. Like I said, this system is well over 10 years old and I haven’t really messed with the setup in that time. Honestly other than updating every 2 weeks and then rebooting I never have downtime on this system until now.

Also, I don’t have inxi available to me on the live USB I have and I don’t really have another way to get a new live USB since my desktop is toast at the moment.

output from:
cat /etc/fstab
parted -l


/dev/sdb1: UUID="c40e773b-9100-4364-8619-956d4d79b81c" TYPE="ext4" PARTUUID="9b26b00a-01"
/dev/sda1: LABEL:"SYSTEM" UUID="E8C27AC5C27A9810" TYPE="ntfs" PARTUUID="ee39b587-01"
/dev/sda2: LABEL="OS" UUID="66041F7D041F5003" TYPE="ntfs" PARTUUID="ee39b587-02"
/dev/sda3: UUID="3ca729ac-c754-4e0c-bca9-2d091770e757" TYPE="ext4" PARTUUID="ee39b587-03"

parted -l
(I can’t upload directly to post or post links.)
cat /etc/fstab is an empty return, understanding this is from /root of the live USB.

I tried fsck /dev/sdb and got

ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks…
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdb
The superblock could not be read or does not describe a valid ext2/ext3/ext4 filesystem. If the device is valid and it really contains an ext2/ext3/ext4 filesystem (adn not swap or ufs or something else), then the superblock is corrupt, and you migt try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
e2fsck -b 32768 <device>
/dev/sdb contains ‘DOS/MBR boot sector; partition 1 : ID=0x83, start-CHS (0x0,32,33), end-CHS (0x181,80,63), startsector 2048, 976771120 sectors, extended partition table (last)’ data

I get the same error message with the suggest e2fsck -b commands. Running fsck /dev/sdb1 just returns clean, 32/30531584 files, 18874246/122096390 blocks.

Filling in some of the historical gaps in my setup. The SSD had three partitions, a boot partition, a partition with Manjaro on it, and a partition for the VMs that is showing up as sdb1 and was last mounted at /Virt in my main Manjaro system. The old Manjaro system was wiped on sda3 and used as storage for the main newer Manjaro install on the SSD, mounted at /data. So it seems that the partition table for the SSD is inaccurate or that the other partitions got wiped somehow when it crashed.

Something is messed up with the disk. Testdisk lists the partition labelled as sdb1 as starting at 0 and taking the whole space, but it finds other partitions starting at 17 and 18 that are the size of the boot partition I had on that disk and another partition that is the size of the Manjaro install partition, but it cannot read the filesystem to try to recover the partitions.

if the fscks didnt work, and you can access the data from the live usb, the hard drive is corrupted …
blkid detects the uuids and partition, the same goes for parted -l
fstab didnt detect anything …
post output also from:
lsblk -f

lsblk -f returns the same as blkid just formatted differently. Same labels and UUIDs for the same partitions. I’m just going to try and start from scratch as the hardware seems corrupted at this point.

you could check the smart status of the ssd

I’ve run the diagnostics from the BIOS and the drive came back as healthy. smartctl also returned healthy status.

if its not urgent, you can wait for @winnie, he knows stuff around ssds…

Nothing critical lost, just hobby stuff that I will miss. Reinstalling/formatting everything.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.