[Stable Update] 2024-03-13 - Plasma 5.27.11, Firefox, Thunderbird, AMDVLK, Qemu

Hello community,

here we have another set of package updates!

Current promotions

  • image

    We currently have a flashsale with our partner MINISFORUM on the UM790Pro featuring the Manjaro Linux GamingEdition. Use the device either as a MiniPC or Gaming Console! Use our link to get yours. Note: US Market only!

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!

  • Protect your personal data, keep yourself safe with Surfshark VPN: 79% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77 and review ISOs are available via github.

Our current supported kernels

  • linux419 4.19.307
  • linux54 5.4.270
  • linux510 5.10.211
  • linux515 5.15.154
  • linux61 6.1.85
  • linux66 6.6.26
  • linux68 6.8.5
  • linux61-rt 6.1.80_rt26
  • linux66-rt 6.6.20_rt25
  • linux67-rt 6.7_rt6

Package Changes (Wed Mar 06 2024 12:30:48 GMT)

  • stable core x86_64: 3 new and 3 removed package(s)
  • stable extra x86_64: 1884 new and 1962 removed package(s)
  • stable kde-unstable x86_64: 0 new and 362 removed package(s)
  • stable multilib x86_64: 5 new and 5 removed package(s)

A list of package Changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-04-04

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab


plymouth update may cause black screens

With a newer version of plymouth than 22.02.122 you may experience an unbootable system with a black screen. This might be due to not having early KMS enabled. If you have an Nvidia GPU you could set nvidia_drm.modeset=1 nvidia_drm.fbdev=1 to the kernel parameters in your bootloader config to avoid the need of KMS. However, with Wayland around the corner, KMS will be needed.

To “fix” the current problem, we have downgraded plymouth once again to have more time to find a proper solution to migrate most of your installations to a working state with newer plymouth versions.

sudo pacman -Syuu

Those who don’t have issues can enjoy the newer version of plymouth.

Directions for adding kms to your system configuration and how you can help troubleshooting by providing some sysinfo, read more → Black Screen with Plymouth - Cause and Solution

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://www.reddit.com/r/archlinux/comments/19bnj0i/comment/kit2v33/

bashrc-manjaro is now merged into bash
  • Yes, replace bashrc-manjaro with bash
  • Please also compare your:
    with the generated
    and retrofit all of your customisations as there was no .pacnew file generated.
  • Same goes for /etc/skel/.bashrc
pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update (after you finished the Release Update) with:

sudo pacman -Syu pacman-contrib


Initramfs image can be bigger on 6.7 kernel due to Nvidia GSP Boot firmware

We all known that kernel 6.7 is very feature rich. One of the features is the inclusion of Nvidia’s GSP Boot firmware into Initramfs. However this will increase your image by 150 MB and the fallback image might be 240 MB in size. A way would be to remove kms from mkinitcpio.conf and redo your initramfs images. A discussion regarding that can be found at Arch Gitlab: kms hook increases the initramfs size heavily starting with 6.7 kernel (#238) · Issues · Arch Linux / Mkinitcpio / mkinitcpio · GitLab

To reduce size add fallback_options="-S autodetect -S kms" to /etc/mkinitcpio.d/linux67.preset

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

In some cases, however it is better to keep the legacy way. Here are some examples: Dbus-broker warnings


grub update

grub 2.12 may need manual post install by the user

With GRUB 2.12 out it is recommended to also install grub to your master boot record or EFI partition. On Manjaro grub gets only installed when you install it to your harddrive the first time. Only advanced users also keep their MBR/EFI in-sync as every package update of grub doesn’t update the installation on your MBR/EFI.

Depending on your system hardware and setup this may could cause an unbootable system on rare cases due to incompatibilities between the installed bootloader and configurations. After a grub package update it is advised to run both, installation and regeneration of configuration:

grub-install [plus the needed options depending of been EFI or BIOS]
grub-mkconfig -o /boot/grub/grub.cfg

For more specific information on grub-install, please refer to this guideline: [root tip] [How To] Primer on handling a grub package update

Additional information to that topic can be found here:


Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm


  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66


Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab


mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.


glibc-locales update requires manual intervention

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*


Changes to default password hashing algorithm and umask settings

2023-09-22 - David Runge

With shadow >= 4.14.0, Arch Linux’s default password hashing algorithm changed from SHA512 to yescrypt [1].

Furthermore, the umask [2] settings are now configured in /etc/login.defs instead of /etc/profile.

This should not require any manual intervention.

Reasons for Yescrypt

The password-based key derivation function (KDF) and password hashing scheme yescrypt has been chosen due to its adoption (readily available in libxcrypt, which is used by pam [3]) and its stronger resilience towards password cracking attempts over SHA512.

Although the winner of the Password Hashing Competition [4] has been argon2, this even more resilient algorithm is not yet available in libxcrypt [5][6].

Configuring yescrypt

The YESCRYPT_COST_FACTOR setting in /etc/login.defs is currently without effect, until pam implements reading its value [7]. If a YESCRYPT_COST_FACTOR higher (or lower) than the default (5) is needed, it can be set using the rounds option of the pam_unix [8] module (i.e. in /etc/pam.d/system-auth).

General list of changes

  • yescrypt is used as default password hashing algorithm, instead of SHA512
  • pam honors the chosen ENCRYPT_METHOD in /etc/login.defs and does not override the chosen method anymore
  • changes in the filesystem (>= 2023.09.18) and pambase (>= 20230918) packages ensure, that umask is set centrally in /etc/login.defs instead of /etc/profile

[1] yescrypt - scalable KDF and password hashing scheme

[2] umask(1p) — Arch manual pages

[3] PAM - ArchWiki

[4] https://www.password-hashing.net/

[5] [RFC] Add argon2 backend. by ferivoz · Pull Request #113 · besser82/libxcrypt · GitHub

[6] Add support for Argon2 by maandree · Pull Request #150 · besser82/libxcrypt · GitHub

[7] pam_unix: Support reading YESCRYPT_COST_FACTOR from /etc/login.defs · Issue #607 · linux-pam/linux-pam · GitHub

[8] pam_unix(8) — Arch manual pages

Arch Linux - News: Changes to default password hashing algorithm and umask settings


filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.

updates for linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module

R8168 driver not loaded on kernel 6.5 after testing update 2023-09-22

All 3 versions of network-r8168 drivers are working again following [Testing Update] 2023-09-27

  • linux65-r8168 8.051.02-7
  • linux61-r8168 8.051.02-5
  • linux515-r8168 8.051.02-4


LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam
Steam crashes at launch with libgudev 238 · Issue #9805 · ValveSoftware/steam-for-linux · GitHub

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match system theme

pamac-gtk 11.0.1 uses Gtk 4 that is not supported on Xfce or Cinnamon
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.

Previous stable update threads:

1 Like

New packages :

lite-xl              : A lightweight text editor written in Lua https://lite-xl.com
gambas3-gb-highlight : A syntax highlighter based on definition files http://gambas.sourceforge.net/

Deleted packages :

haskell-random-source               : Generic basis for random number generators https://github.com/mokus0/random-fu 
yuzu                                : Nintendo Switch emulator https://yuzu-emu.org/ 
haskell-hls-tactics-plugin          : Wingman plugin for Haskell Language Server https://haskellwingman.dev 
haskell-record-hasfield             : A version of GHC.Records as available in future GHCs. https://github.com/ndmitchell/record-hasfield#readme 
python-ansicolors                   : ANSI colors for Python https://github.com/jonathaneunice/colors 
haskell-hls-brittany-plugin         : Integration with the Brittany code formatter https://haskellwingman.dev 
electron29                          : Build cross platform desktop apps with web technologies https://electronjs.org 
haskell-bytestring-show             : Efficient conversion of values into readable byte strin… https://hackage.haskell.org/package/bytestring-show 
haskell-hls-haddock-comments-plugin : Haddock comments plugin for Haskell Language Server https://github.com/haskell/haskell-language-server 
haskell-record-dot-preprocessor     : Preprocessor to allow record.field syntax https://github.com/ndmitchell/record-dot-preprocessor#readme 
haskell-brittany                    : Haskell source code formatter https://github.com/lspitzner/brittany/ 
python-lru-dict                     : A fast and memory efficient LRU cache for Python https://github.com/amitdev/lru-dict 

Replaced packages

libblockdev-tools                   : A library for manipulating block devices - tools https://github.com/storaged-project/libblockdev  -> libblockdev-fs
libblockdev-utils                   : A library for manipulating block devices - utility func… https://github.com/storaged-project/libblockdev  -> libblockdev
libblockdev-lvm-dbus                : A library for manipulating block devices - LVM D-Bus AP… https://github.com/storaged-project/libblockdev  -> libblockdev-lvm
cargo-espflash                      : Cargo subcommand for flashing Espressif devices over se… https://github.com/esp-rs/espflash  -> espflash

I’d understand if you changed the file directly. Instead of doing that, however, you should change it with:

sudo systemctl edit plasma-powerdevil.service

And change it there, by adding this below the ±4th line line:


Save, exit, and reload the daemon:

sudo systemctl daemon-reload

Followed by restarting the service:

sudo systemctl restart plasma-powerdevil.service


I love it when an update’s boring.

Thanks @Manjaro-Team!

You rock!


Other than Discord 0.0.45 still missing everything went smoothly.

1 Like

notebook (acer nitro 5) and proxmox VM == everything went smoothly

keep up the good work

1 Like

Hello everybody.
If i use the following command to update the mirrors:
sudo pacman-mirrors --geoip

i got one repo down the last 3 times i did before i make a update.

 ..... Germany        : http://ftp.rz.tu-bs.de/pub/mirror/manjaro.org/repos/

::FEHLER Connection: HTTPConnectionPool(host='ftp.rz.tu-bs.de', port=80): Read timed out.

Its just cosmetical i know. Just wanted to report it.
sddm-greeter still has the bug with nouveau and nvidia geforce 210 plus kernel greater then 6.1, but i wont bother you anymore because i know its old hardware. But why throwing away if it is ok.

[   82.902509] sddm-greeter[992]: memfd_create() called without MFD_EXEC or MFD_NOEXEC_SEAL set
[   89.866468] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [sddm-greeter[992]] get 000021e000 put 000021e088 ib_get 00000007 ib_put 00000008 state 80000024 (err: INVALID_CMD) push 00400040
[   93.432563] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [sddm-greeter[992]] get 000021e008 put 000021e088 ib_get 0000000b ib_put 0000000c state 80000000 (err: INVALID_CMD) push 00400040
[   93.519264] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [sddm-greeter[992]] get 000021e088 put 000021f6d8 ib_get 0000000d ib_put 0000000e state 80000024 (err: INVALID_CMD) push 00400040
[   93.569194] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [sddm-greeter[992]] get 000021f708 put 000021f760 ib_get 00000013 ib_put 00000014 state 80000000 (err: INVALID_CMD) push 00400040
[   93.571752] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [sddm-greeter[992]] get 000021f764 put 0000220f74 ib_get 00000015 ib_put 00000016 state 80000000 (err: INVALID_CMD) push 00400040
[  102.904475] nouveau 0000:01:00.0: fifo: DMA_PUSHER - ch 4 [ksplashqml[1083]] get 000021e004 put 000021e088 ib_get 0000000b ib_put 0000000c state 800081a4 (err: INVALID_CMD) push 00400040


Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1

I suggest the bug is in the nouveau driver. But i am just a user.

To complete this:

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa (0x10de)
    Device: NVA8 (0xa65)
    Version: 24.0.2
    Accelerated: yes
    Video memory: 1015MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.3
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 812 MB, largest block: 812 MB
    VBO free aux. memory - total: 838859 MB, largest block: 838859 MB
    Texture free memory - total: 812 MB, largest block: 812 MB
    Texture free aux. memory - total: 838859 MB, largest block: 838859 MB
    Renderbuffer free memory - total: 812 MB, largest block: 812 MB
    Renderbuffer free aux. memory - total: 838859 MB, largest block: 838859 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 1015 MB
    Total available memory: 1049590 MB
    Currently available dedicated video memory: 812 MB
OpenGL vendor string: Mesa
OpenGL renderer string: NVA8
OpenGL core profile version string: 3.3 (Core Profile) Mesa 24.0.2-manjaro1.1

Solution for all with NVIDIA Geforce 210:
Use Kernel 6.1.xx until EOL in December 2026. Get newer Hardware.

Maybe somebody should write on the right place Geforce 210 is not longer supported in Manjaro.
For Ubuntu/Mint there is a possibility:

Update went smooth.

Thanks manjaro team.

3 posts were split to a new topic: Ssh-agent not working via gnome-keyring

As far as I can see that’s an unofficial PPA, there is no official support. If you’d be happy to trust that on Ubuntu/Mint then 340.xx and 390.xx drivers are available with patches for later kernels on the AUR;



1 Like

Is still supported by Manjaro:

And older/newer Kernels

1 Like

Well, this is a good one.

I haven’t updated in about two months because I’ve been moving out of Japan and stuff, so I focused on getting the most out of my time here… anyways, I’m running Manjaro GNOME on btrfs due to my (future, not yet realised) NAS running on btrfs. Today I update the package lists and saw that there is about 2.2GBs of packages to install, around 9GB of total Install size. I made some cleanup recently and had 15.6GiBs of free space on disk, so I figured all should fit with some 3GBs overhead… yeah, famous last words.

I checked all the known issues as posted in the wiki post, and I ran the update with pacman -Syyu pacman-contrib due to that 2-16 update which split them. I replaced bashrc-manjaro with /core/bash, downloaded all the packages, the sufficient space check passed, everything was going well until I started getting write errors while updating papirus-icons… This was confusing since df -h and gnome-nautilus both showed 6GB of free space still left on root partition and some sensible values on all others.

Well, I ran paccache -rvk 2 to clear out some 2.1GB more space from old packages. To make sure the filesystems get cleared or maybe SSD trimmed, I rebooted the PC only to find out that all the Linux kernels have been wiped from the boot partition! XD

I’m writing this post from a live-booted Manjaro GNOME from a Ventoy ssd-pendrive I always carry for such occasions. Now I have to remember how it was done the Arch way (I installed Arch once back in 2013), hopefully chrooting into the existing Manjaro install, checking that free space situation, mounting all the partitions and running mkinitcpio should be enogh, but please let me know if you have any better ideas getting out of this predicament.

P.S. this is not the first time I’m getting silly errors due to running out of free disk space (I guess my sence of “enough free space” has gotten deprecated). What’s outrageous is that pacman always passes the free disk space check! I think this might be a bug… one more time this happens and I’m setting up a VM for testing just that, and file a bug report (question to readers: Should I file it here with Manjaro or to upstream (Arch))?

You have to ALWAYS finish the update with kernels. Now just chroot and reinstall them. (and finish the rest of it)

Arch of course. Just make sure you use Arch VM.

1 Like

Well, which are you using? :wink:

Since it seems to be the former, than please create a new Support thread with more details to help us help you.


Update went fine on X11 and stable. Still have the random freezing issue when testing Wayland, but I understand that may not come right for multi-monitor setups with Nvidia proprietary driver until v6.

Hey @MrLavender .
Thank you for the suggestions. I like Manjaro and will use it on this Machine in future, and yes you are right, it is an unsupportet PPA and not trustworthy.

AUR is unsupported from Manjaro because Manjaro does not officially support AUR. The 340.xx Branch is in AUR. (Yes i can try) but i like the nouveau drivers because they are FOSS.

390.xx Branch does not include the old Geforce 210 Hardware. @pheiduck

So … Geforce 210 is not longer supported in Manjaro with kernels higher then 6.1.xx because Manjaro has no support for AUR.

Not sure if this is just me or if others are experiencing this but my discord version still has not been updated from 0.0.44-1 to 0.0.45-1. I was wondering what the process is for updating one of the packages and would have thought that when it was updated on arch that it would have also been updated for the Manjaro Official Repositories. If anybody knows of the process and if there is any way to help in that process I’d be interested in learning. Thanks!


Btrfs is not comparable with other filesystems. You should not go over 80-90% full with btrfs, or you will regret it.

You can find good Information about Btrfs in the wiki

1 Like

0.0.45-1 is on unstable branch. It takes longer for new Arch packages to get to stable branch because they go through unstable and testing first. That’s the whole point of stable.


1 Like

5 posts were split to a new topic: Changes to plasma-powerdevil.service overwritten

It turns out I missed the update a couple days ago. I pushed it to testing & stable a couple of hours ago.

Normally that is the case. However, with Discord the application will not work if it detects there’s an update. Apparently upstream doesn’t care. :man_shrugging: