Changes to plasma-powerdevil.service overwritten

So you do exactly what he said. :facepalm: How many times will we need to repeat that you should NOT change files in /usr.

[@nikgnomic - Original comment in Stable update announcement has been deleted but replies may help other users]

I’m guessing at least twice, possibly more per person: once for each personality…

:wink: :stuck_out_tongue_winking_eye:

Sorry. Not sorry.


That is conflicting statements, you admit to editing that exact file, right after saying you didn’t…and besides, if you didn’t, this wouldn’t have be en the case.

And it’s not only my suggestion. See:


systemctl provides built-in mechanisms for editing and modifying unit files if you need to make adjustments.

Without the messages, there’s no way to explain 'em, but my guess is that if everything worked as it should have, and I understand you correctly, that’s just warning and not actual errors.

sudo systemctl edit plasma-powerdevil.service
[sudo] password for lightning: 
No files found for plasma-powerdevil.service.
Run 'systemctl edit --force --full plasma-powerdevil.service' to create a new unit.

For example the message above appears to say that plasma-powerdevil.service does not exist.
How is it that possible even when running the command in the same directory where the file exists.

Honestly I don’t know what point you are trying to make here except waste everyone’s valuable time.
Please try to focus on the problem rather than picking points.

Explain why when typing ‘sudo systemctl edit plasma-powerdevil.service’ the service responds no such file exists even when you are in the file where it exists?
Where should I run the command from?

When I have time to respond next week - I will answer with any further queries.

We already established that the problem are users editing /usr content.

Doesn’t matter. It’s a user service, so you have to run systemctl --user [...].

1 Like

My point is that you specifically said you did and do not do something. And in the very next line you describe how you did the exact thing you said you didn’t do. Seeing as you brought up the point, that’s a bigger waste of everyone’s valuable time.

See @zbe’s answer below. It’s a user service, apparently. (I use a desktop, not a laptop, so I’ve never used that specifically. I have many other services though.)

So try adding --user just after the systemctl part of the command, for every command, I.e.:

systemctl --user <whatEverTheRestIs>
1 Like