Steam will not launch

When I try to launch steam it just shows the updating screen for a split second then closes.
When I run steam in my terminal it gives me this output:[8613]: Running Steam on manjarolinux 23.0.0 64-bit[8613]: STEAM_RUNTIME is enabled automatically[8686]: Steam runtime environment up-to-date![8613]: Steam client's requirements are satisfied
[2023-07-07 16:56:28] Startup - updater built Jun 21 2023 21:17:38
[2023-07-07 16:56:28] Startup - Steam Client launched with: '/home/samc/.local/share/Steam/ubuntu12_32/steam'
07/07 16:56:28 Init: Installing breakpad exception handler for appid(steam)/version(1687386907)/tid(8761)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2023-07-07 16:56:28] Loading cached metrics from disk (/home/samc/.local/share/Steam/package/steam_client_metrics.bin)
[2023-07-07 16:56:28] Using the following download hosts for Public, Realm steamglobal
[2023-07-07 16:56:28] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-07-07 16:56:28] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-07-07 16:56:28] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-07-07 16:56:28] Checking for update on startup
[2023-07-07 16:56:28] Checking for available updates...
[2023-07-07 16:56:28] Downloading manifest:
[2023-07-07 16:56:28] Manifest download: send request
[2023-07-07 16:56:28] Manifest download: waiting for download to finish
[2023-07-07 16:56:28] Manifest download: finished
[2023-07-07 16:56:28] Download skipped: /steam_client_ubuntu12 version 1687386907, installed version 1687386907, existing pending version 0
[2023-07-07 16:56:28] Nothing to do
[2023-07-07 16:56:28] Verifying installation...
[2023-07-07 16:56:28] Performing checksum verification of executable files
[2023-07-07 16:56:29] Verification complete

(process:8761): GLib-GObject-CRITICAL **: 16:56:29.579: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:8761): GLib-GObject-CRITICAL **: 16:56:29.579: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Loaded SDL version 3.0.0-1782-g214d5daa3
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xec613db0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xec612500
Gtk-Message: 16:56:29.631: Failed to load module "appmenu-gtk-module"
/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'

(steam:8761): Gtk-WARNING **: 16:56:29.636: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
GetWin32Stats: display was not open yet, good
ComputeStartupMode: found registry default startup mode: 0
Switching to desktopui, since -vgui was not specified
GetWin32Stats: display was not open yet, good[8788]: Runtime for steamwebhelper: defaulting to /home/samc/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[8788]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 25 milliseconds to initialize
Failed to init SteamVR because it isn't installed
Assertion 'device' failed at src/libsystemd/sd-device/device-private.c:103, function device_get_tags_generation(). Aborting.
crash_20230707165630_27.dmp[8970]: Uploading dump (out-of-process)
crash_20230707165630_27.dmp[8970]: Finished uploading minidump (out-of-process): success = yes
crash_20230707165630_27.dmp[8970]: response: CrashID=bp-e919952d-82f8-4dd7-8a2a-3412d2230707
crash_20230707165630_27.dmp[8970]: file ''/tmp/dumps/crash_20230707165630_27.dmp'', upload yes: ''CrashID=bp-e919952d-82f8-4dd7-8a2a-3412d2230707''
/home/samc/.local/share/Steam/ line 798:  8761 Aborted                 (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"

Manjaro Unstable
System info:

  Kernel: 6.1.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=b5089fca-1558-4628-b8ce-be93a4357c01 rw quiet
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX505DT.316 date: 01/28/2021
  ID-1: BAT0 charge: 35.8 Wh (100.0%) condition: 35.8/48.1 Wh (74.5%)
    volts: 12.0 min: 11.7 model: FX50442 type: Li-ion serial: N/A status: full
  System RAM: available: 15.06 GiB used: 3.45 GiB (22.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
    built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 2042 high: 2945 min/max: 1400/2300 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1571 2: 1738
    3: 1400 4: 1400 5: 1400 6: 2945 7: 2944 8: 2942 bogomips: 36750
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2
    sse4a ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f91
    class-ID: 0300
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: eDP-1 empty: none bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300
    temp: 67.0 C
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 13d3:56a2
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x0036 built: 2018
    res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Vega 10 Graphics
    (raven LLVM 15.0.7 DRM 3.49 6.1.38-1-MANJARO) direct-render: Yes
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.1.38-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.72 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
    rev: 1.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:2 chip-ID: 13d3:3548
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 596.18 GiB used: 99.15 GiB (16.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P1MA0V4 temp: 41.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: A-Data model: SX900 size: 119.24 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 2a scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 118.95 GiB size: 116.52 GiB (97.96%)
    used: 99.15 GiB (85.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: b5089fca-1558-4628-b8ce-be93a4357c01
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 316 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: F58C-AECD
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 260 MiB fs: vfat label: SYSTEM
    uuid: AAEA-60E5
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 476.03 GiB fs: ntfs label: OS
    uuid: F4ECEC87ECEC4588
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 650 MiB fs: ntfs label: RECOVERY
    uuid: D26E88386E88177F
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-4:2 info: IMC Networks Bluetooth Radio type: bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 500mA chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-1:2 info: IMC Networks USB2.0 HD UVC WebCam type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Device-2: 3-2:3 info: Logitech Mouse type: mouse driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 1.5 Mb/s (183 KiB/s) lanes: 1 mode: 1.0
    power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Hub-4: 4-0:1 info: super-speed hub ports: 1 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 66.0 C mobo: N/A gpu: amdgpu temp: 66.0 C
  Fan Speeds (RPM): cpu: 2700
  Processes: 278 Uptime: 11m wakeups: 1 Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 alt: 11 clang: 15.0.7 Packages: 1931
  pm: pacman pkgs: 1923 libs: 470 tools: pamac,paru pm: flatpak pkgs: 8
  Shell: Zsh v: 5.9 default: Bash v: 5.2.0 running-in: konsole inxi: 3.3.27

I hope you can help. :slight_smile:

As you are on Unstable then it is probably this:

Thanks, is there any way to fix it?

In the bug report someone mentions downgrading

How could I do that?

lib32-gudev … Downgrading to 237 solves the crash.

The downgrade tool is a common choice

Downgrading packages - ArchWiki

1 Like

Thank you, it worked great. :grinning:

Glad to hear it. Of course take care - downgrading is a sort of last choice and should only be considered temporary. Likely you dont want to add it to IgnorePkg… or if you do then try to remember to remove it and check updates.


It appears another fix is to install lib32-libnm
I have verified that working … and it is probably preferable to the downgrade.

Downgrading is a temporary measure, not a solution.

I’ve also seen people suggest installing lib32-libudev0-shim. I have both installed as dependencies of steam-native-runtime and have no issues with Steam.

Hm. Thats probably the more accurate package.
Its also a fraction of the size, though we are talking kb (1522 vs 13) .
On the other hand do I technically want the compatibility library or just the 32bit of a library already installed? …
meh. :person_shrugging:

I also installed this Package and after a system restart it no longer wont work and steam refused to start.

I found the best-to-date bug thread on this:

Where a number of solutions are outlined … and I think I still prefer the installation of lib32-libnm.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.