[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

Hello community,

Another stable branch update with some usual package updates for you. This also completes our migration of [community] repo to [extra]. [community] is now empty.

Get the lastest SoftMaker Office with ChatGPT buillt-in. You will find our Special Offer here!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Kernels and firmware got updated
  • systemd got renewed to 253.5
  • GNOME is now at 44.2
  • NVIDIA driver is now at 535.54.03
  • ZFS updated to 2.1.12
  • LibreOffice is renewed to 7.5.4
  • QEMU got updated to 8.0.2
  • Qt updated to 5.15.10 and 6.5.1
  • KDE Gear is at 23.04.2
  • KDE Frameworks got updated to 5.107.0
  • Thunderbird is at 102.13.0
  • Plasma is now at 5.27.6
  • With Pamac we have now 11.0.1 based on gtk4 and 10.5.3 based on gtk3
  • Firefox got renewed to 115.0.1
  • Wine got renewed to 8.11
  • legacy Nvidia driver got update to 470.199.02
  • Pipewire is now at 0.3.72
  • Bluez got renewed to 5.68
  • Evolution is updated to 3.48.4
  • Usual KDE-git, Python and Haskell updates

Additional Info

GNOME Layout Switcher: New Tiling Layout

GNOME Layout Switcher: New Tiling Layout

Python 3.11 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.288
  • linux54 5.4.249
  • linux510 5.10.186
  • linux515 5.15.120
  • linux61 6.1.38
  • linux63 6.3.12
  • linux64 6.4.2
  • linux61-rt 6.1.33_rt11
  • linux63-rt 6.3.3_rt15
  • linux64-rt 6.4.0_rt6

Package Changes (Sat Jul 1 19:42:38 CEST 2023)

  • stable community x86_64: 0 new and 10670 removed package(s)
  • stable core x86_64: 92 new and 91 removed package(s)
  • stable extra x86_64: 12252 new and 1656 removed package(s)
  • stable kde-unstable x86_64: 276 new and 445 removed package(s)
  • stable multilib x86_64: 81 new and 80 removed package(s)

A list of all changes can be found in detail here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-07-10

libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release.

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and merge the pacman pacnew /etc/pacman.conf.pacnew file.

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository. No need to remove any packages from cache

sudo pacman -Sc
Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam
Steam crashes at launch with libgudev 238 · Issue #9805 · ValveSoftware/steam-for-linux · GitHub

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

pamac install pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.


All initramfs builds fail with ERROR: Hook ‘zfs’ cannot be found

There was an issue with zfs-utils 2.1.11-1 package having the initcipio files wrongly installed. Please update to zfs-utils 2.1.11-1.1 and re-run mkinitcpio -P. If you have an already unbootable system, you may recover by using an install media and chroot into it to complete the update.


xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11

A bug report was opened on 468217 – xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11 and a temporary fis is also mentioned on Mouse acceleration - ArchWiki

Widgets on Plasma desktop are lost after update


GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators. You have to redo that whenever you update a kernel or call update-grub on your own. You can read more about it here
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key. This happens if you forgot to remove the dashes in /boot/grub/grub.cfg after update-grub got called.

We may add a alpm-hook to grub package to do that monkey job for you automatically. As an alternative you may reinstall grub, as the newer version can handle both cases, including the dashes.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. https://bugzilla.kernel.org/show_bug.cgi?id=217174 Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


I got 404 error for every single package, so I am unable to update; obviously I update the mirrors.

Moderator Edit: Remove useless photo

1 Like

Hi !

I’m stuck !

Error: La préparation de la transaction a échoué: impossible de trouver la cible : haskell-crypton-x509

Solved with

pacman-mirrors || sudo pacman-mirrors --continent; pamac update


With last update pamac-gui have change to :

It would be possible to make him again respect my theme on XFCE.
Normally have this :

Best Regards


If you don’t want the GTK4 UI, you can install pamac-gtk3 instead.


Yes have check theme compatibility and see is GTK3 also have switch to GTK3 now that work.

Thank you.

1 Like

The May 21 unstable announcement said

The [community] repository has been merged into [extra] and is now empty.

but it’s not mentioned here.
Is it all automated now?
Nothing we have to do about it?

:: mangohud and mangohud-common are in conflict. Remove mangohud-common? [y/N] y


error: failed to commit transaction (conflicting files)
mangohud: /usr/bin/mangoapp exists in filesystem (owned by mangoapp)
mangohud: /usr/bin/mangohudctl exists in filesystem (owned by mangoapp)
mangohud: /usr/share/vulkan/implicit_layer.d/libMangoApp.x86_64.json exists in filesystem (owned by mangoapp)
Errors occurred, no packages were upgraded.

seems like mangohud should replace both mangohud-common and mangoapp, but it missed mangoapp.

I’ve refreshed mirrors and databases multiple times and tried using mirrors from different countries but to no avail. This error keeps popping up and the entire update cannot be done.

Tried installing this package from command line but same error is thrown ie. target not found.

Please help?

1 Like

Only a minor hiccup. I used yay to update, and it said local perl-finance-quote (1.54) was newer than extra repository with 1.55 ??? When I check the current version with yay or pamac, it says 1.54 from extra, the same since May 10th. But the listing of all changes (above) shows 1.55. I have refreshed mirrors, but no change. I would like to upgrade, but the upgrade does not seem to be visible.

[SOLUTION] The ol’ uninstall-reinstall tango…


(909/909) checking keys in keyring                                                                       [--------------------------------------------------------------] 100%
downloading required keys...
:: Import PGP key C06086337C50773E, "Jelle van der Waa <jelle@archlinux.org>"? [Y/n] 
error: key "C06086337C50773E" could not be imported
:: Import PGP key 632C3CC0D1C9CAF6, "Balló György <bgyorgy@archlinux.org>"? [Y/n] 
error: key "632C3CC0D1C9CAF6" could not be imported
:: Import PGP key 94657AB20F2A092B, "Andreas Radke <andyrtr@archlinux.org>"? [Y/n] 
error: key "94657AB20F2A092B" could not be imported

Ouch, abandoned at this point… What’s up?

I guess I’ll try again tomorrow. Now I’m getting an annoying pamac error ‘Waiting for another package manager to quit…’ after a reboot too.


Restored a snapshot, synchronised, ran doas pacman -Syu then did pamac upgrade.

All good now, thanks guys (",)

I can’t update the system.
The error “lib32-ducktape not found” occurs. When I try to install pamac-gtk3 I get “pamac-gtk3 not found”.

…I don’t understand why you moved pamac to the damn gtk4… Manjaro gnome is the most unpopular edition. And Canonical’s policy is a dead end and annoying to the community.

Update. My upgrade went smoothly when the local mirrors updated all the packages.
And I migrated to pamac-gtk3, thanks.

1 Like

Pamac maintainer uses Gnome as most of our developers actually do. Hence we moved to GTK4 and made it more mobile friendly.


You can always use pamac-gtk3


I’ll try again tonight, thanks for the heads-up! :+1:

1 Like

Hey guys,
I cannot perform the upgrade. Even after refreshing the mirrors and database I get the following error message with “Target not found”:

Fehler: Vorgang konnte nicht erfolgreich vorbereitet werden: Ziel nicht gefunden: python-rpds-py

The package python-rpds-py is not installed on my system…

1 Like

when I try to update with pamac, the following error message appears:

Ziel nicht gefunden: podofo-0.9

With sudo pacman -Syu the update works.
And now also pamac shows that no more updates are needed.