Pamac not following system theme (3)

After last UPdate (20230710), my Pamac shows up with black background, although all my settings are “light”. All other KDE-applications follow the setting and are “light.” It’s only a problem in Pamac, not a big deal.
If seen postings here and there having recommendations from @Mirdarthos and checked

$  pamac search gtk3
gtk3                                                       [Installiert] 1:3.24.38-1                       extra 
    GObject-based multi-platform GUI toolkit
$  pamac search gtk4
gtk4                                                                  [Installiert] 1:4.10.4-1                extra 
    GObject-based multi-platform GUI toolkit

May be, this is useful to identify the problem?

I think you misunderstood the suggestions elsewhere.
pamac now uses gtk4.
The previous pamac used gtk3 and can be regained by installing pamac-gtk3
(not the package gtk3)

1 Like

Issue with pamac theme was first reported by Xfce user in Testing update 2023-06-24
Pamac-gtk does not match Xfce theme - #7 by pheiduck

Stable update [2023-07-10]

Known issues and solutions

▼ Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

pamac install pamac-gtk3

Though its not entirely accurate … users could create relevant files in gtk4 … especially if their theme provides gtk4 configs.

Thank you!

But for my understanding pamac should follow the system settings with gtk4 as well. How can I find other software on my sysetm using gtk4 (just to comapre …)?

Sorta. But not as well.
Try and make sure to re-apply your GTK theme and Color Scheme in System Settings.
(it should create files in ~/.config/gtk-4.0)

pactree -r gtk4

Thank you!

$  pactree -r gtk4
│ └─bottles
│ ├─bottles
│ ├─pamac-gtk
│ │ ├─manjaro-application-utility
│ │ │ └─manjaro-hello
│ │ └─pamac-tray-icon-plasma
│ └─youplay
│ └─bottles

Bad: All these programs show black background …
Started SystemSetting and modified Gnome/GTK as shown in the screenshot:

The timestamp in file ~.config/gtk-4.0/settings.ini is actualized but the programs still black …

In my topic below, it was established that pamac-gtk is gtk4 version that is tied to libadwaita and won’t follow Plasma gtk theming (aside light and dark mode that is ruled by Colors section).

Basically, non-Gnome desktops are encouraged to use pamac-gtk3 instead, where Plasma gtk theming works well.

1 Like