[Fix] System doesn’t boot, boots to a black screen, or stops at a message

Difficulty: ★☆☆☆☆

Original author in old forum was @jonathon

While there are many potential reasons why your Manjaro installation doesn’t boot to a desktop, the primary reason is that the graphics drivers haven’t loaded correctly so your login/display manager (DM) doesn’t start. This is why you get a “black screen” or stuck at an

[   OK   ] Started some service


The normal reason for this is that you have the incorrect driver version for the kernel. This happens when the mirror you are updating from is not fully synchronised and so has different sets of packages in [core] and [extra]. This means the driver extramodule package in [extra] has been built for a different kernel point-release than that in [core].

The first thing to try

Switch to a text console with CTRL+ALT+F2, log in with your normal username and password, then run a full update:

sudo pacman-mirrors -f3
sudo pacman -Syyu

The first command will refresh your mirror list, picking three of the most recently updated mirrors (so those mirrors will all be up-to-date).

The second command will force a download of the current package lists, then perform an update if any updated packages are available.

If any packages were updated, reboot.

Note: If you can’t log in to a text console, use a chroot instead.

The second thing to try

Log into a text console as above and run startx . This should either start X, in which case the issue lies with your Display Manager (e.g. GDM, LightDM, SDDM), OR you will be presented with some output and returned to the console. Of particular interest are Error (EE) lines.

If you can’t see anything obvious

If neither approach helps fix this issue (which the first one will in 90% of cases) then search the forum (Search results for 'black screen' - Manjaro Linux Forum), and, if you can’t find anything, start a new thread mentioning what you have already tried.

If you want more detailed instructions

Read this thread:

Unable to reach the login screen unless I swtich through ttys a few times
Black screen on login (Lenovo V15 ADA AMD 3020E)
Stuck at blinking cursor at boot after update
Black screen on dual-boot install; no cursor and no console
Black screen at login for 10 minutes
[Solved] Booting to black screen
I have to reinstall my GPU drivers after every reboot
Manjaro boots to a black screen
NVIDIA drivers, boot to black screen
Well I've done it again. No video signal
[HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc)
Failed to load/start module acpi_backlight errors in manjaro
I installed Manjaro but after the installation when I try to boot into it I get a black screen
Good morning black screen
My system boots at a black screen and at the top left corner says ''GRUB'' and it doesnt let me type or do anything else
Manjaro KDE se congela a punto de cargar el escritorio (kwallet puede estar relacionado)
Stuck at login screen after entering password
Manjaro boots to black screen after Grub
Unable to boot from hd or USB after crash
Manjaro (KDE) completely black screen
Latest Manjaro XFCE Update
Manjaro wont boot to desktop on USB live media
Cant boot anymore after command pkill x
[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps
Boot doesn't continue
Stuck at screen
How to install GRUB in Manjaro?
Manjaro, boot Grub, error, ideas
Black screen after switching to OSS driver (from proprietary nvidia)
Black screen with cursor
Keyboard and Mouse not working
Manjaro not booting on HP Pavilion 15-ec1028ns
Stuck on /dev/sdb2 clean on boot; how do I remove video drivers l?
Blank screen booting Manjaro ISO USB
Black screen with Cross cursor after login page
Stuck at flashing motherboard logo screen after GRUB (Laptop)
Boots to black screen after update
Optirun failing after latest Manjaro Update
Manjaro froze, after hard reset won't turn on
New install, Nvidia proprietary driver black screen
Black Screen With Cursor (top left) Instead of Login Screen
System doesn't boot, gets stuck on '[OK] Reached Graphical Interface' with the mouse cursor
Limited replies for new user
What are the most common questions (FAQ) in forum
What are the most common questions (FAQ) in forum
What are the most common questions (FAQ) in forum
KDE plasma freezes all the time
Screen Off on Boot
Black screen after [Stable Update] 2020-11-18
Multiple problems after update, some probably caused by my "repairs"
Dual boot ubuntu 20.04 black screen on boot

I had black screen after install of kernel 5.8 and 5.9rc. But I discovered it was due to nvidia. Reference:

I hope it will help in some cases. Now I am able to run 5.9 with free driver.

I solved the issue by reinstall NVIDIA Drivers.

  1. Remove the NVIDIA driver by entering the following command into your terminal:
    sudo mhwd -r pci video-nvidia

  2. Reboot your computer

  3. Enter the following into your terminal:
    sudo gedit /etc/mkinitcpio.conf

  4. delete the word nouveau from the following line:
    MODULES=" nouveau"
    It should now look like this (i.e. keep the speech marks ("")):

  5. Save and close the file.

  6. It is now necessary to reconfigure your existing kernel to take into account this change. The syntax of the necessary command to enter into your terminal is:
    sudo mkinitcpio -p [linux kernel version]
    For example, if you are currently using Kernel 5.10, you would enter the following:
    sudo mkinitcpio -p linux510

  7. Now re-install the NVIDIA driver by entering the following command into your terminal:
    sudo mhwd -a pci nonfree 0300

  8. Reboot your system. Now it should work :wink:



Sorry but before install manjaro with gnome, I’m not access show black screen and not create user and password

try with root/manjaro and manjaro/manjaro
and nothing

You are a lifesaver, this worked without a hitch!

Just a heads up though, not everyone is going to have gedit installed. A better alternative would be to use vim, even tough in my case it was completely unnecessary since I didn’t have to do step 4.

1 Like

The post doesn’t mention how to proceed with the issue corresponding to

This should either start X, in which case the issue lies with your Display Manager (e.g. GDM, LightDM, SDDM)

I am currently able to boot into my system using startx via tty but the login page GUI is still stuck. I’d like to get some help on that part. Also, newbie here, if you feel this needs to be raised as a separate question post entirely. Thank you.

Not everyone has vim installed as well. Nano is in manjaro by default however as a gnu tool.

1 Like