Unable to boot after update 19.5. 2023 - black screen freeze

Hi all,

I run kernel 5.15. Since last kernel update (which I did on 19.5.2023) I can’t boot to Manjaro.

Normally I get the screen followed by blinking cursor, that says something like:
/dev/mapper/luks-49.......1e1: clean 11....03/19...76 files 73..57/79..44 blocks

And then I get graphical login page:
But this time after the update the cursor freezes and Manjaro never boots.

I tried [Fix] System doesn’t boot, boots to a black screen, or stops at a message
But I can’t switch to other console and not even start Manjaro directly into runlevel 3 by modifying Grub.

Only thing that worked was to select initramfs fallback option in Grub.

However, then I recreated initramfs images and I lost even that option:
sudo mkinitcpio -P

So right now, the only option I have is to boot to older, unsuported Kernel 5.13. Which I obviously don’t want to use.

From 5.13 I tried to install other kernels (6.1; 5.10) but all of them have the same problem. With 6.1 I get only the black screen.

My inxi report:

I am using Manjaro Mate.

Thank you in advance for any suggestions.

Did you see this?

Hello megavolt, thank you for answer!

I used to have the same “no disk found error” in the past, but I never really paid much attention to it, because system automatically booted few seconds after without any further problems. Also, recently this error message ceased to appear (way before this error)

I checked the /boot/grub/grub.cfg as you suggested, but there are no dashes anywhere near cryptsetup.
Full config is here:
manjaro-grubcfg - Pastebin.com.

I have removed “quiet” parameter to find out that system always hangs after
Finished File System check on /dev/disk/by-uuid/12AE-EE30

Also it seems to me, that system is able to mount and decrypt encrypted partition, otherwise it wouldn’t get that far.

Btw. Strangely enough I managed to boot into 5.15 once. I did some editing in grub, booted. It failed and I got dropped into emergency shell. I restarted it, then it booted. When I restarted it again, I am back at the old problem.

@ripfruit after a quick look I saw this:

  ID-1: / raw-size: 303.49 GiB size: 297.66 GiB (98.08%)
    used: 268.17 GiB (90.1%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0

Take that into account for ext4:

  • 1 % → file system, also called metadata
  • 5% → reserved space for root
  • 5-10% → ext4 journal

303.49 - 16% = 254.93

303.49 - 11% = 270.10

Take into account that encryption has also its extra space. So I conclude: Your root disk is just full and if you run lightdm as login-manager it won’t run if no space is available.

Thank you, but I don’t think that it is a problem in this case.
I can boot 5.13 kernel into the same GUI fast and without any problem. 5.15 could as well, until the last update.
Also, the system freezes even when it should boot only to runlevel 3.

Nevertheless, I freed some space, but the problem persists.

Can you share the full journal when booting another kernel than 5.13?

Sure, here it is, unsuccesfull 5.15:

Here is succesfull 5.13

I obtained it with
journalctl -b -1 and journalctl -b 0

Is it the log you need?

When boot freezes, I usually hard kill it. Now just thinking:
All previous boot logs ends with
kvě 25 22:46:55 automaton systemd-journald[339]: Time spent on flushing to /var/log/journal/9b6b597c07c04b33ac94870b748879b7 is 16.957ms for 959 entries.
(With different ms time)
So I wonder whether I shouldn’t let it just be. However, once last week I let it frozen for 30+ minutes and there was no change. Also the disk utilization is 2.6 GB according to
journalctl --disk-usage
And again, this doesn’t explain why it is not problem in 5.13