Black screen after [Stable Update] 2020-11-18

Hi,

since last stable update, desktop won’t start, just a black screen, switching to kernel 5.4/5.8/fallback initramfs did not change anything, please help.

(I’ve fixed the ext4 errors, but it did not solve the problem, I assume they have been there longer.)
I tried the solutions from [Fix] System doesn’t boot, boots to a black screen, or stops at a message but my packages are up-to-date and startx does not return an Error, but just waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.e: No such file or directoryxinit: connection to X server lost

System:
Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64

Machine:
Type: Laptop System: Dell product: XPS 13 9350 v: N/A serial:
Chassis: type: 9 serial:
Mobo: Dell model: 07TYC2 v: A01 serial: UEFI: Dell v: 1.13.0

Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:1916
Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo
bus ID: 1-5:5 chip ID: 0c45:670c
Display: server: X.org 1.20.9 driver: intel unloaded: modesetting
alternate: fbdev,vesa tty: 200x56

dmesg -l emerg,alert,crit,err,warn:

[ 0.079437] DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x000000007b800000-0x000000007fffffff], contact BIOS vendor for fixes
[ 0.079438] DMAR: [Firmware Bug]: Your BIOS is broken; bad RMRR [0x000000007b800000-0x000000007fffffff]
BIOS vendor: Dell Inc.; Ver: 1.13.0; Product Version:
[ 0.109996] MDS CPU bug present and SMT on, data leak possible. See MDS - Microarchitectural Data Sampling — The Linux Kernel documentation for more details.
[ 0.109996] #3
[ 0.113497] ENERGY_PERF_BIAS: Set to ‘normal’, was ‘performance’
[ 0.950499] i8042: Warning: Keylock active
[ 0.972366] usb: port power management may be unreliable
[ 2.456014] sd 8:0:0:0: [sda] Asking for cache data failed
[ 2.456015] sd 8:0:0:0: [sda] Assuming drive cache: write through
[ 4.670954] EXT4-fs (dm-0): warning: mounting fs with errors, running e2fsck is recommended
[ 8.140304] EXT4-fs (dm-0): warning: mounting fs with errors, running e2fsck is recommended
[ 9.798663] ACPI Warning: _SB.IETM._ART: Return Package type mismatch at index 0 - found Integer, expected Reference (20200717/nspredef-258)
[ 9.798673] ACPI: Invalid package element [0]: got number, expecting [R]
[ 9.798674] _ART package 0 is invalid, ignored
[ 9.940841] wmi_bus wmi_bus-PNP0C14:01: WQBC data block query control method not found
[ 10.021523] i2c_hid i2c-DLL0704:01: supply vdd not found, using dummy regulator
[ 10.021560] i2c_hid i2c-DLL0704:01: supply vddl not found, using dummy regulator
[ 10.851040] snd_hda_intel 0000:00:1f.3: NHLT table not found
[ 10.999889] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4350-pcie for chip BCM4350/8
[ 11.009763] brcmfmac 0000:3a:00.0: Direct firmware load for brcm/brcmfmac4350-pcie.Dell Inc.-XPS 13 9350.txt failed with error -2
[ 11.009788] brcmfmac 0000:3a:00.0: Direct firmware load for brcm/brcmfmac4350-pcie.txt failed with error -2
[ 11.457433] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4350-pcie for chip BCM4350/8
[ 11.457469] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 11.457730] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4350/8 wl0: Oct 22 2015 06:16:26 version 7.35.180.119 (r594535) FWID 01-e791c176
[ 12.009580] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[ 12.009584] Bluetooth: hci0: BCM: ‘brcm/BCM4350C5-0a5c-6412.hcd’
[ 12.009586] Bluetooth: hci0: BCM: ‘brcm/BCM-0a5c-6412.hcd’
[ 12.480169] EXT4-fs error (device dm-0): ext4_validate_block_bitmap:385: comm systemd: bg 1296: bad block bitmap checksum
[ 12.725426] EXT4-fs error (device dm-0): ext4_validate_inode_bitmap:100: comm snapd: Corrupt inode bitmap - block_group = 1280, inode_bitmap = 41943056
[ 14.464703] kauditd_printk_skb: 34 callbacks suppressed
[ 20.750629] kauditd_printk_skb: 7 callbacks suppressed
[ 5031.729779] smpboot: Scheduler frequency invariance went wobbly, disabling!
[ 5032.051081] usb 2-2: Disable of device-initiated U1 failed.
[ 5032.054468] usb 2-2: Disable of device-initiated U2 failed.
[ 5033.918346] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[ 5033.918348] Bluetooth: hci0: BCM: ‘brcm/BCM4350C5-0a5c-6412.hcd’
[ 5033.918349] Bluetooth: hci0: BCM: ‘brcm/BCM-0a5c-6412.hcd’
[ 5164.099513] kauditd_printk_skb: 1 callbacks suppressed
[ 5224.964462] kauditd_printk_skb: 10 callbacks suppressed

From /var/log/Xorg.0.log:

[    13.505] Build Date: 17 November 2020  03:15:53PM
[    13.505]  
[    13.505] Current version of pixman: 0.40.0
[    13.505] 	Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    13.505] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    13.505] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 21 17:51:59 2020
[    13.506] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    13.506] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    13.507] (==) No Layout section.  Using the first Screen section.
[    13.507] (==) No screen section available. Using defaults.
[    13.507] (**) |-->Screen "Default Screen Section" (0)
[    13.507] (**) |   |-->Monitor "<default monitor>"
[    13.507] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    13.507] (==) Automatically adding devices
[    13.507] (==) Automatically enabling devices
[    13.507] (==) Automatically adding GPU devices
[    13.507] (==) Automatically binding GPU devices
[    13.507] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    13.510] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    13.510] 	Entry deleted from font path.
[    13.510] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    13.510] 	Entry deleted from font path.
[    13.510] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[    13.510] 	Entry deleted from font path.
[    13.510] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[    13.510] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[    13.510] 	Entry deleted from font path.
[    13.510] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[    13.510] (==) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/TTF
[    13.510] (==) ModulePath set to "/usr/lib/xorg/modules"
[    13.510] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    13.510] (II) Module ABI versions:
[    13.510] 	X.Org ANSI C Emulation: 0.4
[    13.510] 	X.Org Video Driver: 24.1
[    13.510] 	X.Org XInput driver : 24.1
[    13.510] 	X.Org Server Extension : 10.0
[    13.511] (++) using VT number 1

[    13.511] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    13.512] (II) xfree86: Adding drm device (/dev/dri/card0)
[    13.512] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[    13.525] (--) PCI:*(0@0:2:0) 8086:1916:1028:0704 rev 7, Mem @ 0xdb000000/16777216, 0x90000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    13.525] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    13.525] (II) LoadModule: "glx"
[    13.527] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    13.538] (II) Module glx: vendor="X.Org Foundation"
[    13.538] 	compiled for 1.20.9, module version = 1.0.0
[    13.538] 	ABI class: X.Org Server Extension, version 10.0
[    13.538] (==) Matched intel as autoconfigured driver 0
[    13.538] (==) Matched modesetting as autoconfigured driver 1
[    13.538] (==) Matched fbdev as autoconfigured driver 2
[    13.538] (==) Matched vesa as autoconfigured driver 3
[    13.538] (==) Assigned the driver to the xf86ConfigLayout
[    13.538] (II) LoadModule: "intel"
[    13.538] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    13.542] (II) Module intel: vendor="X.Org Foundation"
[    13.542] 	compiled for 1.20.9, module version = 2.99.917
[    13.542] 	Module class: X.Org Video Driver
[    13.542] 	ABI class: X.Org Video Driver, version 24.1
[    13.542] (II) LoadModule: "modesetting"
[    13.542] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    13.545] (II) Module modesetting: vendor="X.Org Foundation"
[    13.545] 	compiled for 1.20.9, module version = 1.20.9
[    13.545] 	Module class: X.Org Video Driver
[    13.545] 	ABI class: X.Org Video Driver, version 24.1
[    13.545] (II) LoadModule: "fbdev"
[    13.547] (WW) Warning, couldn't open module fbdev
[    13.547] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    13.547] (II) LoadModule: "vesa"
[    13.547] (WW) Warning, couldn't open module vesa
[    13.547] (EE) Failed to load module "vesa" (module does not exist, 0)
[    13.547] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    13.548] (II) intel: Driver for Intel(R) HD Graphics
[    13.548] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    13.548] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    13.548] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    13.548] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20200715
[    13.548] (II) intel(0): SNA compiled from 2.99.917-912-gad5540f6
[    13.549] (WW) Falling back to old probe method for modesetting
[    13.550] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 520
[    13.550] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[    13.551] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    13.551] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    13.551] (==) intel(0): RGB weight 888
[    13.551] (==) intel(0): Default visual is TrueColor
[    13.551] (II) intel(0): Output eDP1 has no monitor section
[    13.552] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    13.552] (II) intel(0): Enabled output eDP1
[    13.552] (II) intel(0): Output DP1 has no monitor section
[    13.552] (II) intel(0): Enabled output DP1
[    13.552] (II) intel(0): Output HDMI1 has no monitor section
[    13.552] (II) intel(0): Enabled output HDMI1
[    13.552] (II) intel(0): Output DP2 has no monitor section
[    13.552] (II) intel(0): Enabled output DP2
[    13.552] (II) intel(0): Output HDMI2 has no monitor section
[    13.552] (II) intel(0): Enabled output HDMI2
[    13.552] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    13.552] (II) intel(0): Output VIRTUAL1 has no monitor section
[    13.552] (II) intel(0): Enabled output VIRTUAL1
[    13.552] (--) intel(0): Output eDP1 using initial mode 3200x1800 on pipe 0
[    13.553] (==) intel(0): TearFree disabled
[    13.553] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[    13.553] (==) intel(0): DPI set to (96, 96)
[    13.553] (II) Loading sub module "dri3"
[    13.553] (II) LoadModule: "dri3"
[    13.553] (II) Module "dri3" already built-in
[    13.553] (II) Loading sub module "dri2"
[    13.553] (II) LoadModule: "dri2"
[    13.553] (II) Module "dri2" already built-in
[    13.553] (II) Loading sub module "present"
[    13.553] (II) LoadModule: "present"
[    13.553] (II) Module "present" already built-in
[    13.553] (II) UnloadModule: "modesetting"
[    13.553] (II) Unloading modesetting
[    13.556] (II) intel(0): SNA initialized with Skylake (gen9) backend
[    13.556] (==) intel(0): Backing store enabled
[    13.556] (==) intel(0): Silken mouse disabled
[    13.556] (II) intel(0): HW Cursor enabled
[    13.557] (==) intel(0): DPMS enabled
[    13.557] (==) intel(0): Display hotplug detection enabled
[    13.558] (II) intel(0): [DRI2] Setup complete
[    13.558] (II) intel(0): [DRI2]   DRI driver: i965
[    13.558] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    13.558] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[    13.558] (II) intel(0): hardware support for Present enabled
[    13.558] (II) Initializing extension Generic Event Extension
[    13.558] (II) Initializing extension SHAPE
[    13.558] (II) Initializing extension MIT-SHM
[    13.559] (II) Initializing extension XInputExtension
[    13.559] (II) Initializing extension XTEST
[    13.559] (II) Initializing extension BIG-REQUESTS
[    13.559] (II) Initializing extension SYNC
[    13.560] (II) Initializing extension XKEYBOARD
[    13.560] (II) Initializing extension XC-MISC
[    13.560] (II) Initializing extension SECURITY
[    13.560] (II) Initializing extension XFIXES
[    13.561] (II) Initializing extension RENDER
[    13.561] (II) Initializing extension RANDR
[    13.561] (II) Initializing extension COMPOSITE
[    13.561] (II) Initializing extension DAMAGE
[    13.561] (II) Initializing extension MIT-SCREEN-SAVER
[    13.561] (II) Initializing extension DOUBLE-BUFFER
[    13.561] (II) Initializing extension RECORD
[    13.561] (II) Initializing extension DPMS
[    13.562] (II) Initializing extension Present
[    13.562] (II) Initializing extension DRI3
[    13.562] (II) Initializing extension X-Resource
[    13.562] (II) Initializing extension XVideo
[    13.562] (II) Initializing extension XVideo-MotionCompensation
[    13.562] (II) Initializing extension GLX
[    13.605] (II) AIGLX: Loaded and initialized i965
[    13.605] (II) GLX: Initialized DRI2 GL provider for screen 0
[    13.605] (II) Initializing extension XFree86-VidModeExtension
[    13.605] (II) Initializing extension XFree86-DGA
[    13.606] (II) Initializing extension XFree86-DRI
[    13.606] (II) Initializing extension DRI2
[    13.616] (II) intel(0): switch to mode 3200x1800@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    13.623] (II) intel(0): Setting screen physical size to 846 x 476
[    13.728] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    13.728] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    13.728] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    13.729] (**) Power Button: Applying InputClass "system-keyboard"
[    13.729] (II) LoadModule: "libinput"
[    13.729] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    13.734] (II) Module libinput: vendor="X.Org Foundation"
[    13.734] 	compiled for 1.20.8, module version = 0.30.0
[    13.734] 	Module class: X.Org XInput Driver
[    13.734] 	ABI class: X.Org XInput driver, version 24.1
[    13.734] (II) Using input driver 'libinput' for 'Power Button'
[    13.734] (**) Power Button: always reports core events
[    13.734] (**) Option "Device" "/dev/input/event3"
[    13.734] (**) Option "_source" "server/udev"
[    13.742] (II) event3  - Power Button: is tagged by udev as: Keyboard
[    13.742] (II) event3  - Power Button: device is a keyboard
[    13.742] (II) event3  - Power Button: device removed
[    13.785] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[    13.785] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    13.785] (**) Option "xkb_model" "pc105"
[    13.785] (**) Option "xkb_layout" "de"
[    13.785] (**) Option "xkb_variant" "nodeadkeys"
[    13.845] (II) event3  - Power Button: is tagged by udev as: Keyboard
[    13.846] (II) event3  - Power Button: device is a keyboard
[    13.847] (II) config/udev: Adding input device Video Bus (/dev/input/event13)
[    13.847] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    13.848] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    13.848] (**) Video Bus: Applying InputClass "system-keyboard"
[    13.848] (II) Using input driver 'libinput' for 'Video Bus'
[    13.848] (**) Video Bus: always reports core events
[    13.848] (**) Option "Device" "/dev/input/event13"
[    13.848] (**) Option "_source" "server/udev"
[    13.851] (II) event13 - Video Bus: is tagged by udev as: Keyboard
[    13.851] (II) event13 - Video Bus: device is a keyboard
[    13.851] (II) event13 - Video Bus: device removed
[    13.889] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input21/event13"
[    13.889] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    13.889] (**) Option "xkb_model" "pc105"
[    13.889] (**) Option "xkb_layout" "de"
[    13.889] (**) Option "xkb_variant" "nodeadkeys"
[    13.894] (II) event13 - Video Bus: is tagged by udev as: Keyboard
[    13.894] (II) event13 - Video Bus: device is a keyboard
[    13.896] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    13.896] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    13.896] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    13.896] (**) Power Button: Applying InputClass "system-keyboard"
[    13.896] (II) Using input driver 'libinput' for 'Power Button'
[    13.896] (**) Power Button: always reports core events
[    13.896] (**) Option "Device" "/dev/input/event1"
[    13.896] (**) Option "_source" "server/udev"
[    13.899] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    13.899] (II) event1  - Power Button: device is a keyboard
[    13.899] (II) event1  - Power Button: device removed
[    13.929] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1/event1"
[    13.929] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    13.929] (**) Option "xkb_model" "pc105"
[    13.929] (**) Option "xkb_layout" "de"
[    13.929] (**) Option "xkb_variant" "nodeadkeys"
[    13.933] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    13.933] (II) event1  - Power Button: device is a keyboard
[    13.935] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    13.935] (II) No input driver specified, ignoring this device.
[    13.935] (II) This device may have been added with another device file.
[    13.936] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[    13.936] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    13.936] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[    13.936] (**) Sleep Button: Applying InputClass "system-keyboard"
[    13.937] (II) Using input driver 'libinput' for 'Sleep Button'
[    13.937] (**) Sleep Button: always reports core events
[    13.937] (**) Option "Device" "/dev/input/event2"
[    13.937] (**) Option "_source" "server/udev"
[    13.940] (II) event2  - Sleep Button: is tagged by udev as: Keyboard
[    13.940] (II) event2  - Sleep Button: device is a keyboard
[    13.940] (II) event2  - Sleep Button: device removed
[    13.959] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2/event2"
[    13.959] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[    13.959] (**) Option "xkb_model" "pc105"
[    13.959] (**) Option "xkb_layout" "de"
[    13.959] (**) Option "xkb_variant" "nodeadkeys"
[    13.963] (II) event2  - Sleep Button: is tagged by udev as: Keyboard
[    13.963] (II) event2  - Sleep Button: device is a keyboard
[    13.967] (II) config/udev: Adding input device ELAN Touchscreen (/dev/input/event5)
[    13.968] (**) ELAN Touchscreen: Applying InputClass "evdev touchscreen catchall"
[    13.968] (**) ELAN Touchscreen: Applying InputClass "libinput touchscreen catchall"
[    13.968] (II) Using input driver 'libinput' for 'ELAN Touchscreen'
[    13.968] (**) ELAN Touchscreen: always reports core events
[    13.968] (**) Option "Device" "/dev/input/event5"
[    13.968] (**) Option "_source" "server/udev"
[    13.973] (II) event5  - ELAN Touchscreen: is tagged by udev as: Touchscreen
[    13.973] (II) event5  - ELAN Touchscreen: device is a touch device
[    13.974] (II) event5  - ELAN Touchscreen: device removed
[    14.009] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/0003:04F3:20D0.0001/input/input10/event5"
[    14.009] (II) XINPUT: Adding extended input device "ELAN Touchscreen" (type: TOUCHSCREEN, id 10)
[    14.009] (**) Option "AccelerationScheme" "none"
[    14.009] (**) ELAN Touchscreen: (accel) selected scheme none/0
[    14.009] (**) ELAN Touchscreen: (accel) acceleration factor: 2.000
[    14.009] (**) ELAN Touchscreen: (accel) acceleration threshold: 4
[    14.015] (II) event5  - ELAN Touchscreen: is tagged by udev as: Touchscreen
[    14.015] (II) event5  - ELAN Touchscreen: device is a touch device
[    14.018] (II) config/udev: Adding input device ELAN Touchscreen (/dev/input/mouse0)
[    14.018] (II) No input driver specified, ignoring this device.
[    14.018] (II) This device may have been added with another device file.
[    14.021] (II) config/udev: Adding input device ELAN Touchscreen UNKNOWN (/dev/input/event6)
[    14.021] (II) No input driver specified, ignoring this device.
[    14.021] (II) This device may have been added with another device file.
[    14.023] (II) config/udev: Adding input device ELAN Touchscreen UNKNOWN (/dev/input/event7)
[    14.023] (II) No input driver specified, ignoring this device.
[    14.023] (II) This device may have been added with another device file.
[    14.026] (II) config/udev: Adding input device Integrated_Webcam_HD: Integrate (/dev/input/event21)
[    14.026] (**) Integrated_Webcam_HD: Integrate: Applying InputClass "evdev keyboard catchall"
[    14.026] (**) Integrated_Webcam_HD: Integrate: Applying InputClass "libinput keyboard catchall"
[    14.026] (**) Integrated_Webcam_HD: Integrate: Applying InputClass "system-keyboard"
[    14.026] (II) Using input driver 'libinput' for 'Integrated_Webcam_HD: Integrate'
[    14.026] (**) Integrated_Webcam_HD: Integrate: always reports core events
[    14.026] (**) Option "Device" "/dev/input/event21"
[    14.026] (**) Option "_source" "server/udev"
[    14.030] (II) event21 - Integrated_Webcam_HD: Integrate: is tagged by udev as: Keyboard
[    14.030] (II) event21 - Integrated_Webcam_HD: Integrate: device is a keyboard
[    14.031] (II) event21 - Integrated_Webcam_HD: Integrate: device removed
[    14.069] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input29/event21"
[    14.069] (II) XINPUT: Adding extended input device "Integrated_Webcam_HD: Integrate" (type: KEYBOARD, id 11)
[    14.069] (**) Option "xkb_model" "pc105"
[    14.069] (**) Option "xkb_layout" "de"
[    14.069] (**) Option "xkb_variant" "nodeadkeys"
[    14.074] (II) event21 - Integrated_Webcam_HD: Integrate: is tagged by udev as: Keyboard
[    14.074] (II) event21 - Integrated_Webcam_HD: Integrate: device is a keyboard
[    14.077] (II) config/udev: Adding input device DLL0704:01 06CB:76AE Mouse (/dev/input/event10)
[    14.077] (**) DLL0704:01 06CB:76AE Mouse: Applying InputClass "evdev pointer catchall"
[    14.077] (**) DLL0704:01 06CB:76AE Mouse: Applying InputClass "libinput pointer catchall"
[    14.077] (II) Using input driver 'libinput' for 'DLL0704:01 06CB:76AE Mouse'
[    14.077] (**) DLL0704:01 06CB:76AE Mouse: always reports core events
[    14.077] (**) Option "Device" "/dev/input/event10"
[    14.077] (**) Option "_source" "server/udev"
[    14.082] (II) event10 - DLL0704:01 06CB:76AE Mouse: is tagged by udev as: Mouse Pointingstick
[    14.083] (II) event10 - DLL0704:01 06CB:76AE Mouse: device is a pointer
[    14.086] (II) event10 - DLL0704:01 06CB:76AE Mouse: device removed

sudo systemctl --failed

  UNIT LOAD ACTIVE SUB DESCRIPTION
0 loaded units listed

Wow, there are a lot of BIOS related errors there. However, 1.13.0 is the most recent version which you already have.

Have you gone over the Arch wiki article? Dell XPS 13 (9350) - ArchWiki

Yes, I upgraded to the latest 1.13.0 after seeing these errors, but it had no effect.

Not recently, it worked for a year or so (also with kernel 5.9), but the latest update broke it. I can’t find a solution there.

Do you have any timeshift backup on your machine by any chance? If so you can revert back to the previous backup when it was working and take if from there using the Manjaro startup disk.

Not on that machine, unfortunately there was not much disk space.
But what do you mean by “Manjaro startup disk” - a live usb?

Well, you could use the Manjaro 20.1 ISO that you’d created on a USB stick and boot from it . Then you can launch the application menu and run timeshift, and restore the system to what ever back up you have. I do a backup every time before I update the system, because you never know!

There is no backup, but I can boot and access all files with tty, there is just no GUI at all (not even the KDE logo), so I can’t work with it like normal.

For example if I try playing a video with mpv from tty, I get
Error opening/initializing the selected video_out (--vo) device.

Or if I try launching firefox I get
Error: no DISPLAY environment variable specified

Using startx to launch the GUI doesn’t work:
waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.e: No such file or directoryxinit: connection to X server lost

There must be a way to fix this.

Seems like there is a problem with sddm:

systemctl status sddm.service

Loaded: loaded …
Active: inactive …

sddm-helper[786]: [PAM] Closing session
sddm-helper[786]: pam_unix(sddm-autologin:session): session closed for user anthony
sddm[756]: Auth: sddm-helper exited with 1
sddm[756]: Auth: Signal received SIGTERM
systemd[1]: Stopping Simple Desktop Display Manager…
sddm[756]: Display server stopping…
sddm[756]: Display server stopped.
sddm[756]: Running display stop script “/usr/share/sddm/scripts/Xstop”
systemd[1]: sddm service: Succeeded.
systemd[1]: sddm service: Stopped Simple Desktop Display Manager.

If I follow the advice here Failed to start Simple Desktop Display Manager
system is up-to-date
systemctl stop sddm - takes me back to the screen with output from boot,
startplasma-x11 - returns “$DISPLAY is not set or cannot connect to the X server”

Perhaps it does have to do with this [Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa after all.

Downgrading sddm to 0.18.1-2 did not solve it unfortunately, but now there is a mouse pointer visible after booting (while the boot output are still visible and nothing else happens)

Downgrading to sddm 0.18.1-3 solved it!
pacman -U /var/cache/pacman/pkg/sddm-0.18.1-3-x86_64.pkg.tar.zst