Unable to shutdown with AMD Radeon 7800XT

Hey folks,

TL;DR: Can’t fully turn off my computer, how can I find out what causes this, I suspect the GPU?

I am pretty new to Manjaro, coming from Linux Mint hoping a newer Kernel would fix my issue but unfortunately it didn’t so far.
I’ve been silently reading on this issue for about 10 months now. I’ll try to explain what I think is going on.
Last year I got myself a new computer(I’ll list the components below) and I’m pretty happy about how everything works except for the fact that I can’t shut that thing down. Sleep mode works well and it’s what I use 99% of the time now. I can reboot without any issues and every once in a while I try to shutdown and it looks good in the beginning, like a shutdown is supposed to look, and the screens turn dark but then the computer remains running. In this state I am totally locked out, I can only force turn off the system by pressing and holding the power button.
This is not a Manjaro issue but I decided to stay with Manjaro so this is why I am asking for advice here.
I had the same issue with a pretty old default Kernel on Linux Mint and the issue slightly changed in the meantime.
I did a lot of research on this and I am very sure that my issue is highly related to this:
https://bbs.archlinux.org/viewtopic.php?id=289227
I too had rebootloops at some point but now it’s just a system that becomes unresponsive during shutdown. The guy in that thread apparently solved that problem with a specific Kernel version so that’s why I think this issue is about the Kernel.

Unfortunately I can’t even prove or determine that this is my issue because I lack troubleshooting skills on Manjaro, especially when I have to dive that deep.

While I would love an instant solution I mostly came here for troubleshooting advice.
I know there are logfiles about the activities during the shutdown process as I have seen them on other forums. Can anyone help me how to find these logfiles?

I am so sure it’s something about the GPU but of course that’s just an assumption based on issues other people had, so I really would like more information.

I’m running a pretty much up to date Manjaro with the Kernel Version 6.9.5-1, KDE 6

These are the components in use:

CPU:
AMD Ryzen 7 7700X

GPU:
16GB PowerColor Radeon RX 7800 XT Red Devil

Mainboard:
ASRock B650M PRO RS AM5

Cooler:
Endorfy Fortis 5 Cooler

SSD
2TB Lexar NM790

RAM
32GB (2x 16GB) G.Skill Flare EXPO X5 DDR5-6000 DIMM

PSU:
750 Watt be quiet! Pure Power 12 M Modular 80+ Gold

Oh and I hate to admit this but as part of troubleshooting I tried Windows 10 as well and everything worked fine there, so I am confident that it’s not a faulty piece of hardware.

Kind regards
kismet

What if you install kernels 6.6 and 6.1 and try them? Select the kernel to boot on (not the fallback version) in grub at boot.

Everything is better than a hard shutdown right? I would at least try to wake up your PC with:

Maybe reactivate your system with crlt+alt+f3 for TTY (hope it works) and crlt+alt+f2 for back to desktop or try to shutdown from TTY with shutdown commands like:
shutdown -P now

There are other shutdown commands available too.

Btw. since how long you experience this shutdown problems?

Removing Plymouth with deleting this both commands:
quiet splash from Grub, this should atleast show you the steps what your system is doing before its shutdown and probably, where it stucks.

And after saving the Grub file, don’t forget this command:
sudo grub-mkconfig -o /boot/grub/grub.cfg

Here is the Tutorial, but that info that i gave you should already be enough:

1 Like

You can view logfiles with journalctl. Use the --boot=-1 option to view the log from the previous boot. So on the next start after a failed shutdown

journalctl --boot=-1 --no-pager

will output the whole log from the previous boot. Look for anything suspicious towards the end where it’s shutting down. Or upload it to one of these pastebin services and post the link here. E.g.

journalctl --boot=-1 --no-pager | curl -F 'file=@-' https://0x0.st

You could also try

journalctl --boot=-1 --no-pager | grep watchdog

to see any messages about watchdog timers as that seems to have been the issue for some people.

I came from earlier Kernel versions and tried a bunch but I didn’t take specific notes. I will try those again and share the results here.

Unfortunately that didn’t work.

I’ve been dealing with this the entire time, waiting for kernel updates for compatibility since this is a relatively new GPU. The only moment when the shutdown worked was when I put a windows drive in there instead of manjaro or linux mint.

Oh nice I didn’t know how to turn that off! The results look kind of good so far though.

That’s awesome. I did a reboot and tried to shut down quickly afterwards, so all the timestamps are unfortunately pretty close I think… I waited for about 3 minutes after the screens turned black and that did a hard shutdown.
These are the results:
https://0x0.st/XaDt.txt

Watchdog seems to be okay and not the issue here unfortunately.

Doing that will likely leave you in an even worse state.

However, there is a comparatively safer way:

Cheers.

2 Likes

hey @kismet - do you have any user scripts that run on shutdown? check system settings > autostart > logout scripts

if so, delete them and test shutdown and if it works, just re-add them

i saw something in the changelog for systemd that affects this stuff and perhaps that change has propagated to manjaro

possibly related: System won’t shutdown (2024-07-01 update) - Support / System Updates - Manjaro Linux Forum

You should evade hard shutdown on all cost, as @soundofthunder mentioned, to activate reisub is a very good idea.

But as i wrote already, you can also use different (and there are a few) shutdown Terminal commands.

See it as work around till the Startmenue shutdown is working again.

Can you specify entire time?

Nice one, I did try REISUO but the result is the same, the machine remains running. I mean screens are black and it’s not responding to anything but according to a Power measurement plug it’s still pulling about 200W -.-

Sorry I wasn’t more specific. I had to check the receipts to be sure but I assembled the machine in November 2023. Started with Linux Mint and a 5.x Kernel and immediately had that issue. Tried newer Kernels and eventually switched to Manjaro for more up to date stuff.

There is no obvious error there but you do have the sp5100_tco watchdog that is noted as a possible problem in the linked thread from your original post. So first thing to do is try blacklisting it. This won’t do any harm even if it isn’t the cause, I blacklisted it on my system years ago.

sudo sh -c 'echo "blacklist sp5100_tco" > /etc/modprobe.d/disable_sp5100.conf'

and reboot.

If that doesn’t help the next thing I’d look at is Plymouth which seems to cause numerous issues. Try disabling it temporarily by booting to the grub menu, press e, and remove the “splash” option. If that fixes the problem you can remove Plymouth permanently - How to remove plymouth? - #14 by jamjar

If neither of those steps helps then report back.

Done. I blacklistet sp5100_tco and also disabled Plymouth according to the link you provided, I don’t need it anyway and I enjoy having a bit more transparency on what’s happening.
Unfortunately the issue persists. I created a new logfile:
https://0x0.st/XanR.txt

And also because I started to question my memories of everything working with windows I created a WinPE live stick to test and the shutdown works perfectly fine there.

Edit: to all of you, already thank you for your support so far, I already learned a lot today.

To rule out a configuration problem specific to your user account;

Does the shutdown hang happen if you boot from a live Manjaro KDE iso image? If not - create a new user, reboot, login to the new user and test shutdown from there.

Also, I know you said earlier you’d used other kernel versions but do try the 6.6 LTS kernel. I don’t think it’s worth trying anything older than 6.6 with a 7800XT.

Sooo I tried the Manjaro KDE Live ISO and it has a 6.9 Kernel and I get the same result, no working shutdown.

However switching to the 6.6 LTS Kernel did something. With 6.6 I get a reboot instead of a shutdown hang, so it doesn’t crash but reboots right away.
REISUO however gives me the shutdown hang even with 6.6.

That’s interesting because that does exactly match previous reported issues which there have been various attempts at fixing since 6.7.

From what I can make out it’s something to do with power limit settings but I’m not certain. Some people are reporting that reverting this one-line change that got added in 6.8.6 fixes their problem.

But there appear to have been some further changes in 6.10 so the first thing I’d try is installing the 6.10rc4 kernel and see if that helps at all.

If not then I’m afraid further troubleshooting is going to require building and installing a patched kernel…

I tried 6.10rc4 and it seems like it messed with my beloved sleep mode. I can’t properly put the system to sleep anymore, it results in a hang too. Shutdown results in a shutdown hang too, so that gives me the worst experience so far.

That’s some very new ground for me. Is it like taking the source, changing that one line, compiling it? I’ll dig into that.

Can I file an issue or so for this so it will at some point be a regular part of the kernel?