[Stable Update] 2024-07-01 - Kernels, Systemd, KDE Gear, LibreOffice, Firefox, Wine, Qemu

Hello community, here we have another set of package updates.

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: Get 3 months extra

Recent News

  • Philip will be at Computex and show off the OrangePi Neo
  • Manjaro Team member @romangg has a new library project with a guest post on Phoronix.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog

image

Notable Package Updates

  • Kernels got updated
    • including new firmwares
  • Systemd is at 256.1 which brings a lot of new features
  • updates to gaming related packages
  • KDE Gear is at 24.05.1
  • Firefox has a point release 127.0.1
  • Qemu is at 9.0.1
  • Wine 9.11 fixes an 17 year old bug
  • LibreOffice is at 24.2.4
  • Initial udpates to Cinnamon 6.2 series.
  • regular Haskell and Python updates

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

checkrebuild
Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.316
  • linux54 5.4.278
  • linux510 5.10.219
  • linux515 5.15.161
  • linux61 6.1.94
  • linux66 6.6.34
  • linux68 6.8.12 [EOL]
  • linux69 6.9.5
  • linux610 6.10-rc4
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.30_rt30
  • linux67-rt 6.7_rt6

Package changes (Thu Jun 20 02:59:48 CEST 2024)

  • stable core x86_64: 59 new and 59 removed package(s)
  • stable extra x86_64: 2637 new and 2736 removed package(s)
  • stable multilib x86_64: 38 new and 37 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-07-01

The sshd service needs to be restarted after upgrading to openssh-9.8p1

2024-07-01 - Robin Candau

After upgrading to openssh-9.8p1, the existing SSH daemon will be unable to accept new connections (see Can't login after openssh 9.8p1-1 upgrade, MUST restart sshd (#5) · Issues · Arch Linux / Packaging / Packages / openssh · GitLab).
When upgrading remote hosts, please make sure to restart the sshd service using systemctl try-restart sshd right after upgrading.

We are evaluating the possibility to automatically apply a restart of the sshd service on upgrade in a future release of the openssh-9.8p1 package.

Arch Linux - News: The sshd service needs to be restarted after upgrading to openssh-9.8p1

Virtual machines using libvirt have no internet if the host uses UFW

This is a known bug. “Workaround” is to change the firewall with firewalld or to disable UFW.
Another easier workaround is to edit /etc/libvirt/network.conf, and add

firewall_backend = "iptables"

2024-05-29

:warning: Linux 6.8 is EOL

Linux 6.8 is EOL and will - at some point - be removed from the repo.

If you use Linux 6.8 and Nvidia or inside a virtual machine, it is of great importance, that you install Linux 6.6 or Linux 6.9 to avoid driver problems.

sudo mhwd-kernel -i linux66

2024-05-14

No plasma interface with kernel 6.9 + Nvidia gpu + Wayland

If you encouter a black screen with no inteface after login in, it’s probably a problem with simpledrm loading.

To solve it add nvidia_drm.fbdev=1 to /etc/default/grub
in the line begining with GRUB_CMDLINE_LINUX=" .
Verify that you also have nvidia_drm.modeset=1 in the same line.
Then exec sudo update-grub

Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Exemple :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.

:arrow_right: 2024-05-13

:warning: Linux 6.7 is EOL
Linux 6.7 is EOL and will - at some point - be removed from the repo.

If you use Linux 6.7 and Nvidia or inside a virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

sudo mhwd-kernel -i linux66
Python interpreter upgrade

If you have a lot of pip/AUR packages to upgrade to Python 3.12, read this.

If you installed python312 from the AUR, you need to uninstall it before running this update.

Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.

If you use KDE you better logout of your session and do the update via Pacman or Pamac in tty.

Helper script to reset plasma https://codeberg.org/wonky/Manjaro-Plasma-Reset/src/branch/main/manjaro-plasma-reset.sh @liinux-aarhus
Also I would, before the update:

  • make a Timeshift snapshot if you ain’t got no recent one.
  • ( export content of widgets like your radio stations in Advanced Radio Player or your Podcasts in Kasts or any podcatcher as a backup )
  • make a fresh boot, but before that even:
  • System Settings > Appearance > Global Theme > set to Breath and tick both options for defaults
  • You might go to the hamburger menu in System Settings and look what changes you made away from default by selecting: Highlight Changed Settings and see if you want to make the effort to get back more defaults
  • System Settings > Workspace > Startup and Shutdown: SDDM defaults and Desktop Session: Start with empty session
  • disable all user-installed widgets that are still on your desktop, panels and even lock screen or wallpaper (e.g. Active Blur)
  • Export your custom shortcuts or mouse gestures in SS> Workspace > Shortcuts
  • Reboot, Timeshift snapshot, reboot
  • then do not log in, do the update via tty (CTRL+ALT+F3, same with F2 gets you back)
  • reboot, login, check through System Settings
  • reboot again
  • enjoy 8)

post-install:

  • look for Plasma 6 replacements for your widgets after the install
  • in case you have Github-installed theming: uninstall the KDE5-version of klassy, install the Plasma 6 version of klassy, maybe reinstall lightly

(greetings, @1efaf7d71a8637c6800a , PS: these are just my thoughts; I didn’t do this update yet!)

How to fix `plasma-firewall` error in System Settings GUI when running `ufw`

Open /usr/lib/kde_ufw_plugin_helper.py and change the first line from #!/usr/bin/python3.11 to #!/usr/bin/python3.12. This fixed the issue for me immediately and makes sense since Manjaro is currently on Python 3.12.

Xfce has inconsistent themes for Qt applications

Qt 6 is now default but some apps are still using Qt 5
To restore the look of QT apps after this update

pamac install kvantum-qt5

Manjaro-settings-manager has light theme instead of dark

2024-04-04

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Symptoms:
Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Solution:
Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000

2024-03-06

gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

2024-02-21

plymouth update may cause black screens

With a newer version of plymouth than 22.02.122 you may experience an unbootable system with a black screen. This might be due to not having early KMS enabled. If you have an Nvidia GPU you could set nvidia_drm.modeset=1 nvidia_drm.fbdev=1 to the kernel parameters in your bootloader config to avoid the need of KMS. However, with Wayland around the corner, KMS will be needed.

To “fix” the current problem, we have downgraded plymouth once again to have more time to find a proper solution to migrate most of your installations to a working state with newer plymouth versions.

sudo pacman -Syuu

Those who don’t have issues can enjoy the newer version of plymouth.

Directions for adding kms to your system configuration and how you can help troubleshooting by providing some sysinfo, read more → Black Screen with Plymouth - Cause and Solution

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://www.reddit.com/r/archlinux/comments/19bnj0i/comment/kit2v33/

bashrc-manjaro is now merged into bash
  • Yes, replace bashrc-manjaro with bash
  • Please also compare your:
    /etc/bash.bashrc
    with the generated
    /etc/bash.bashrc.pacsave
    and retrofit all of your customisations as there was no .pacnew file generated.
  • Same goes for /etc/skel/.bashrc
pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update (after you finished the Release Update) with:

sudo pacman -Syu pacman-contrib

2024-01-13

Initramfs image can be bigger on 6.7 kernel due to Nvidia GSP Boot firmware

We all known that kernel 6.7 is very feature rich. One of the features is the inclusion of Nvidia’s GSP Boot firmware into Initramfs. However this will increase your image by 150 MB and the fallback image might be 240 MB in size. A way would be to remove kms from mkinitcpio.conf and redo your initramfs images. A discussion regarding that can be found at Arch Gitlab: kms hook increases the initramfs size heavily starting with 6.7 kernel (#238) · Issues · Arch Linux / Mkinitcpio / mkinitcpio · GitLab

To reduce size add fallback_options="-S autodetect -S kms" to /etc/mkinitcpio.d/linux67.preset

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

In some cases, however it is better to keep the legacy way. Here are some examples: Dbus-broker warnings

2023-12-23

grub update

grub 2.12 may need manual post install by the user

With GRUB 2.12 out it is recommended to also install grub to your master boot record or EFI partition. On Manjaro grub gets only installed when you install it to your harddrive the first time. Only advanced users also keep their MBR/EFI in-sync as every package update of grub doesn’t update the installation on your MBR/EFI.

Depending on your system hardware and setup this may could cause an unbootable system on rare cases due to incompatibilities between the installed bootloader and configurations. After a grub package update it is advised to run both, installation and regeneration of configuration:

grub-install [plus the needed options depending of been EFI or BIOS]
grub-mkconfig -o /boot/grub/grub.cfg

For more specific information on grub-install, please refer to this guideline: [root tip] [How To] Primer on handling a grub package update

Additional information to that topic can be found here:

2023-12-10

Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm

2023-12-01

  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66
    

2023-11-28

Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab

2023-11-21

mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.

2023-11-13

Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention

2023-11-06

Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.

Previous stable update threads:

2 Likes

Getting the following message while trying to upgrade through pamac:

Preparing...
Synchronizing package databases...
Refreshing core.db...                                                                                                                                                                                                                 
Refreshing extra.db...                                                                                                                                                                                                                
Refreshing multilib.db...                                                                                                                                                                                                             
Warning: installing alsa-lib (1.2.12-1) breaks dependency 'alsa-lib=1.2.11' required by lib32-alsa-lib                                                                                                                                
Add lib32-alsa-lib to remove
Warning: installing alsa-plugins (1:1.2.12-1) breaks dependency 'alsa-plugins=1:1.2.7.1' required by lib32-alsa-plugins
Add lib32-alsa-plugins to remove
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing lib32-alsa-lib breaks dependency 'lib32-alsa-lib' required by lib32-libcanberra
- removing lib32-alsa-lib breaks dependency 'libasound.so=2-32' required by lib32-pipewire
- removing lib32-alsa-plugins breaks dependency 'lib32-alsa-plugins' required by steam
Resolving dependencies...
Checking inter-conflicts...
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing lib32-alsa-lib breaks dependency 'lib32-alsa-lib' required by lib32-libcanberra
- removing lib32-alsa-lib breaks dependency 'libasound.so=2-32' required by lib32-pipewire
- removing lib32-alsa-plugins breaks dependency 'lib32-alsa-plugins' required by steam

1 Like

Really looking forward to Nvidia 555.58 finally making it into what I assume will be the next Stable update; I’m using the beta via AUR but some folks’ systems have had unplayable flickering in 3D games under Wayland since last November!

2 Likes

5 posts were split to a new topic: I would have expected Plasma 6.1

Same happens here. I’m using pamac in KDE Plasma.

EDIT: when using pacman I got the following:

sudo LANG=en_EN.UTF-8 pacman -Syu                                                                                 INT ✘ 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing alsa-lib (1.2.12-1) breaks dependency 'alsa-lib=1.2.11' required by lib32-alsa-li

EDIT: updating and changing mirrors solved the issue. Thank you @philm for the link

lib32-alsa-lib is also updated with this update. What happens if you open a terminal and issue sudo pacman -Syu? @Kyoketsu9513 Seems to be similar to this one: Latest update and alsa-lib

Did the update. No Issues.

ty :slight_smile:

I voted “no issues”, but after the update, I noticed that the system just logs off when selecting “Shutdown” from application menu in Cinnamon. It’s obviously a Cinnamon bug, see cinnamon-session does not shutdown PC · Issue #173 · linuxmint/cinnamon-session · GitHub.

1 Like

Hi.

I have an issue with a particular package. Everything else worked fine.

Update:
In the meantime solved itself. Dunno why.

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "pcre2=10.44", a dependency of "lib32-pcre2"
:: The following package cannot be upgraded due to unresolvable dependencies:
      lib32-pcre2

:: Do you want to skip the above package for this upgrade? [y/N]

Plasmashell gets stuck, (cpu usage goes to 100%).
I can run applications via krunner but Plasma Docks are stuck, cannot use activities etc.
Restarting plasmashell indeed restarts it only to get stuck again.

octopi notifier does not start automatically anymore, must be started manually

2 Likes

Hi guys!!! Hope all fine for u…im facing this issue when trying to update

error: no se pudo realizar la operación (archivos en conflicto)
npm: /usr/lib/node_modules/npm/node_modules/cidr-regex/dist/index.js existe en el sistema de archivos
npm: /usr/lib/node_modules/npm/node_modules/is-cidr/dist/index.js existe en el sistema de archivos
Ocurrieron errores, por lo que no se actualizarán los paquetes

This is the output of npm --version

npm --version                                                                                                                              1 ✘  10s  
10.8.1

Any idea? Thanks, in advance

1 Like

Same for me, update went smooth on Cinnamon with 6.6 LTS kernel, but also the shutdown bug, which as stated above is a Cinnamon issue.

Shutdown issue occured for me after update.

Gets stuck at boot time with

A start job is running for /dev/tpmrm0 (1min 5s / 1lmin 34Ys)
Timed out waiting for device /dev/tpmrm0

Hangs for a couple of minutes. I searched this thread for tpmrm0 but dont see it. What do i do?

❱inxi -bz

System:
Kernel: 6.9.5-1-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
Machine:
Type: Desktop System: Dell product: OptiPlex 7050 v: N/A
serial:
Mobo: Dell model: 055H3G v: A01 serial: UEFI: Dell
v: 1.26.0 date: 08/20/2023
CPU:
Info: quad core Intel Core i7-7700 [MCP] speed (MHz): avg: 1331
min/max: 800/4200
Graphics:
Device-1: Intel HD Graphics 630 driver: i915 v: kernel
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
loaded: modesetting dri: iris gpu: i915 resolution: 3840x2160~60Hz
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.1.1-manjaro1.1
renderer: Mesa Intel HD Graphics 630 (KBL GT2)
Network:
Device-1: Intel Ethernet I219-LM driver: e1000e
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
Drives:
Local Storage: total: 1.84 TiB used: 482.24 GiB (25.6%)
Info:
Memory: total: 16 GiB available: 15.48 GiB used: 3.78 GiB (24.4%)
Processes: 245 Uptime: 8m Shell: fish inxi: 3.3.35

I did the update and restarted my computer. It is stuck after the GRUB with the error message below:

[!!!] Refusing to run under cgroup v1, SYSTEMD_CGROUP_ENABLE_LEGACY_FORCE=1 not specified on kernel command line.

I’ve also tried to boot with another Manjaro Gnome USB and tried to manjaro-chroot, then installed a different kernel version, but the result is the same error message.

How can I get rid of this error?

* Support for cgroup v1 ('legacy' and 'hybrid' hierarchies) is now
  considered obsolete and systemd by default will refuse to boot under
  it. To forcibly reenable cgroup v1 support,
  SYSTEMD_CGROUP_ENABLE_LEGACY_FORCE=1 must be set on kernel command
  line. The meson option 'default-hierarchy=' is also deprecated, i.e.
  only cgroup v2 ('unified' hierarchy) can be selected as build-time
  default.
4 Likes

Confirmed. I’ve now added it to the Plasma Autostart section.

2 Likes

I have a little Problem, the first command, prints python-manjaro-sdk
if i do the second command, it prints file not found
checkrebuild prints foreign khotkeys python-manjaro-sdk

are the command right?