[Stable Update] 2022-02-05 - Kernels, LibreOffice, KDE Gear, Nvidia, Calamares, VirtualBox, Pipewire, Mesa, Systemd

Hello community,

Another stable branch update with some usual updates for you.


Stay tuned for some upcoming product reviews of our new Manjaro UM700 MiniPC

  • Some of the Kernels got updated, including fixes for BTRFS regressions. Note that 4.4 series is now marked EOL. Also linux514 got dropped from our repos.
  • linux-firmware we kept split-up, however we ship them uncompressed to support 4.x kernels still
  • KDE Gear got renewed to 21.12.2
  • LibreOffice is now at 7.3
  • Nvidia published their first stable version of 510 driver series: 510.47.03
  • We updated Calamares to 3.2.51
  • Mesa is now at 21.3.5
  • Wine got renewed to 7.1
  • OpenSearch is at 1.2.4
  • VirtualBox got updated to 6.1.32
  • Systemd is now at 250.3
  • Firefox got renewed to 96.0.2
  • AMDVLK is at 22.Q1.1
  • PipeWire got updated to 0.3.45 for fixing Audio issues with Zoom and other communication apps
  • The usual upstream updates including Haskell and Python

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.302 [EOL]
  • linux49 4.9.299
  • linux414 4.14.264
  • linux419 4.19.227
  • linux54 5.4.176
  • linux510 5.10.96
  • linux515 5.15.19
  • linux516 5.16.5
  • linux517 5.17-rc2
  • linux515-rt 5.15.18_rt28
  • linux516-rt 5.16.2_rt18

Package Updates (Fri Feb 4 12:44:29 CET 2022)

  • stable community x86_64: 2000 new and 1946 removed package(s)
  • stable core x86_64: 78 new and 70 removed package(s)
  • stable extra x86_64: 930 new and 1091 removed package(s)
  • stable kde-unstable x86_64: 342 new and 342 removed package(s)
  • stable multilib x86_64: 44 new and 45 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Qonos 21.2.3 is now available!


Download XFCE





Minimal (linux510)


Minimal (linux54)


Download GNOME





Minimal (linux510)


Minimal (linux54)


Download KDE





Minimal (linux510)


Minimal (linux54)



Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

Issues with Jack2 when using Pipewire.

Pipewire tend to replace all stuff related to Audio. This time jack2 seems to create issues. In the past pipewire-jack provided jack2. However, since the lack of dbus support that line got removed and only conflicts kept. So if you use jack2 with the dbus feature, you may want to remove the pipewire-jack package. If not you can continue and additionally install lib32-pipewire-jack package.

This update removes linux514. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have.

sudo mhwd-kernel -r linux514
sudo pacman -Syu
sudo mhwd-kernel -i linux515
Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic

Older Issues:

Xorg crashes with multiple monitors if portrait view or custom display scale is used on 2nd display (possibly leading to infinite login loop)

Error: LightDM infinite login loop
[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #244 by LS650V
for problem descriptions and possible solutions.

KDE Plasma shows visual graphical errors

This is a known issue based on changes within SVG files. Clearing the Plasma SVG cache fixes it. Do this: rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

If did not help, try strengthened variant of clearing cache (to be sure that it is not the cache-related issue)
  1. Log out from user session to shutdown all KDE and user apps which could use the cache.
  2. Enter TTY, for example TTY3: Ctrl+Alt+F3.
  3. Login in that textual terminal.
  4. Clear all cache and extra KDE-related stuff by entering these 3 commands: KDE - ArchWiki.
  5. Type systemctl reboot to reboot PC.

Nvidia 495xx driver series drops Kepler support; need to manually switch to 470xx.

mhwd’s video-nvidia now provides 495xx; if you need 470xx you must manually switch before updating, by using the commands below.

With the new 495xx driver series a lot of Wayland adjustments got added. Also Nvidia decided to remove Kepler support. Therefore you may want to switch drivers to 470xx series, which still supports those graphic cards:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx

Nvidia 340xx driver series no longer works.

This driver is end of life by NVIDIA, you should not be using it as there are serious security issues with this driver. You have to either get newer supported hardware or switch to Nouveau:

#remove old
sudo mhwd -r pci video-nvidia-340xx
sudo mhwd -r pci video-linux
#install new nouveau
sudo mhwd -i pci video-linux

Reboot after and you're done.
Shotcut Scrolling doesn't work any more in Cinnamon

You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards. Source

Fullscreen loses focus

Full-screen apps like YouTube and games:

  • Load fine but after briefly showing the application you’re dumped back into your Desktop Environment (DE) whilst the application was still running fine in the background.
  • Clicking on the running application briefly brings you back to it but you’re dumped again to the DE after a second or 2.

disable the Desktop Icons (DING) extensions

SDDM shows wrong/default theme


Set SDDM theme to Breath in System Settings / Startup and Shutdown / Login Screen (SDDM).

No search results in application launcher when using multiple kickoff instances

Edit 2: Bug is fixed with the 2022-01-23 Stable Release of Manjaro. People who have replaced the Applet by using Solution 1 may want to revert the solution.

Edit: Bug is now fixed Upstream. It will be in the next Plasma 5.23.5 Release, which is scheduled at Tue 2022-01-04.

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there’s more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

Steam shows black screen

:warning: Opting in or out for Steam beta changes nothing.


  • Open a terminal
  • Execute:
    LD_PRELOAD=/lib/libharfbuzz.so steam

Buzzing sound while using headphones.


  • Execute:
    sudo nano --backup /etc/tlp.conf
  • Only if you have to, set SOUND_POWER_SAVE_ON_BAT=0 as well

No idea how much it affects battery life, though.

Unable to login in remotely using ssh using rsa keys

After this upgrade authentication might not work and might find the following error in the ssh log:

userauth_pubkey: key type ssh-rsa not in PubkeyAcceptedAlgorithms [preauth]

Good solution:

  • generate new keys using a more secure algorithm like ED25519

Lazy solution (acceptable for rsa keys with a length >= 3000bits):

  1. Execute:
    sudo nano --backup /etc/ssh/sshd_config
  2. copy-paste the following into the above file:
  3. To save, press Ctrl+X Enter Y

It works now, but you’re still using SHA1 which has been showing weaknesses for years now (although it’s not actually cracked, it’s not recommended any more and why ssh disabled it)

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.

Brave segfaults / crashes


  • Clear cache / Data
  • Re-install Brave afterwards

You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv

nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules

Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages:

sudo pacman -Rdd lib32-libcanberra-pulse \
lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer

Note: there are 4 packages to remove: copy all those two lines of the command.
We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!



I got this error: jack2 and pipewire-jack are in conflict. Which ones of the packages should be removed?


jack2 and pipewire-jack are both an implementation of the JACK API. pipewire-jack now properly provides jack, which means that it can no longer be installed side-by-side with jack2.

I think you can remove jack2. Run pactree -r jack2 to see what depends on it before removing.


Getting the same error.
Here is another related discussion:

I also encountered the jack2 pipewire-jack conflict issue. The method I used to resolve this conflict is by reinstalling pipewire-jack. It automatically removes jack2 so that the update can continue.

This seems to be resolved:

Name                  : pipewire-jack
Version               : 1:0.3.45-1
Description           : Low-latency audio/video router and processor - JACK support
URL                   : https://pipewire.org
Licenses              : MIT GPL2
Repository            : extra
Installed Size        : 694.6 kB
Groups                : --
Depends On            : sh pipewire-session-manager libpipewire-0.3.so=0-64
Optional Dependencies : jack-example-tools: for official JACK example-clients and tools
Required By           : blender ffmpeg fluidsynth gst-plugins-good portaudio qemu recordmydesktop
Optional For          : alsa-plugins manjaro-pipewire mlt mpg123 pipewire sdl2 vlc
Provides              : jack libjack.so=0-64 libjackserver.so=0-64 libjacknet.so=0-64
Replaces              : --
Conflicts With        : jack jack2
Packager              : David Runge <dvzrv@archlinux.org>
Build Date            : Thu Feb  3 18:26:02 2022
Install Date          : Sat Feb  5 11:37:36 2022
Install Reason        : Installed as a dependency for another package
Validated By          : Signature
Backup files          : --

During kernel update an error is displayed: possible missing firmware for qb and 3 three other firmware modules.

Another reminder is that nvidia 510 driver seems to solve the dbus issue, so we can safely disable the fake-powerd systemd service.

sudo systemctl stop nvidia-fake-powerd.service
sudo systemctl disable nvidia-fake-powerd.service
pamac remove nvidia-fake-powerd

can confirm, removing jack2 works fine for me.

your solution worked for me

sudo pacman -S pipewire-jack

remove jack2, then procced with the rest of the update normally

as a side notice i installed 5.15.19-1 kernel which was not flagged as lts on manjaro settings manager, rebooted and now it is listed properly as lts ,some kind of bug?


While updating my system, I got the following error message:

Installation von nvidia-utils (510.47.03-4) verletzt Abhängigkeit 
»nvidia-utils=495.46«, benötigt von linux514-nvidia

I currently have kernel 5.14.21-2 installed which is no longer supported. Tried to install another kernel, but this getting the same error message.

How can I solve this dependency?

You may use a Live environment to chroot to your system to install the LTS kernel. See this

1 Like

Remove kernel 5.14, install a supported one, 5.4, 5.10 or 5.15, its *-headers package and try again.

1 Like

I created a user account for some testing purposes. But when I click Delete User in KDE System Settings > Users, nothing happens. No password prompt, nothing …
Also I cannot create new accounts from KDE system settings.
The actions can be done from MSM, though.

Can anyone please confirm if this is happenning in my system only?

Things i noticed while updating:

  • i had also encountered the JACK issue, which was simply fixed by running pacman -S pipewire-jack before the full upgrade
  • while it updated, kde plasma (wayland) desktop crashed (i dont know exactly which process it is but the one that provides the taskbar and the desktop-background (task-switching still works fine))
  • package accountservice gave a warning that /var/lib/AccountsService/ has mismatched directory permissions (filesystem: 755 package: 775), even though i never modified that directory
  • a “random” note from brltty (i dont quite know what this does) is Please add your user to the brlapi group.

I can’t performs the update, I got:

Resolving dependencies...
Warning: cannot resolve "libx264.so=164-64", a dependency of "ffmpeg4.4"
Warning: cannot resolve "ffmpeg4.4", a dependency of "hedgewars"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libx264.so=164-64' required by ffmpeg4.4
- unable to satisfy dependency 'ffmpeg4.4' required by hedgewars

I’ll have to temporary remove ffmpeg4.4 and hedgewars?


By removing hedgewars the update went fine, however, if I attempt to reinstall it, I got the same dependencies errors; furthermore, I also had this long list of leftovers:


By checking using the command dependency-checker I see that all these
haskell-* packages were required by hedgewars, so all seems fine.

It’s braile driver (I have no idea how it work, you probably need special device). If you aren’t completely blind you probably don’t need it :stuck_out_tongue: You can safely remove this packaage.

Update went fine, but one error-message occured:

Warning: Directory permissions differ for /var/lib/AccountsService/

Can anyone tell me how to fix this please?

Awwno, here we go again :upside_down_face:

pamac build $(pacman -Qoq /usr/lib/python3.9) --no-confirm
1 Like

As a update from my initial message:

  • kde crashed while having something related being upgraded and now (even after restarts), the taskbar does not come back (and i cant find a setting for this)
  • after upgrading and before rebooting, firefox suddenly kept crashing over and over

update: it seems like my ~/.config/plasma-org.kde.plasma.desktop-appletsrc got into a bad state, reverting it to some hours before (btrfs snapshot), fixed it