Error: LightDM infinite login loop


I am unable to login using LightDM. I have two users one using the i3 desktop and the other xfce. When either user enters their password the screen goes blank - as if the system thinks about logging in - and then returns to the LightDM password screen. Entering the wrong password provides the normal challenge to enter the correct password. This behaviour happens for both i3 and xfce user. There was no obvious reason as to why this happened, possibly it was caused following a standard pamac update command which I think I ran last night before shutting down.

I can login via tty.

Running at the tty terminal:

inxi --admin --verbosity=7 --filter --width

gives the following output:

My /var/log/lightdm/lightdm.log can be viewed at:

My /var/log/Xorg.0.log can be viewed at:

A ~/.xsession-errors file is created (from the unsuccessful log in I believe), which can be viewed at:

[EDIT] Running coredumpctl for today also brings up a number of errors with /usr/lib/Xorg, /usr/bin/xfce4-power-manager and /usr/bin/python3.9 as shown at:

I’ve tried a number of things: rolling back to the last kernel via grub, trying the LightDM infinite login loop suggestions on the Arch wiki and installing plymouth. I did the last one as I noticed a line about plymouth not starting in an error log. Installing plymouth has removed that error line (so I kept it), but it hasn’t solved the problem.

I would really appreciate help on this. I’ve spent hours looking at forums etc, but haven’t been able to nail this. If you are generous enough to assist I’d really appreciate pointers on the commands I need to enter, rather than ‘have you looked at x’ - I’m not a noob exactly, but I wouldn’t consider myself experienced in Linux.

Thank you in advance.

Just putting this here.

1 Like

I appreciate the speedy help, but my original post includes this link and that unfortunately it didn’t work.

Have you installed video-vesa ? Please remove it from TTY.
sudo mhwd -r pci video-vesa

1 Like

Thank you very much for the suggestion.

Running the command above at tty gives me:

Error: config 'video-vesa' is not installed!

Interesting. Wonder if you just had a partial update then. If you run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu

do you get more updates ?

Earlier today in my attempts to fix I did run sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu. It gave me two updates: thunderbird and zensu; but I still wasn’t able to log in.

I’ve just now run the command you gave me (thanks) - but got the ‘nothing to do’ message after it had synced mirrors.

It might be called xf86-video-vesa. Would it be worth it to try and replace lightdm-gtk-greeter and lightdm-gtk-greeter settings with lightdm-slick-greeter and lightdm-settings?

1 Like

I also had the recent update clobber my lightdm, in fact timeshift btrfs snapshots saved my @ss
I ended up fixing my issue by

  • renaming /etc/X11 to X11_old then
  • installing gdm and wayland… then
  • disable lightdm and enabling gdm
  • going to /etc/systemd/system/ and replacing the default display manager link to one pointing to gdm
    ln -s /usr/lib/systemd/system/gdm.service /etc/systemd/system/display-manager.service
1 Like

Thanks for the suggestions. My /etc/lightdm/lightdm.conf already has the line:


I haven’t amended this, so it must be the default from the i3 edition of Manjaro.

I’m not exactly sure how I would replace the lightdm-gtk-greeter settings with the lightdm-settings; but I’m thinking this might already be the case given the conf file?

1 Like

That seems like a fairly major alteration! To fill in some of the gaps in my knowledge, the commands you didn’t specify would be:

The install part:

pacman install gdm
pacman install wayland

Swapping one dm for the other:

sudo systemctl enable gdm.service --force
sudo systemctl disable lightdm.service --force

One question though - isn’t the wayland install quite a major piece though, if Manjaro as a whole is using X; then going to Wayland might cause some issues down the line? Excuse my ignorance.

EDIT: Looking into this option more, I’m not sure that i3 works on Wayland - there is a Wayland equivalent called Sway; but I’d be moving quite far away from where I started.

So after realising that this issue was related to the Qonos 21.2.0 update I’ve since learnt this is affecting other users. It concerns Xorg and the use of multiple monitors. I’ve described my temporary workaround in the Qonos update thread.

Appreciate all who responded.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.