[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

Hello community,

After a month of hard work, we are happy to present this stable branch update to you, our community! Please take this update with care!

Especially Nvidia Fermi and Keppler users should read the Troubleshoot post to avoid non-loading desktops …

This brings also our first preview release of 21.2 we call Qonos

  • We updated our Kernels. Note that 5.13 series is marked EOL and 5.12 got removed!
  • We added the RC1 of linux516. So far only the Nvidia 470xx driver builds against this new kernel
  • Pipewire got updated to 0.3.40, which brings better Jack compatibility
  • Gnome 41 is maybe the biggest addition to this update
  • After a long time there is a new Xorg-Server release. 21.1 brings new features and might break support on Nvidia drivers. So let us know if you see any issues, before we drop them.
  • Finally there is the first stable release of LxQt!
  • Plasma got another point release: 5.23.3
  • With 470.86 the Nvidia driver for Keppler cards got additional fixes.
  • One of the featured updates is KDE Frameworks 5.88.0. Please read our Troubleshoot section if you see visual graphical issues.
  • Nemo got some rebuilds and other Cinnamon packages got some updates
  • Both pacman-mirrors and shiny-mirrors got updates so you can generate mirrorlists with ease
  • Firefox got update to 94.0.2
  • Thunderbird 91.3.1 got added
  • Auto-CPUFreq is now at 1.7.1
  • Enhancements on the new app shiny-mirrors
  • LibreOffice got renewed to 7.2.2
  • LibreOffice Still is now at 7.1.7
  • We ported System76’s Cosmic Desktop over to Manjaro
  • Mesa got updated to 21.2.4
  • VirtualBox got updated to 6.1.28
  • Nvidia driver is now at 470.82.00
  • Kodi is now at 19.2
  • Both PHP7 and PHP8 got updated
  • Wine is at 6.21
  • MauiKit got renewed to 2.1.0
  • KDE Gear is at 21.08.3
  • A lot of Python and Haskell updates got added
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.292
  • linux49 4.9.290
  • linux414 4.14.255
  • linux419 4.19.217
  • linux54 5.4.159
  • linux510 5.10.79
  • linux513 5.13.19 [EOL]
  • linux514 5.14.18
  • linux515 5.15.2
  • linux516 5.16-rc1
  • linux510-rt 5.10.73_rt54
  • linux515-rt 5.15_rt17

Package Updates (Tue Nov 16 16:07:31 CET 2021)

  • stable-staging community x86_64: 1432 new and 1444 removed package(s)
  • stable-staging core x86_64: 38 new and 36 removed package(s)
  • stable-staging extra x86_64: 549 new and 541 removed package(s)
  • stable-staging kde-unstable x86_64: 364 new and 364 removed package(s)
  • stable-staging multilib x86_64: 38 new and 38 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

First Preview of 21.2 Qonos available!


Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)



Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

No search results in application launcher when using multiple kickoff instances

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there’s more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

Xorg crashes with multiple monitors if portrait view or custom display scale is used on 2nd display (possibly leading to infinite login loop)

Error: LightDM infinite login loop
[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #244 by LS650V
for problem descriptions and possible solutions.

KDE Plasma shows visual graphical errors

This is a known issue based on changes within SVG files. Clearing the Plasma SVG cache fixes it. Do this: rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

This update removes linux512. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have. Note: 5.13 is marked EOL and will be dropped next!

sudo mhwd-kernel -r linux512
sudo pacman -Syu
sudo mhwd-kernel -i linux515
Nvidia 390xx driver series not supported by this update

nvidia-390xx is not compatible to Xorg-Server 21.1.1 yet. This was already reported in April this year and we gave another hint this month. Since Nvidia didn’t respond in time we decided to do a workaround, since not so much got changed in Xorg-Server after all. Therefore we added the file /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf with following content:

Section "ServerFlags"
  Option "IgnoreABI" "1"

However, it seems for Bumblebee users also the file /etc/bumblebee/xorg.conf.nvidia needs this ignore flag. Most likely I’ve to check if also /etc/X11/mhwd.d/nvidia.conf overwrites xorg.conf.d files …

Fermi users should really think about replacing their GPU or change to Nouveau drivers at some point. Nvidia is informed about the issue. Maybe comment politely why 390xx should continue to be supported with new Xorg-Servers …

Nvidia 495xx driver series drops Keppler support.

With the new 495xx driver series a lot of Wayland adjustments got added. Also Nvidia decided to remove Keppler support. Therefore you may want to switch drivers to 470xx series, which still supports those graphic cards:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx
Nvidia 340xx driver series no longer works.

This driver is end of life by NVIDIA, you should not be using it as there are serious security issues with this driver. You have to either get newer supported hardware or switch to Nouveau:

#remove old
sudo mhwd -r pci video-nvidia-340xx
sudo mhwd -r pci video-linux
#install new nouveau
sudo mhwd -i pci video-linux

Reboot after and you're done.
Pamac can't handle file conflicts checking

As of now libpamac v11.1.2 has still the issue checking for file conflicts properly. Keep an eye on this ticket and use pacman for now as needed. As soon as a fix is available it will be pushed to all branches: Hangs on file conflicts checking (#1138) · Issues · Applications / pamac · GitLab

Solution: update to libpamac 11.1.3 sudo pacman -Sy libpamac

Shotcut Scrolling doesn't work any more

You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards.

Fullscreen loses focus

Full-screen apps like YouTube and games:

  • Load fine but after briefly showing the application you’re dumped back into your Desktop Environment (DE) whilst the application was still running fine in the background.
  • Clicking on the running application briefly brings you back to it but you’re dumped again to the DE after a second or 2.

disable the Desktop Icons (DING) extensions

Older Issues:

With 21.1.4 and initial 21.1.5 release it was not possible to install on non-BTRFS filesystems

Seems grub-btrfs preinstalled in version 4.10.1 introduced a regression to error out when no BTRFS filesystem was found on your system. This was part of 21.1.4 ISO and our initial 21.1.5 release. Please re-download 21.1.5, which is now fixed.

Fixed ISOs:

58de4cd58b23fea2ef69c055dd0088726350294a  manjaro-gnome-21.1.5-211008-linux513.iso
a8af15b768479ea321c897aa83e573e26bd61784  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
aef8a60820666cddce79c980258693d0cf13da9a  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
564c64ddf342c9b7483c469a6d8dca2f94492719  manjaro-kde-21.1.5-211008-linux513.iso
3781a3c0d3a92496b1418dafb49cef247379aa93  manjaro-kde-21.1.5-minimal-211008-linux513.iso
1f4c83be758275e3d0bb17a0b32138b7a0b313a8  manjaro-kde-21.1.5-minimal-211008-linux54.iso
00737362c81c3c3d4ec7fba6f7a7ec72701a0450  manjaro-xfce-21.1.5-211008-linux513.iso
c2e2f5018d9a50a1112bbcc761a22c8e4dcb7275  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
a34e27a17ab5fcc6473f1ad503d2049a9c904608  manjaro-xfce-21.1.5-minimal-211008-linux54.iso

Broken ISOs:

91cf900bb978dfbb3d32fec083c27d4c428b03ca  manjaro-gnome-21.1.5-211008-linux513.iso
c9f07d7ab4f3bb3a75b1a3c84e909cbf3bd74309  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
7e0673c604e1ce267f59d0056ddf819cede21f38  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
1f56c7feaf7c5fea485b30a6d3c513fb3d0188bb  manjaro-kde-21.1.5-211008-linux513.iso
0922345bdec24b2eb5ed6f635c600b2a499a1ed9  manjaro-kde-21.1.5-minimal-211008-linux513.iso
74fd38b172be9c996d6d59e40e4a730b93f9c88f  manjaro-kde-21.1.5-minimal-211008-linux54.iso
3b9409492b791f4380f617489c63e327ae7f6d53  manjaro-xfce-21.1.5-211008-linux513.iso
10a8d165d9bd0a8edcae1a640e0c753b1ff1c54c  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso
Steam shows black screen

:warning: Opting in or out for Steam beta changes nothing.


  • Open a terminal

  • Execute:

    LD_PRELOAD=/lib/libharfbuzz.so steam
Buzzing sound while using headphones.


  • Execute:

    sudo nano --backup /etc/tlp.conf

  • Only if you have to, set SOUND_POWER_SAVE_ON_BAT=0 as well

No idea how much it affects battery life, though.

Vertex-Maia-Icons are messed up.


  • Vertex-Maia-Icons will be dropped from the repository soon:
  • Choose some new icon theme.
Unable to login in remotely using ssh using rsa keys

After this upgrade authentication might not work and might find the following error in the ssh log:

userauth_pubkey: key type ssh-rsa not in PubkeyAcceptedAlgorithms [preauth]

Good solution:

  • generate new keys using a more secure algorithm like ED25519

Lazy solution (acceptable for rsa keys with a length >= 3000bits):

  1. Execute:

    sudo nano --backup /etc/ssh/sshd_config
  2. copy-paste the following into the above file:

  3. To save, press Ctrl+X Enter Y

It works now, but you’re still using SHA1 which has been showing weaknesses for years now (although it’s not actually cracked, it’s not recommended any more and why ssh disabled it)

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.
Brave segfaults / crashes


  • Clear cache / Data
  • Re-install Brave afterwards
You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv
nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!


The wait is over.


Prepare to say goodbye to nice and useful KWin 3D effects like FlipSwitch and Cube :sob:

Hopefully they will be implemented again soon…


For me. It’s Sumner Time… and I can’t find a Creative Commons Meme.

1 Like

Sorry for the off-topic but what’s the story behind that video?

“Shotcut Scrolling doesn’t work any more – You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards.”

That sounds horrible. Now every time you want to scroll, the start menu opens afterwards and you need to close it again.

1 Like

1.9 GB of DL with quit a few important updates,
i sense a flood of incoming support asking threads.

time to make a Timeshift backup.


hi, I get this error:

Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:
- pipewire-media-session and wireplumber are in conflict

any idea?


2 posts were split to a new topic: Conflicting files: foot already exists in filesystem

I also can’t upgrade. I get the error message: “unable to satisfy dependency ‘libffi.so=8-64’ required by thunderbird”.

I haven’t updated yet but I wanted to say thank you to the dev team and all those that contributed to this update. It’s easy to forget how many hours go into projects like Manjaro and this update was not an easy one.

Thanks again!!


Read the known issues. :stuck_out_tongue:

1 Like

See here:

had the same problem with pacman…

solution is:

sudo pacman -S pipewire-media-session
pamac install wireplumber

Your mirror isn’t fully synced (yet), Wait for it to sync or try another one.

1 Like

Done before posting, does not fix the issue. The manjaro-sway repo has the old version which causes the error.

“Your mirror isn’t fully synced (yet), Wait for it to sync or try another one.”

Probably this. :point_up:

Check here for more info: https://repo.manjaro.org/

1 Like

About the second step: do you actually need to specifically update wireplumber? Could it not be updated with the rest?

sudo pacman -S pipewire-media-session
sudo pacman -Su
1 Like

no, the first step removes wireplumber.