Call for testers: Manjaro COSMIC

You may remember System76 announcing COSMIC earlier this year with the release of Pop!_OS 21.04:

Since then, I’ve been testing packaging the COSMIC experience for Manjaro. Now with Pop!_OS 21.10 (still in beta), COSMIC is finally compatible with GNOME 40.

:information_source: It is not yet fully compatible with GNOME 41. :information_source:

Install

  • Switch to the testing or unstable branch
  • Install the cosmic package group:
    pamac install cosmic
    
  • Enable the Cosmic Dock, Pop Cosmic and Pop Shell GNOME Shell Extensions. Optionally enable Cosmic Workspaces if you want a vertical overview.

There are also optional dependencies, be sure and check those if you want the full Pop!_OS experience.

If you want the Pop! Dark Cyan folder color while using papirus-icon-theme, install papirus-folders and run the following command.
Replace Papirus-Dark with whichever Papirus variant you might be using:

papirus-folders -t Papirus-Dark -C darkcyan

The Manjaro GNOME logo that appears in the bottom right-hand corner of the first screenshot below is gnome-shell-extension-background-logo (Background Logo). Thanks to @bogdancovaciu for making the logo.

Preview

Cosmic Dock is just a fork of Dash to Dock with some tweaks for COSMIC, you already know how it works.

9 Likes

Looking forward to seeing this hit stable. Thanks for the effort :ok_hand:t2:

1 Like

Oh yeah, one more Cool Desktop Environment :wink:

1 Like

Oh yeahhh! Also, does anyone know if I can install it directly from Xfce or do I need to have the GNOME variant installed?

Just installed this and rebooted but it didn’t give me any option to select Cosmic desktop, just Gnome.

You’ll need to enable both the Shell and COSMIC in GNOME extensions

1 Like

I’ve installed it with pamac install cosmic (didn’t really paid attention to the logs) and rebooted.

It was quite familiar to what I already had, so I checked in Extensions and it was still Dash to Dock, no trace of Cosmic.

I disabled Dash to dock just in case, I reinstalled Cosmic, paid attention that this time it was installed correctly and that gnome-control-center such as gnome-shell-extension-dash-to-dock were uninstalled as planned.

After reboot, I enabled Cosmic Dock and Pop COSMIC in Extensions.

I find it weird that Dock Settings are overwritten/doubled within Pop Cosmic settings, that are within customized Gnome/Pop Control Center. Hey, by design.

Desktop section is not localized, except Backgrounds that was part of original Gnome Control Center.
image
image

Clicking in Pop COSMIC settings in Extensions is English only too.
image

In General, one can decide what Meta key will open. Workspaces and Applications work fine, I don’t know what Launcher is, it does nothing. Presumably a Pop thing.

In Appearance, I played with Light/Dark themes. It meant Pop themes, as it broke my personal theming. But it was just Applications, no big deal.


In Dock, enabling the Icons does nothing.
image

I also enabled the Applications icon through Dock settings directly but nothing.
It’s the only drawback I encountered compared to original Dash to Dock, as I have no more Applications icon.
image

But I enabled Applications button in the Top Bar, and mapped Meta Key to launch Applications instead of Workspaces, I’ll survive.

Overall, some nice additions compared to Dash to Dock, with only a slight loss compared to my previous workflow.

Edit: ha ha, I did not even read @Yochanan review, some things are redundant.

COSMIC is not a separate Desktop Environment. It’s “a set of catered customizations” for GNOME.

It’s featured in the first screenshot in the first post on the left monitor.

Do you see any complaints in the log about pop-shell or the launcher service when the Super Key Action is set to Launcher?

journalctl -f -o cat /usr/bin/gnome-shell
1 Like

I’m out at the moment, I’ll report when I can have my hands on the laptop.

Hey, that was just a pun based on KDE abbreviation and the fact that Cosmic starts with a proper C letter :wink:

st_widget_get_theme_node called on the widget [0x55664efd6030 Gjs_ui_iconGrid_BaseIcon.overview-icon:insensitive first-child last-child] which is not in the stage.
st_widget_get_theme_node called on the widget [0x55664d7b1bb0 StBoxLayout:insensitive first-child last-child] which is not in the stage.
st_widget_get_theme_node called on the widget [0x55664f4ba940 StBin:insensitive first-child last-child] which is not in the stage.
st_widget_get_theme_node called on the widget [0x55664f2cac60 StIcon.show-apps-icon:insensitive first-child last-child] which is not in the stage.
Can't update stage views actor MetaWindowGroup is on because it needs an allocation.
Can't update stage views actor MetaWindowActorX11 is on because it needs an allocation.
Can't update stage views actor MetaSurfaceActorX11 is on because it needs an allocation.
Can't update stage views actor MetaWindowGroup is on because it needs an allocation.
Can't update stage views actor MetaWindowActorX11 is on because it needs an allocation.
Can't update stage views actor MetaSurfaceActorX11 is on because it needs an allocation.

Those are “normal” messages so far. Nothing related to Pop Shell or Pop Launcher. Did you set the Super Key Action to Launcher and press the Super key before / while running that?

I did after, while letting the logs.
It writes nothing into the logs.

Switching back to Applications, it doesn’t log either after pressing Meta several times.

Do you have the Pop Shell Extension enabled?

No, just Pop COSMIC and Cosmic Dock.

I’ll try now, never was a fan of tiling.

You can have the extension enabled but disable tiling from the tray icon if you want.

Launcher works now ; boy that’s ugly.

I’ll tinker a little to see if I can get used to tiling, otherwise I’ll disable the extension, as I use Applications with Meta key.

Off-topic: is there a CPU and/or RAM consumption (ok, it would be negligible) to have a Gnome extension enabled, but not using it?

Last thing, Pop Shell is not localized either.
But as I never used it before installing Cosmic, perhaps it always has been like that.

So far, so good, no issue detected.

30 min later: I just got an update for Vertical overview extension. I checked, not present in Extensions, and I’ve got the classic Gnome 40 overview. After reboot, gosh it’s ugly too, this Pop overview.

I disabled the extension, weird that it appeared only now, it’s not my first reboot after Cosmic install.

Super + Arrow keys are buggy? Trying to shift focus between windows, and it sometimes doesn’t work or just moves the entire app window to the position, on top of the other window.

PSA: gnome-shell-extension-vertical-overview-cosmic (Pop!_OS fork of Vertical Overview) has been renamed to gnome-shell-extension-cosmic-workspaces (Cosmic Workspaces). Installing the new package will replace the old one.

Still not using it, but after the application switch the vertical overview still works, so do Cosmic dock and Pop Shell.

Fun fact I discovered today at boot, my system boots directly on desktop, no more on overview. Good for me as I never use overview at startup, but I don’t remember having set it specifically. It must be part of one of the Pop settings I did not paid attention to.