[Stable Update] 2021-10-08 - Kernels, Mesa, Browsers, Python, UKUI, PHP, Thunderbird, Pipewire

Hello community,

Another stable branch update with some usual updates for you.

Don’t miss out on our new merch!

  • We updated our Kernels. Note that 5.13 series is marked EOL and 5.12 got removed!
  • Mesa is now at 21.2.3
  • Pipewire got renewed to 0.3.38
  • We updated browsers like Vivaldi, Brave and Firefox
  • Thunderbird is now at 91.1.2
  • Other regular upstream updates including Python

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.284
  • linux49 4.9.283
  • linux414 4.14.248
  • linux419 4.19.208
  • linux54 5.4.150
  • linux510 5.10.70
  • linux513 5.13.19 [EOL]
  • linux514 5.14.10
  • linux515 5.15-rc3
  • linux510-rt 5.10.52_rt47

Package Updates (Tue Oct 5 09:21:03 CEST 2021)

  • stable community x86_64: 614 new and 605 removed package(s)
  • stable core x86_64: 26 new and 26 removed package(s)
  • stable extra x86_64: 373 new and 520 removed package(s)
  • stable kde-unstable x86_64: 311 new and 308 removed package(s)
  • stable multilib x86_64: 20 new and 19 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Before trying to upgrade, please check if your mirror has already synced:

My mirror(s) is (are) not yet updated

Please note that mirrors are not under the control of the Manjaro team and your first port of call when having mirror problems is to try to update your mirrors then try pamac upgrade again.

  • The quick solution:

    sudo pacman-mirrors --geoip && sudo pacman -Syyu
  • The long-term solution:

    • Check the mirrors for your country and the closest neighbouring country

    • Execute:

      sudo pacman-mirrors --country YourCountry,NeighbouringCountry --interactive
    • In the list of presented mirrors, select the green mirrors that are fastest with and on your keyboard and space to select them

    • Tab to the OK button

    • Press Enter

    • Execute:

      sudo pacman -Syyu
      pamac upgrade
    • Check again for no errors, hit Y Enter

    • :hourglass_flowing_sand: :wink:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

Shotcut Scrolling doesn't work any more

You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards.

Fullscreen loses focus

Full-screen apps like YouTube and games:

  • Load fine but after briefly showing the application you’re dumped back into your Desktop Environment (DE) whilst the application was still running fine in the background.
  • Clicking on the running application briefly brings you back to it but you’re dumped again to the DE after a second or 2.

disable the Desktop Icons (DING) extensions

With 21.1.4 and initial 21.1.5 release it was not possible to install on non-BTRFS filesystems

Seems grub-btrfs preinstalled in version 4.10.1 introduced a regression to error out when no BTRFS filesystem was found on your system. This was part of 21.1.4 ISO and our initial 21.1.5 release. Please re-download 21.1.5, which is now fixed.

Fixed ISOs:

58de4cd58b23fea2ef69c055dd0088726350294a  manjaro-gnome-21.1.5-211008-linux513.iso
a8af15b768479ea321c897aa83e573e26bd61784  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
aef8a60820666cddce79c980258693d0cf13da9a  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
564c64ddf342c9b7483c469a6d8dca2f94492719  manjaro-kde-21.1.5-211008-linux513.iso
3781a3c0d3a92496b1418dafb49cef247379aa93  manjaro-kde-21.1.5-minimal-211008-linux513.iso
1f4c83be758275e3d0bb17a0b32138b7a0b313a8  manjaro-kde-21.1.5-minimal-211008-linux54.iso
00737362c81c3c3d4ec7fba6f7a7ec72701a0450  manjaro-xfce-21.1.5-211008-linux513.iso
c2e2f5018d9a50a1112bbcc761a22c8e4dcb7275  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
a34e27a17ab5fcc6473f1ad503d2049a9c904608  manjaro-xfce-21.1.5-minimal-211008-linux54.iso

Broken ISOs:

91cf900bb978dfbb3d32fec083c27d4c428b03ca  manjaro-gnome-21.1.5-211008-linux513.iso
c9f07d7ab4f3bb3a75b1a3c84e909cbf3bd74309  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
7e0673c604e1ce267f59d0056ddf819cede21f38  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
1f56c7feaf7c5fea485b30a6d3c513fb3d0188bb  manjaro-kde-21.1.5-211008-linux513.iso
0922345bdec24b2eb5ed6f635c600b2a499a1ed9  manjaro-kde-21.1.5-minimal-211008-linux513.iso
74fd38b172be9c996d6d59e40e4a730b93f9c88f  manjaro-kde-21.1.5-minimal-211008-linux54.iso
3b9409492b791f4380f617489c63e327ae7f6d53  manjaro-xfce-21.1.5-211008-linux513.iso
10a8d165d9bd0a8edcae1a640e0c753b1ff1c54c  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso
Steam shows black screen

:warning: Opting in or out for Steam beta changes nothing.


  • Open a terminal

  • Execute:

    LD_PRELOAD=/lib/libharfbuzz.so steam
Buzzing sound while using headphones.


  • Execute:

    sudo nano --backup /etc/tlp.conf

  • Only if you have to, set SOUND_POWER_SAVE_ON_BAT=0 as well

No idea how much it affects battery life, though.

Vertex-Maia-Icons are messed up.


  • Vertex-Maia-Icons will be dropped from the repository soon:
  • Choose some new icon theme.
Unable to login in remotely using ssh using rsa keys

After this upgrade authentication might not work and might find the following error in the ssh log:

userauth_pubkey: key type ssh-rsa not in PubkeyAcceptedAlgorithms [preauth]

Good solution:

  • generate new keys using a more secure algorithm like ED25519

Lazy solution (acceptable for rsa keys with a length >= 3000bits):

  1. Execute:

    sudo nano --backup /etc/ssh/sshd_config
  2. copy-paste the following into the above file:

  3. To save, press Ctrl+X Enter Y

It works now, but you’re still using SHA1 which has been showing weaknesses for years now (although it’s not actually cracked, it’s not recommended any more and why ssh disabled it)

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.
Brave segfaults / crashes


  • Clear cache / Data
  • Re-install Brave afterwards

Older Issues:

You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv
nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!


Pahvo 21.1.5 got released!


Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)



10 posts were split to a new topic: Firefox got downgraded to 92 in last update

3 posts were split to a new topic: Unable to login in remotely using ssh using SHA1 after last update

5 posts were merged into an existing topic: [Stable Update] 2021-09-24: LightDM no longer automatically start

3 posts were split to a new topic: Buzzing sound after last update

A post was split to a new topic: To which version did the update today upgrade?

On Manjaro KDE, I got a black screen after reboot.

  • Boot with a Manjaro USB stick

  • Boot from a secondary disk

  • Execute

    sudo update-grub

and then grub boots again.


A post was merged into an existing topic: Unable to login in remotely using ssh using rsa keys after last update

A post was merged into an existing topic: Buzzing sound after last update

2 posts were split to a new topic: Conky doesn’t start during login after lats update

A post was split to a new topic: Wake from sleep broken on Kernel 5.14

2 posts were split to a new topic: Vivaldi downgraded during last update

2 posts were merged into an existing topic: Update breaks dependencies

All well, except for

~$ libinput-gestures-setup restart
libinput-gestures failed to start as a desktop application.

2 posts were split to a new topic: Steam shoiws Black screen only since last update

A post was split to a new topic: Converted to Personal Message

A post was merged into an existing topic: Dell XPS 9575 has black screen during boot after update to Linux kernel 5.14

2 posts were split to a new topic: Neovim breaking changes since last update