Fullscreen loses focus after latest batch of updates

Hi all,

yesterday lots of updates (mesa, vulkan, libraries etc…) appeared in my package manager, as usual I installed all of them and rebooted.
After the reboot I watched some Youtube and noticed the arrow keys no longer skipped forward or went back when watching in fullscreen, but when I clicked on the video in fullscreen they worked again briefly.
Afterwards I wanted to play some games and once again weird behavior appeared, the game loaded fine but after briefly showing the game I was dumped back into my DE whilst the game was still running fine in the background.
Clicking on the running game briefly brought me back to game but I was dumped again to the DE after a second or 2.

It was at that time I realized the updates most likely broke something, luckily I had a Timeshift from before the updates.
I’ve rolled back the system to before the updates et voila, the focus issue was gone.

My questions now are:

  1. Is this also happening to other people?
  2. What can I do to resolve this, except not updating?

I like to keep my system up to date.
Obviously I’ve Googled this issue but nothing useful came up.


System specs:

Manjaro (GNOME / Kernel 5.13.19-2)
AMD R5 3600
Radeon RX 5700XT (Opensource drivers)
256GB Nvme boot drive
5.5TB HDD LVM cached by 2 x 256GB RAID 0 SATA SSD’s

Update and look through the existing solutions and if it’s not in there, post about it!


I just had this exact issue and found a solution! (for me at least)

I noticed the Desktop Icons on Gnome going crazy while the windows got minimized, so I decided to try to disable the Desktop Icons (DING) extensions. Lo and behold, games fullscreen as normal now.

Hope this helps! :slight_smile:

Edit: I opened an issue at the extensions GitLab



so I’ve updated my kernel to 5.14.10-1, reinstalled all the updates and now it appears to be working fine.
No idea what actually caused the issue or if the new kernel was the solution.
I blame cosmic ray bit flips. :grinning:

EDIT: just looked at your Gitlab issue, so you were right, nice catch!
May I ask how you figured that out?

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.