[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Hello community,

Another stable branch update with some usual updates for you.

  • Most of our Kernels got updated
  • Mesa is now at 21.0.2
  • More updates to Gnome 40 Apps
  • Xorg-Server is at 1.20.11, which brings security fixes
  • Bluez got updated to 5.58
  • Plasma and KDE Frameworks got updated to their latest stable releases
  • LibreOffice got updated to 7.1.2
  • PipeWire is now at 0.3.25
  • A lot of KDE-Dev package updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux44 4.4.266
  • linux49 4.9.266
  • linux414 4.14.230
  • linux419 4.19.187
  • linux54 5.4.112
  • linux59 5.9.16 [EOL]
  • linux510 5.10.30
  • linux511 5.11.14
  • linux512 5.12-rc7
  • linux54-rt 5.4.106_rt54
  • linux59-rt 5.9.1_rt19

Packages Changes (Thu Apr 15 23:26:14 CEST 2021)

  • stable community x86_64: 1806 new and 1814 removed package(s)
  • stable core x86_64: 36 new and 36 removed package(s)
  • stable extra x86_64: 697 new and 687 removed package(s)
  • stable kde-unstable x86_64: 364 new and 363 removed package(s)
  • stable multilib x86_64: 27 new and 27 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

26 Likes

Known issues and solutions

  • For TL3s and up: This is a wiki post; please edit as necessary.
  • Please, consider subscribing to the Stable Updates Announcements RSS feed
  • Please,, please, please don’t comment “Everything is fine with my upgrade” but use the voting buttons instead and leave the replies for actual solutions. (Pretty please with :unicorn: :unicorn: :unicorn: and :rainbow: :rainbow: :rainbow: )

New issues:

  • In some rare cases you may face the following error on your KDE Plasma Desktop: usr/lib/libKF5KIOCore.so.5: undefined symbol: _ZN4KJob14percentChangedEPS_mNS_14QPrivateSignalE.

    Please click the ► at the beginning of this line to view this solution

    We filed an issue upstream already.
    Current workaround is to downgrade kio back to 5.79.0:

    wget https://archive.archlinux.org/packages/k/kio/kio-5.79.0-1-x86_64.pkg.tar.zst
    sudo pacman -U kio-5.79.0-1-x86_64.pkg.tar.zst
    echo "IgnorePkg = kio" | sudo tee -a /etc/pacman.conf
    

    Solution: upstream suggests to reboot the machine or issue kdeinit5 once.

  • If you need dual-boot you can reactivate os-prober the easiest with the following command combination in a terminal:

    echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub
    
  • If you have locale issues, have a look here first!

  • Man-pages-de signature error:

    Please click the ► at the beginning of this line to view this solution

    If you get:

    Fehler: man-pages-de: signature from "Jaroslav Lichtblau <svetlemodry@archlinux.org>" is unknown trust
    :: Datei /var/cache/pacman/pkg/man-pages-de-4.9.3-1-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
    Soll die Datei entfernt werden? [J/n] 
    

    execute the following:

       sudo pacman-key --recv-keys 24E4CDB0013C2580
       sudo pacman-key --lsign-key 24E4CDB0013C2580
    
  • Apache error:  httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server

    Please click the ► at the beginning of this line to view this solution

    Full error message:

    MMM DD HH:MM:SS ServerName httpd[45914]: httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server: /etc/httpd/modules/libphp7.so: cannot open shared object file: No such file or directory
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Control process exited, code=exited, status=1/FAILURE
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Failed with result ‘exit-code’.‘exit-code’.
    
    • Execute:

      sudo nano --backup  /etc/httpd/httpd.conf
      
    • change the following lines:

      LoadModule php7_module modules/libphp7.so
      Include conf/extra/php7_module.conf
      

      to:

      LoadModule php_module modules/libphp.so
      Include conf/extra/php_module.conf
      

      Respectively! (They are not necessarily next to one another!)

    • Save (Ctrl+X Enter Y)

    • Restart Apache (or reboot if you don’t know how or to to get that Window$ feeling again)

  • Pulseeffects stopped working

    Please click the ► at the beginning of this line to view this solution

    Execute:

    pamac install manjaro-pipewire
    pamac install gst-plugin-pipewire
    

    OR

    pamac install pulseeffects-legacy
    

    pulseeffects-legacy does not depend on Pipewire and does not require removal of PulseAudio packages

  • gnome-shell-extension-desktop-icons  cannot be updated

    "Please click the ► at the beginning of this line to view this solution
    error: failed to commit transaction (conflicting files)
    gnome-shell-extension-desktop-icons: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/schemas/gschemas.compiled exists in filesystem
    Errors occurred, no packages were upgraded.
    

    please run the following command:

    sudo pacman -S gnome-shell-extension-desktop-icons --overwrite /usr/share/gnome-shell/extensions/\*
    

    and the issue will be resolved.

  • I’m still running on nvidia-450 and I want to recompile the 450 driver (Kernel 5.4 LTS):

    Please click the ► at the beginning of this line to view this solution
    1. Add the line IgnorePkg = lib32-nvidia-utils lib32-opencl-nvidia mhwd-nvidia opencl-nvidia in file /etc/pacman.conf

    2. Upgrade your packages (using the pamac GUI) or:

      pamac upgrade
      
    3. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    4. Boot will be stuck because no driver has been found, just open a console with Ctrl+Alt+F2

    5. First read Note 2 below, then get the sources for your driver (in my case, 450xx):

      git clone https://gitlab.manjaro.org/packages/extra/nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-450xx.git
      
    6. Compile the driver (if you get an error, see Note 3):

      cd nvidia-450xx-utils && makepkg -si
      cd ../lib32-nvidia-450xx-utils && makepkg -si
      cd ../nvidia-450xx && makepkg -sif
      
    7. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    Now, everything is working again! To check if you’re indeed running kernel Linux 5.4, you can run uname --kernel-release in a console, and to check if you’re running the driver you just compiled, you can run inxi --graphics --display OR nvidia-smi

    Note 1: to choose which kernel to boot on, you need to edit those two lines in /etc/default/grub to match those (5 as in 5 seconds to make your choice on the menu, you can put whatever):

      GRUB_TIMEOUT=5
      GRUB_TIMEOUT_STYLE=menu
    

    Then, run sudo update-grub. When booting, you’ll now see a menu with all installed kernels so you can choose which one to use for this session.

    Then finally execute the reboot command:

      sudo reboot 
    

    Note 2: During step 5 and 6: If you already have compiled the nvidia driver during last update, you can skip cloning nvidia-450xx-utils and lib32-nvidia-450xx-utils (you already have the sources, you just need to compile them again), but I suggest you remove your older nvidia-450xx folder (rm -rf nvidia-450xx) and clone it again before compiling this one, otherwise you will get an error like “folder already exists” when trying to compile.

    Note 3: When trying to compile the driver, you might get an error with two nvidia packages creating conflicts (I think lib32-nvidia-utils was one of them, I don’t remember the other one). To fix that, just uninstall those packages with pamac remove <package>.

  • I’m still running on nvidia-450 and I want to upgrade to 460 (Kernel 5.10):

    Please click the ► at the beginning of this line to view this solution
    • Print this page so you have it as a reference while in TTY2

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      pamac remove nvidia-450xx-utils
      #you will get some warnings about optional components needing this: 
      #  no worries, you'll install 460 in the next line
      sudo mhwd --install pci video-nvidia
      sudo reboot
      

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/

Moving to Zstandard images by default on mkinitcpio

Moving to Zstandard images by default on mkinitcpio

2021-02-19 - Giancarlo Razzolini

As linux-lts moved to the 5.10 version, all official kernels of Arch Linux now support zstd compressed initramfs images, so mkinitcpio is switching to zstd compressed images by default with version 30, which is currently on [testing].

If, for any reason, you are using a kernel version prior to 5.9, make sure to change mkinitcpio.conf COMPRESSION to use one of the compressors supported, like gzip, otherwise you will not be able to boot images generated by mkinitcpio.

https://archlinux.org/news/moving-to-zstandard-images-by-default-on-mkinitcpio/


Older Issues

Please click the ► at the beginning of this line to view the older issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

xf86-video-intel already exists in filesystem errors

Please click the ► at the beginning of this line to view this solution

If you get something like this:

error: failed to commit transaction (conflicting files)
xf86-video-intel: /usr/bin/intel-virtual-output exists in filesystem
xf86-video-intel: /usr/lib/libI810XvMC.so exists in filesystem
...
xf86-video-intel: /usr/share/man/man4/intel.4.gz exists in filesystem
xf86-video-intel: /usr/share/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy exists in filesystem
Errors occurred, no packages were upgraded.

Just delete the files that are in conflictand perform the upgrade again.

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

8 Likes

Here are some new links via CDN77.com

Download XFCE

Full

https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510.iso
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510.iso.sig
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510.iso.sha1
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510.iso.sha256
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510.iso.torrent
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-210419-linux510-pkgs.txt

Minimal

https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510.iso
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510.iso.sig
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510.iso.sha1
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510.iso.sha256
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510.iso.torrent
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux510-pkgs.txt

Minimal (linux54)

https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54.iso
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54.iso.sig
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54.iso.sha1
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54.iso.sha256
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54.iso.torrent
https://download.manjaro.org/xfce/21.0.2/manjaro-xfce-21.0.2-minimal-210419-linux54-pkgs.txt

Download GNOME

Full

https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510.iso
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510.iso.sig
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510.iso.sha1
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510.iso.sha256
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510.iso.torrent
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-210419-linux510-pkgs.txt

Minimal

https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510.iso
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510.iso.sig
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510.iso.sha1
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510.iso.sha256
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510.iso.torrent
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux510-pkgs.txt

Minimal (linux54)

https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54.iso
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54.iso.sig
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54.iso.sha1
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54.iso.sha256
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54.iso.torrent
https://download.manjaro.org/gnome/21.0.2/manjaro-gnome-21.0.2-minimal-210419-linux54-pkgs.txt

Download KDE

Full

https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510.iso
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510.iso.sig
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510.iso.sha1
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510.iso.sha256
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510.iso.torrent
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-210419-linux510-pkgs.txt

Minimal

https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510.iso
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510.iso.sig
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510.iso.sha1
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510.iso.sha256
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510.iso.torrent
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux510-pkgs.txt

Minimal (linux54)

https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54.iso
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54.iso.sig
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54.iso.sha1
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54.iso.sha256
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54.iso.torrent
https://download.manjaro.org/kde/21.0.2/manjaro-kde-21.0.2-minimal-210419-linux54-pkgs.txt

8 Likes

Took long enough to post about this when it came out almost 6 hours ago :slight_smile: but as good update <3

1 Like

VULKAN_NOT_FOUND error message when trying to run games in Lutris.
Think Mesa broke my Vulkan drives, had to revert.

2 Likes

Hi,

Kate doesn’t start any more, strange…
I removed and reinstalled, nothing change… doesn’t start

2 Likes

3 posts were split to a new topic: Update - then boot to black screen

lightdm faild to start:

● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sun 2021-04-18 18:41:16 CEST; 1min 23s ago
       Docs: man:lightdm(1)
    Process: 2968 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 2968 (code=exited, status=1/FAILURE)

Apr 18 18:41:16 BlackBox systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Apr 18 18:41:16 BlackBox systemd[1]: Stopped Light Display Manager.
Apr 18 18:41:16 BlackBox systemd[1]: lightdm.service: Start request repeated too quickly.
Apr 18 18:41:16 BlackBox systemd[1]: lightdm.service: Failed with result 'exit-code'.
Apr 18 18:41:16 BlackBox systemd[1]: Failed to start Light Display Manager.

-- Journal begins at Sat 2021-04-10 21:04:55 CEST, ends at Sun 2021-04-18 18:48:55 CEST. --
Apr 18 18:41:16 BlackBox systemd[1]: Failed to start Light Display Manager.
Apr 18 18:42:58 BlackBox lightdm[12504]: gkr-pam: unable to locate daemon control file

I’m sure they give it a bit of time after they upload the update so that the mirrors have time to sync. As of right now there are still 32 mirrors that aren’t fully in sync. It takes time, they don’t want to announce it and then have a thread full of people complaining that they can’t update.

https://repo.manjaro.org/

4 Likes

For those that have a black screen on start, does it work if you remove splash from the kernel line at boot?

That fixes it for me at least.

1 Like

What do you mean?

Minor issue here : black screen aon shutdown.
On start this is fixed. (but reapears on next shutdown : I’ll investigate).

Everything else ok (even PulseEffects on Pipewire)

In your grub menu on system start, if you press ‘e’ to edit the kernel line and remove the word ‘splash’, does it boot normally?

3 Likes

Oh man you saved me!

For the manjaro team: there is a black screen bug on start, removing splash from grub menu fixed it

For reference, these are my logs:
journalctl
inxi

The issue seems to be that gdm doesn’t start when the bootsplash is enabled for me, specifically it seems the bootsplash doesn’t release /dev/dri/card0 properly:

apr 18 16:24:24 harman /usr/lib/gdm-x-session[928]: (II) xfree86: Adding drm device (/dev/dri/card0)
apr 18 16:24:24 harman /usr/lib/gdm-x-session[928]: (EE) systemd-logind: failed to take device /dev/dri/card0: Device or resource busy
apr 18 16:24:24 harman /usr/lib/gdm-x-session[928]: (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

This doesn’t happen when splash is removed from the kernel line:

apr 18 17:00:16 harman /usr/lib/gdm-x-session[1078]: (II) xfree86: Adding drm device (/dev/dri/card0)
apr 18 17:00:16 harman /usr/lib/gdm-x-session[1078]: (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
apr 18 17:00:16 harman /usr/lib/gdm-x-session[1078]: (II) xfree86: Adding drm device (/dev/dri/card1)
apr 18 17:00:16 harman /usr/lib/gdm-x-session[1078]: (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 12 paused 0

E: Downgrading plymouth doesn’t solve the problem.

Python 3.9.3 was recalled due to unintentional breakage of ABI compatibility with C extensions built-in Python 3.9.0 - 3.9.2. as in this link.

3 Likes

The Arch python package is flagged out of date, not sure why they haven’t updated to 3.9.4 yet.

3 Likes

Ok, I removed the “splash” word, and worked. Thanks.
Whus this happened? There is an explanation?

Alright, it seems to be an issue with the GDM package in my case.

E: Bad advice removed, see @Yochanan below instead

Only happen on the linux511 Kernel
linux510 is fine