[Stable Update] 2021-06-07 - Kernels, Perl, Haskell, Tesseract, Cutefish, KDE, Nvidia

Hello community,

Another stable branch update with some usual updates for you.

Cutefish is a new DE, designed for tablets and desktop, based on qt and plasma: get the ISO!

  • Most of our Kernels got updated
  • Nvidia driver is now at 465.31. If you use Display-Port see also this!
  • There was a perl rebuild by upstream Arch. Tell us if we missed some rebuilds!
  • Cutefish DE got added
  • Kodi-Addons got updated
  • AMDVLK is now at 2021.Q2.4
  • LibreOffice is at 7.0.6
  • Mesa got updated to 21.1.2
  • Our toolchain got updated to gcc 11
  • KDE Gear got updated to 21.04.1
  • Lot of KDE-git package updates and removal from [community] repos
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Download 21.0.6

Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)


Our current supported kernels

  • linux44 4.4.270
  • linux49 4.9.270
  • linux414 4.14.234
  • linux419 4.19.192
  • linux54 5.4.123
  • linux510 5.10.41
  • linux511 5.11.22
  • linux512 5.12.8
  • linux513 5.13-rc4
  • linux54-rt 5.4.115_rt57
  • linux59-rt 5.9.1_rt19
  • linux511-rt 5.11.4_rt11

Package Updates (Mon May 31 09:42:31 CEST 2021)

  • stable community x86_64: 2306 new and 2206 removed package(s)
  • stable core x86_64: 67 new and 68 removed package(s)
  • stable extra x86_64: 942 new and 1000 removed package(s)
  • stable kde-unstable x86_64: 375 new and 364 removed package(s)
  • stable multilib x86_64: 44 new and 42 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • Some Nvidia cards don’t work with the current 460.80 drivers when used with Display Port and/or 4k Monitors. More about the issue at the Nvidia Developer Forum. We recommend to switch to Nouveau driver as needed. If you however need the Nvidia driver, you can get the PKGBUILDs of the 460.73.01 version and build your driver locally with makepkg or use the pre-compiled packages: nvida-utils, dkms and lib32 + precompiled .

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

GDM does not start (black screen when booting gnome edition)

Log into your system via tty and depending on your use of Plymouth or bootsplash-systemd choose a option from this post

1 Like
  • Terminal prompt broken after this update.
  • rofi won’t start (error " Failed to set locale.")
  • py3status won’t start (error “No locale available”)

Other apps complain about missing locales but start with a fallback to C.

locale says:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


$ ls -la /etc/locale.gen 
-rw-r--r-- 1 root root 9984 May 12 21:18 /etc/locale.gen

But I did not edit locale.gen.

1 Like

After last update:
“Failed to Start Simple Desktop Display Manager”.
Using RX580 and Ryzen 5 3600X with KDE Plasma DE.
Re-installing SDDM - didn’t help.
Disconnecting my second monitor also comes with nothing - same error.

1 Like

KDE ryzen + nvidia (proprietary) system prompts the following when update tried.

resolving dependencies…
warning: cannot resolve “expat=2.4.1”, a dependency of “lib32-expat”
warning: cannot resolve “libcap=2.50”, a dependency of “lib32-libcap”
warning: cannot resolve “libelf=0.184”, a dependency of “lib32-libelf”
warning: cannot resolve “expat=2.4.1”, a dependency of “lib32-expat”
warning: cannot resolve “libelf=0.184”, a dependency of “lib32-libelf”
warning: cannot resolve “libelf=0.184”, a dependency of “lib32-libelf”
:: The following packages cannot be upgraded due to unresolvable dependencies:
lib32-expat lib32-libcap lib32-libelf
:: Do you want to skip the above packages for this upgrade? [y/N]

responding default N fails update. Dependency list seems weird.

Packages skipped. No problems so far

I’m getting this when updating:

==> dkms install --no-depmod -m rtbth -v 3.9.6.r8.g989b89b -k 5.12.8-1-MANJARO
Error! Bad return status for module build on kernel: 5.12.8-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtbth/3.9.6.r8.g989b89b/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m rtbth -v 3.9.6.r8.g989b89b -k 5.12.8-1-MANJARO' returned 10

EDIT : It doesn’t really cause any problems though. Bluetooth works just fine.

No problems here on three KDE computers :slight_smile:


1 Like

Check this out:

1 Like

5 posts were split to a new topic: Steam-native crashing

That’s not a valid locale, the last part should be uppercase en_US.UTF-8 (and with a hyphen as @dolour spotted/posted below).

1 Like

I have an Dell XPS 9560 which has a NVIDIA GTX 1050 and I use a CallDigit TS3 dock connected to two DisplayPort connected LG 27UD69P 27" 4K monitors. One monitor is connected with a USB-C-DisplayPort cable and the other is connected with a DisplayPort to DisplayPort cable.
I have had no problems with the NVIDIA drivers in this update with kernel 5.11.22-2 and KDE.
Was expecting problems based on previous reports and had a TimeShift backup ready to go. Thankfully, I didn’t have to use it.

That links to manjaro’s gitlab which

  1. wants me to log in there
  2. produces a 404 (not found) error



No problems with KDE version running at VMWare VM.
Kudos for awesome update.

Maybe this can help somebody considering the update:

I have the following setup and had no issues regarding the Nvidia drivers:

LG 27UD58P-B 4K monitor connected directly to DP
Samsung S24D300H 1080p monitor connected to DP with an HDMI adapter
NVIDIA RTX 2080 SUPER using proprietary drivers

1 Like

All those normal packages got updated as you can see in the list. Else it would have been reported earlier.

Always has been en_US.utf8 so far via Manjaro install. Dunno where you should get the upper case UTF8 version.

I dont think upper- or lowercase matters (although its consistently uppercase on my list, which also uses just defaults), but there seems to be a “-” missing. Afaik it should be “en_US.UTF-8”

1 Like

Weird, not on my machines:

$ grep en_US /etc/locale.gen
#  en_US ISO-8859-1
#  en_US.UTF-8 UTF-8
#en_US.UTF-8 UTF-8  
#en_US ISO-8859-1

edit: /etc/locale.gen is owned by glibc package. Just extracted the last version in my package cache - it’s the same uppercase spelling there.

I experienced graphical glitches in applications that use OpenGL with my AMD R9 graphics card upon updating mesa to the version in this stable update (21.1.2-0). However, switching to unstable branch and updating just the mesa packages to version 21.1.2-1 seems to have corrected the graphical issue for me. I don’t know if this information is helpful to anybody else, but I thought I’d share it.

edit: Graphical glitches still appearing with mesa 21.1.2-1 even. I was wrong, they haven’t gone away. Ignore everything I have written here… my apologies…

The graphical glitches look like this–> https://bugs.archlinux.org/task/71015?getfile=20328


Maybe check in a live-session with a fresh 21.0.6 ISO if you have the same graphical glitches. They just finished building. Links are in the first post of this thread.