My internet connection is no longer working

same here; after this update and rebooting a few times,i can’t connect to the internet.
I’m using DSL/PPPoE with a username and password provided by the ISP.
i tried restarting the Network Manager service but to no avail.
i’m quit annoyed as i have things to do.
i’d appreciate some urgent help.

`inxi`
System:
  Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a445c87d-e6a9-47fd-9601-614f3b3e7781 rw quiet apparmor=1
    security=apparmor resume=UUID=29e42246-1548-46dd-91f5-17d1f76c7bfd
    udev.log_priority=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX705GD_FX705GD v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX705GD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX705GD.306 date: 05/25/2020
Battery:
  ID-1: BAT0 charge: 56.8 Wh (100.0%) condition: 56.8/64.1 Wh (88.5%)
    volts: 16.3 min: 15.6 model: Simplo SDI ICR18650 type: Li-ion
    serial: <filter> status: Full cycles: 41
CPU:
  Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 3856 high: 4100 min/max: 800/4100 scaling:
    driver: intel_pstate governor: performance cores: 1: 3863 2: 4052 3: 3913
    4: 4010 5: 3327 6: 4052 7: 3724 8: 3728 9: 3917 10: 4100 11: 3728 12: 3866
    bogomips: 52815
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1c8d
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-11:4 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 model: AU Optronics built: 2018 res: 1920x1080 hz: 60
    dpi: 128 gamma: 1.2 size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 476.94 GiB used: 64.99 GiB (13.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
    model: RBUSNS8154P3512GJ size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: E8FK11.C temp: 45.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.84 GiB size: 459.5 GiB (98.22%)
    used: 64.99 GiB (14.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 57.0 C pch: 47.0 C mobo: 27.8 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 297 Uptime: 17m wakeups: 1 Memory: 15.48 GiB
  used: 2.93 GiB (18.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1371 lib: 398 flatpak: 0
  Shell: Zsh v: 5.8.1 running-in: konsole inxi: 3.3.13

Edit: i’m currently using a mobile Hotspot.

Nope that was the first thing i have tried myself… smth changed with this update in some network manager related file… problem is I lack the familiarity to even know what exact files are those and if I can simply replace them with a functional prior version of themselves from my bootable usb stick…

Its amazing how smth like this slipped into the stable build… either way i’m out of ideas and short of taking some more blind shots based on the arch wiki tomorrow ill just call it quits and scrap the distro altogether in favor of smth that doesn’t require me to flip trough douzens of wiki pages just to get a simple working PPoE connection.

Welcome to the club linub seems like you got the same exact issue i got and suspect more folks will be joining use soon enough(probably all that are using a dsl/ppoe)

seems that you’re 2 with same issue now. That seems to be an issue with PPoE-connections. Hopefully some cracks will join the thread and are able to give more knowledge than me.
is there a possibility to downgrade ?

@grraf already tried as mentioned in his first post.

What says ip addr ?

If you are refering to the network manager i already tried that but it doesn’t help hence my assumption that some settings files got modified somewhere and isnt an issue of the networkmanger itself.
But as i stated before i’m no dev and haven’t got a clue what those files are and what was changed to them.

is safe to share?and does it matter now that i’m using a Hotspot+VPN?

Edit:
is this related?

there’s a command they suggest that might fix it,but not sure i should run it.

It happened to me as well, except I couldn’t access specific domains for whatever reason, i.e. google, and judging from the comments you left, I decided to downgrade the version of Network Manager.

If you don’t have it, install the downgrade package:
sudo pacman -S downgrade

After that, downgrade the networkmanager package:
sudo downgrade networkmanager

Select any version prior to 1.36, I chose 1.34 and after that’s done, just restart the service:
sudo systemctl restart NetworkManager

Hope this helps at least someone, I’m not sure how to go about this if you’ve lost connection to the outside world. :frowning:

2 Likes

ip addr only shows your network connection and not your ip adress.

unfortunately i cleared old packages sometime ago.
can i download NetworkManager 1.4 from a manjaro repository?

Well a downgrade of both networkmanager&libnm to version 1.34 then doing sudo systemctl restart NetworkManager does the trick…

The reason i failed on my first downgrade attempt was due to not also downgrading libnm alongside networkmanager

Anyways thank you folks for yr help i guess its problem solved for now…

If I had to guess, you could try:

pacman -U https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

Which should install 1.34 for you, but like @grraf wrote, you might also need to downgrade the libnm package as well.

1 Like

is there a list like that for Manjaro?
shouldn’t a package be ported/ built or compiled for manjaro first?(i have no idea what i’m saying)

Well Arch packages worked for me whenever I needed to get something working on Manjaro, and since it’s Arch-based, things tend to “just work” with Arch packages.

i’ve manually downloaded both
libnm-1.34.0-1-x86_64.pkg.tar.zst and networkmanager-1.34.0-1-x86_64.pkg.tar.zst
can i just put them both in /var/cache/pacman/pkg/ and do a downgrade from there with :
downgrade networkmanager
downgrade libnm ?

edit
That’s exactly what i did :point_up:

Thanks @crni , you’ve been of great help.

[Testing Update] 2022-04-04 - Mesa 21.3.8, Blender 3.1.2, Xorg-Stack, Haskell, Python
[Testing Update] 2022-03-16 - GStreamer, Haskell, KDE Frameworks, Budgie, NetworkManager, Calamares
[Stable Update] 2022-04-15 - Kernels, Mesa, Nvidia, Budgie, PipeWire, LIbreOffice, KDE Frameworks, Wine
[Stable Update] 2022-06-12 - Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire, LibreOffice
[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0
[Stable Update] 2022-03-14 - Kernels, KDE, LibreOffice, Kodi, Qt5, Mozilla, NetworkManager, Pipewire
[Testing Update] 2022-03-20 - Kernels, Haskell, Python, Gnome, PHP
[Testing Update] 2022-05-17 - Kernels, Toolchain, Nvidia, KDE, Qt, Maui, LibreOffice
[Testing Update] 2022-03-24 - Linux517, Nvidia, Palemoon (not)
[Testing Update] 2022-04-02 - Kernels, Mesa, Plasma 5.24.4, Deepin, LibreOffice, PipeWire, Wine 7.5
[Testing Update] 2022-05-18 - Kernels, Plasma
[Testing Update] 2022-04-25 - Kernels, Mesa, Gnome 42, KDE Apps & Frameworks, LxQt, Firefox, Thunderbird, Virtualbox
[Testing Update] 2022-05-04 - Kernels, Plasma 5.24.5, Systemd, Gstreamer, Pipewire, Firefox, Thunderbird
[Testing Update] 2022-05-21 - Mesa 22.0.4, Firefox 100.0.2, Qemu
[Testing Update] 2022-05-23 - KDE-Git, Haskell
[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird
[Testing Update] 2022-06-07 - Kernels, Mesa 22.1.1, Haskell, Perl, Python, Pamac
[Testing Update] 2022-06-23 - Kernels, KDE Frameworks, Cinnamon 5.4, Qt5, Gstreamer, Haskell, Python
[Stable Update] 2022-06-24 - Kernels, KDE Frameworks, Cinnamon 5.4, Qt5, Gstreamer, Haskell, Python
[Testing Update] 2022-05-19 - Kernels, Qt5, KDE-Git, Firefox Beta, Haskell
[Testing Update] 2022-05-10 - Kernels, Mesa, Gnome 42.1, LibreOffice, Gstreamer, Qemu
[Testing Update] 2022-06-10 - Kernels, Pipewire, KDE Gear 22.04.2, Haskell, Python, LibreOffice

This is what happened to me.

  • Using Manjaro GNOME on kernel 5.15, WiFi card Intel AC 9260. Other kernel installed (as backup) was 5.10.
  • Installed all the updates, and rebooted.
  • Found that WiFi was no longer working and inaccessible in the settings GUI.
  • Tried plugging in an EDIMAX USB WiFi dongle, didn’t work.
  • With the WiFi dongle still plugged in, rebooted into kernel 5.10 (fallback initramfs)
  • Still no WiFi, so I went to get a coffee. Miraculously when I came back, both the Intel WiFi card and dongle were enabled and I’m back online.
  • Unplugged the WIFi dongle.
  • Installed Kernel 5.16, rebooted. WiFi card was still working.

Staying on Kernel 5.16 for now. Day 2: WiFi is still working normally on Kernel 5.16.

there’s two things i wonder;
-how come we are so few to be affected,how are people connecting to the internet?
-how much time can i have those 2 packages in ignore before things starts to break?

Mostly via a router (or combined modem/router).
The router makes the PPPoE connection to the ISP on the WAN side,
and has a builtin DHCP server that sets up any PC that connects to the LAN side.

Most likely someone at Arch will fix it soon.
More likely if people send bug reports…

that sounds just like what i’m using; a modem/router provided by the ISP.

i did; upstream.

Edit
no need to downgrade; it’s fixed with 1.36.2-1.0

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.