[Testing Update] 2022-06-07 - Kernels, Mesa 22.1.1, Haskell, Perl, Python, Pamac

Hello community,

Another testing branch update with some usual updates for you.

Small but POWERFUL! Check out Beelink’s SER4 with Manjaro pre-installed and ready to rock:
Visit the store

  • Most of our Kernels got updated
  • Linux 5.19-rc1 got added
  • Mesa 22.1.1: Release notes
  • Pamac got a new point-release. Also its lib got some enhancements and fixes
  • Some more Perl, Python and Haskell updates
  • Daily KDE-git updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.246
  • linux54 5.4.197
  • linux510 5.10.120
  • linux515 5.15.45
  • linux517 5.17.13
  • linux518 5.18.2
  • linux519 5.19-rc1
  • linux515-rt 5.15.44_rt46
  • linux518-rt 5.18.0_rt11

Package Changes (Tue Jun 7 08:05:09 CEST 2022)

  • testing community x86_64: 1252 new and 1247 removed package(s)
  • testing core x86_64: 29 new and 27 removed package(s)
  • testing extra x86_64: 176 new and 167 removed package(s)
  • testing kde-unstable x86_64: 279 new and 279 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-06-07

Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.


QEMU >= 7.0.0 changes split package setup

2022-05-09 - David Runge

With the update to qemu 7.0.0 the package has been turned into a more fine grained split package utilizing meta packages.

  • The qemu package is now virtually provided by the meta packages qemu-base, qemu-desktop and qemu-full.
  • The functionality of qemu prior to 7.0.0 is replaced by qemu-desktop
  • The functionality of qemu-headless is replaced by qemu-base
  • The functionality of qemu-arch-extra and qemu-headless-arch-extra is replaced by qemu-emulators-full
  • The meta package qemu-full provides all QEMU related packages (excluding qemu-guest-agent)


Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild it:
pamac build qt5-styleplugins
FIXED? VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

FIXED? DSL/PPPoE may require downgrading 2 packages

See my-internet-connection-is-no-longer-working and FS#73948 - networkmanager 1.36.0 breaks DSL connection

Please check if 1.36.2-1.0 of NetworkManager improve things, else downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst


New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic

systemd 251.2-2 and filesystem 2021.12.07-5 breaks the system - must go back to old version !!!

The old etc/locale.conf was deleted and the new only includes LC_COLLATE=C - doesn’t work !!!


1 Like

I just have gotten the update and rebootet.
I’m using Cinnamon Desktop with german locale.

  • after Login Cinnamon wants to rename the folders in my home Dir
  • Desktop locale is EN
  • I cannot start any program when clicking an icon

How can I fix this?

My /etc/locale.conf was backed up to /etc/locale.conf.pacsave. Would it be safe to just replace the new /etc/locale.conf with the backup?

gnome-terminal can not start in Gnome.
journalctl shows the error:

systemd[1311]: Failed to start GNOME Terminal Server.

It looks like that LANG=C in /etc/locale.conf breaks some apps.


  • Restore the old files /etc/locale.conf and /etc/locale.gen or edit them manually.
  • Rebuild locales sudo locale-gen
  • Reboot
  • It works for me

If you need more info:

Please correct me if I’m wrong.


Virtualbox can not start or takes frozen in some hardware (e.g. Intel 11th gen CPU in laptop) when using Linux Kernel 5.18.

The known issue:


  • Switch back to Linux Kernel 5.17
1 Like

No, it did not work here.

I restored locale.conf and locale.gen, then ran locale-gen.

After reboot my Cinnamon UI is still in EN locale and I cannot change it, because nothing can be run under the UI.

And another finding.

Logging in on TTY gives:

warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8): No such file or directory
warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8): No such file or directory

I haven’t rebooted yet, but there’s been no issues since the latest update of glibc, systemd and filesystem so far. One remark though: I used to manually modify locale.gen uncommenting locales I need after every glibc update, and I today I did it too. Then sudo locale-gen and voilà presto!

However, I’m not going to reboot for a while, there’s a lot of work to do and I don’t want to break into :sob:, so looking forward to any further comments.

I cloned /etc/locale.conf.pacnew as /etc/locale.conf and rebooted.
Language DE is working again. (kernel5.15.45)

Ok I had the wrong locale.gen with only C locale.

Restored the right locale.gen then ran locale-gen.
Now it’s working again.


I noticed that too, but what ist the effect of filesystem 2021.12.07-5 ?
Systemd 251.2-2 ==> keyboard-error because of missing non-existing keys /
QJournalctl breaks kernel…

I’ve just updated the wiki post, please review:

1 Like

Still high cpu load of qemu-system-x86 on kernel 5.18.2 and 2x sandy bridge xeon e5-2687w.
It doesn’t happen with 5.17.x and 5.15.x.
I noticed the high load is there only in the first minutes (about 5 minutes) from booting the host (manjaro) and the vm.

mmm by comparing top commands in all kernels the load on cpu seems to be the same, but for some unknown reason the vm is stuttering with 5.18.2…

After updating I’ve not edited /etc/locale.conf but did did run sudo locale-gen
These are active: en_US.utf8 & nl_NL.utf8

$ cat /etc/locale.gen | grep -v '#'                                                                           
en_US.UTF-8 UTF-8  
nl_NL.UTF-8 UTF-8
$ locale -a                                         
$ cat /etc/locale.conf                                                                                                      
 #This is the fallback locale configuration provided by systemd.

The old config has more settings, logging in from tty and gnome terminal, region and language settings are all working & correct and nothing seems broken so far.

$ cat /etc/locale.conf.pacsave                             

@Yochanan MSM > Locale Settings > Detailed Settings, fields for formats are empty after update. Is an update /adjustment necessary for it?

Running cinnamon desktop and everything seems ok apart from terminal/cli. I can’t open terminal, it just doesn’t launch which means I have to alter my pacsave via gui (or install another terminal via gui)

Did you try any tty? ctrl+alt+f2 for example?

1 Like