[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

Hello community,

welcome to our monthly stable update. This will mark the beginning of 22.0 release. We will start to polish the experience and might issue the first preview install images soon.


Get 40 USD discount on our MiniPC from Minisforum via Code: CVN00HKD82A6. Visit the store today!

Some Update highlights with this one:

  • All Kernels got updated

  • GNOME got updated to 42.1.

    • More info about theme changes in the dedicated post of this update announcement!
  • Plasma got updated to 5.24.5

  • KDE Frameworks are now at 5.93.0

  • KDE Gear got renewed to 22.04.0

  • Mesa 22 got its third stable release

  • Octopi saw a new release

  • VirtualBox is at 6.1.34

  • LxQt got updated to 1.1.0

  • Systemd got updated to 250.5

  • Pipewire got updated to 0.3.51

  • Firefox got updated to 100.0

  • Thunderbird got updated to 91.9.0

  • NVIDIA production branch release driver updated to 510.68.02

  • Gstreamer got updated to 1.20.2

  • LibreOffice is at 7.3.3

  • Mesa got updated to 22.0.3

  • Qemu got renewed to 7.0.0.

    • Now Qemu is split so you may only install those components you may need.
  • Usual Haskell and Python package updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Annoucement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux49 4.9.312
  • linux414 4.14.277
  • linux419 4.19.241
  • linux54 5.4.192
  • linux510 5.10.114
  • linux515 5.15.38
  • linux516 5.16.20 [EOL]
  • linux517 5.17.6
  • linux518 5.18-rc6
  • linux515-rt 5.15.36_rt41
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt17

Package Changes Tue May 10 06:36:12 CEST 2022)

  • testing community x86_64: 1350 new and 1343 removed package(s)
  • testing core x86_64: 22 new and 22 removed package(s)
  • testing extra x86_64: 342 new and 344 removed package(s)
  • testing kde-unstable x86_64: 211 new and 210 removed package(s)
  • testing multilib x86_64: 33 new and 33 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

25 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:


:arrow_right: 2022-05-13

Chromium / Google Chrome cannot save files to most folders (GNOME and Xfce)

This is an upstream bug with the package xdg-desktop-portal-gnome

In the meantime, you can try to remove the package xdg-desktop-portal-gnome (if feasible, without any dependency issues or conflicts), or wait for the bug to be fixed upstream.

Without any xdg-desktop-portal-* packages, Chromium and Google Chrome should correctly detect the environment and present either KDialog (KDE) or GTK file picker (GNOME, Xfce) upon saving and downloading files.

An alternative workaround, for now, is to intentionally click on the filename field, and then press Enter to save / download the file.

GNOME 42: theming and COSMIC packages changes, Bluetooth disabled by default
libkipi: Pamac fails to build the package from AUR
  • libkipi is a deprecated dependency for some KDE applications, and has been moved to AUR.
  • When using Pamac graphically, you can disable the update for libkipi, before removing it from your system.
  • When using Pamac from the terminal, you can proceed the update in multiple steps:
pamac upgrade --no-aur
pamac remove libkipi
pamac upgrade --aur
TimeShift: new rsync snapshots do not show
sudo pacman-mirrors -f 5 && sudo pacman -Syu
Wine: cannot be built locally
GNOME 42 Xorg Fractional Scaling

Please install gnome-control-center from the repo after this update and reboot.

pamac install gnome-control-center

gnome-control-center-x11-scaling is currently not available for GNOME 42, because Ubuntu is using version 41 for their current LTS and the patches have not been ported.

You can still use mutter-x11-scaling but will have to enable/disable fractional scaling via gsettings.
To enable fractional scaling after installation run:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

To disable fractional scaling run:

gsettings reset org.gnome.mutter experimental-features

See also here and here.

2022-04-15

KeePassXC auto-type does not work

Upgrading KeePassXC from version 2.6.6 to 2.7.0 partially breaks the “auto-type” function. This is fixed upstream in version 2.7.1.

In in the meantime, to have it behave (and work) as it did with version 2.6.6, change the following option:

Tools → Settings → General → Auto-Type → uncheck “Always ask before performing Auto-Type”

Version 2.7.1, which did not make it into this batch of Stable Updates, works correctly, even with the above option enabled.

Desktop Icons (DING) Gnome extention and File Previews stop working due to a crash in sushi.

This has been fixed upstream in sushi version 41.2. To restore functionality you can manually upgrade.

sudo pacman -U https://archive.archlinux.org/packages/s/sushi/sushi-41.2-1-x86_64.pkg.tar.zst

2022-03-14

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild or remove it:
pamac build qt5-styleplugins
DSL/PPPoE may require downgrading 2 packages

First please check if new bugfix version 1.36.2-1.0 of NetworkManager improves things.

If it does not, downgrade to 1.34.0 (and restart network manager after) :

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

Bug report: FS#73948 - networkmanager 1.36.0 breaks DSL connection

Older dicussion: my-internet-connection-is-no-longer-working

mangohud (AUR) prevents Wine/Proton applications from starting
  • Consider disabling the mangohud overlay until the bug is fixed upstream.
VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

2022-02-27

Microsoft Teams does not open.

See this thread.

2022-02-05

Issues with Jack2 when using Pipewire.

Pipewire tend to replace all stuff related to Audio. This time jack2 seems to create issues. In the past pipewire-jack provided jack2. However, since the lack of dbus support that line got removed and only conflicts kept. So if you use jack2 with the dbus feature, you may want to remove the pipewire-jack package. If not you can continue and additionally install lib32-pipewire-jack package.

Last update removed linux514. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have.

sudo mhwd-kernel -r linux514
sudo pacman -Syu
sudo mhwd-kernel -i linux515
New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic
12 Likes

:information_source: GNOME 42 has arrived! :partying_face:

Gtk 4 theming and Libadwaita
Unfortunately, there will be no custom theming available for Libadwaita applications. However, once the Libadwaita Recoloring API is implemented, we should be able to add Maia to the color palette.

I suggest installing the adw-gtk-theme from our community repo to make all Gtk applications have a matching theme. In Tweaks, set the Legacy Applications theme to Adw or Adw-dark. I recommend setting the Shell theme to Default or another shell theme you prefer that has GNOME 42 support.

To automatically switch the system theme and legacy application theme when toggling between the Light and Dark style in Settings, install the Legacy (GTK3) Theme Scheme Auto Switcher extension (gnome-shell-extension-legacy-theme-auto-switcher).

Qt application theming
For Qt application theming, we have switched back to QGnomePlatform for GNOME 42. qt5ct and qt6ct (Qt Configuration Utilities) may be marked as orphans. If you want to use QGnomePlatform with the Adwaita Qt style, you’ll need remove or comment the QT_QPA_PLATFORMTHEME variable in /etc/environment. You’ll want both qgnomeplatform and qgnomeplatform-qt6 for Qt 5 and Qt 6 applications.

New Adwaita folder icon style
If you want the new Adwaita folder icon style with Papirus, you can use papirus-folders to set it:

For example, with Papirus-Dark:

papirus-folders -C adwaita --theme Papirus-Dark

Manjaro COSMIC status
For those using the Manjaro COSMIC packages, you will need to remove them. I’ve dropped them from the repos. Once System76 finishes their new Gtk 4 applications for Pop!_OS, I’ll see about adding them.

KNOWN ISSUES

If you’re not using GNOME

If you want to change the theme of Libadwaita applications on another Gtk desktop like Xfce or Cinnamon, you can use the following commands:

Light Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme default

Dark Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme prefer-dark
8 Likes
Latest Updates vs Themes
Bluetooth disabled after suspend
3 problems since the last update: Internet connection not working, some extensions not working, can't change theme
Applications not using system wide theming
The themes are not consistent after upgrade to gnome 42 in stable update 2022-05-13
[Stable Update] 2022-07-18 - Kernels, Pipewire, Mesa, Xorg, XWayland, Gnome, KDE Gear, Plamo
Bluetooth is disabled by default after upgrading to the latest stable
How to bring back the greenish look?
Manjaro-gnome-settings and manjaro-gdm-theme are in conflict, error: unresolvable package conflicts detected
[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird
GNOME 42 broke my Bluetooth
An array of apps do not seem to adopt the configured window theme anymore
[Stable Update] 2022-06-24 - Kernels, KDE Frameworks, Cinnamon 5.4, Qt5, Gstreamer, Haskell, Python
[Stable Update] 2022-07-21 - Cinnamon 5.4, Kodi Game-Addons, Pipewire 0.3.56, KDE-Git
[Stable Update] 2022-07-04 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell
[Stable Update] 2022-07-29 - Kernels, Cinnamon, Haskell, Python, Virtualbox, Mesa
[Stable Update] 2022-07-12 - Kernels, Pipewire, Mesa, KDE Gear, Plasma, KDE Frameworks, Gnome, Python, Haskell
Gparted and timeshift ignore system theme
[Stable Update] 2022-08-07 - Kernels, Nvidia, Thunderbird, Cinnamon, Glibc, GCC, LibreOffice, Firefox, MangoHud, KDE-git
Chromium file dialog is not using the default file manager
GNOME in Manjaro is applying dark mode only to some GNOME apps, not to all
[Stable Update] 2022-06-12 - Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire, LibreOffice

Just tried to install the update, but I get the error:

Kann Abhängigkeiten nicht erfüllen:
- unable to satisfy dependency 'nvidia-utils=510.60.02' required by linux516-nvidia

It also says something about “libkipi”…
Could you pls help me?

1 Like

Yes. Read carefully:

6 posts were split to a new topic: Failed to build libmediawiki

2 posts were merged into an existing topic: I cannot upgrade libkipi

i got an error while updating

:: installing icu (71.1-1) breaks dependency ‘libicuuc.so=70-64’ required by harfbuzz-icu
:: installing icu (71.1-1) breaks dependency ‘icu<70.2’ required by manjaro-settings-manager
:: installing icu (71.1-1) breaks dependency ‘libicuuc.so=70-64’ required by raptor

anyone know how to fix it?

Probably not fully synced mirror.

i did sudo pacman-mirrors it looks like my mirror is ok

[sudo] password for lunarfox:
Pacman-mirrors version 4.23.2
Local mirror status for stable branch
Mirror #1 OK 00:33 Australia https:// manjaro.lucassymons. net/

After the update I am experiencing problems starting JOSM, a Java application via .jnlp, console output giving me this:

[xxx@xxx ~]$ /usr/share/icedtea-web/bin/javaws "https://josm.openstreetmap.de/download/josm.jnlp"
selected jre: /usr/lib/jvm/default-runtime
Warning!, Fall back in resolve_jar to hardcoded paths: 
/usr/share/java/js.jar
WARNING: package sun.applet not in java.desktop
WARNING: package com.sun.net.ssl.internal.ssl not in java.base
WARNING: package javax.jnlp not in java.desktop
Exception in thread "main" java.lang.UnsupportedOperationException: The Security Manager is deprecated and will be removed in a future release
        at java.base/java.lang.System.setSecurityManager(System.java:416)
        at net.sourceforge.jnlp.runtime.JNLPRuntime.initialize(JNLPRuntime.java:268)
        at net.sourceforge.jnlp.runtime.Boot.init(Boot.java:353)
        at net.sourceforge.jnlp.runtime.JnlpBoot.run(JnlpBoot.java:58)
        at net.sourceforge.jnlp.runtime.Boot.run(Boot.java:274)
        at net.sourceforge.jnlp.runtime.Boot.run(Boot.java:63)
        at java.base/java.security.AccessController.doPrivileged(AccessController.java:318)
        at net.sourceforge.jnlp.runtime.Boot.main(Boot.java:214)

Update:

The issue applies only to java-18-openjdk, no problems with java-17-openjdk.

1 Like

i fixed it it seems all i had to do was restart

i got an error while updating
:: installing icu (71.1-1) breaks dependency ‘libicuuc.so=70-64’ required by harfbuzz-icu
:: installing icu (71.1-1) breaks dependency ‘icu<70.2’ required by manjaro-settings-manager
:: installing icu (71.1-1) breaks dependency ‘libicuuc.so=70-64’ required by raptor

This is fixed. we missed to update that particular linux516-nvidia package.

1 Like

The libkipi issue is a problem with the key. Using Pamac, I trusted the source (after all, so far the library has been working just fine), and was able to update the package.
Remember, though, that it’s an AUR library -no guarantees that it won’t give you a headache.

3 Likes

Just about everything seems to be working fine on my GNOME + Nvidia system. However, it looks like the option for a GNOME Wayland session has disappeared from GDM’s lower-right corner options menu. Anyone know what I can do to get it back? I’m using the 510.68.02 proprietary driver.

This is fixed. we missed to update that particular linux516-nvidia package.

Or
reboot on kernel 5.15 LTS , remove 5.16
do update and add kernel 5.17

Some packages always want to upgrade to AUR version. They are abandoned in Arch/Manjaro repo? Stellarium, kipi-plugins, libkipi, libvkontakte, they didn’t get an update in repo? Or someone tries to scam thru AUR?

1 Like

OpenCL stopped working after the update. Even clinfo shows 0 platforms.

Error message: clGetPlatformIDs(0, 0, &num_platforms) returned -1001

This in on an intel HD 520 graphics machine (i5-6200U) running kernel 5.15.38-1. Following packages are installed (I believe these are the relevant ones):

intel-compute-runtime 22.18.23063-1
intel-gmmlib 22.1.2-1
intel-graphics-compiler 1:1.0.11104-1
opencl-clhpp 2.0.16-1
opencl-headers 2:2022.01.04-1

Previously (before the update), OpenCl was working but only with the AUR version of intel-graphics-compiler. After this update, neither the AUR nor the Manjaro repository versions are helping. The issue might be somewhere else.

If anyone could suggest what I should it, I would really appreciate it.

More than 430 updated packages, 1.9GB of downloaded data. Process took ~8 minutes and one restart - and everything looks fine. Teams is working, so does KVM/Qemu - these are usually my major pain points. I’m impressed, well done.

EDIT: GNOME on 5.17 kernel, x.org instead of Wayland, btrfs root fs, AMD Ryzen 9

1 Like

After upgrade+reboot my keyboard stopped working. Any ideas?