[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird

Hello community,

Another stable branch update with some usual updates for you.

In need an Office-ready MiniPC? Check out the UM350 shipping with KDE Plasma and OnlyOffice pre-installed!

  • Most of our Kernels got updated including new firmware
  • With this update we ship a new toolchain based on GCC 12.1.0.
  • Maui 2.1.2 got released
  • OpenSearch is now at 1.3.2
  • Nvidia drivers got updated to: 510.73.05, 470.129.06 and 390.151. This adds official support up to 5.17 kernel series.
  • KDE Gear 22.04.1 and KDE frameworks 5.94 got added
  • LibreOffice is now at 7.2.7
  • Qt5 got updated to 5.15.4 incl. KDE patchsets. Report any breakage!
  • Usual Haskell and Python package updates
  • Mesa got updated to 22.0.4
  • Latest Firefox 100.0.2 and beta release
  • Thunderbird 91.9.1
  • Qemu got some fixes for virtio-scsi fixing 100% CPU consumption in IOThread added
  • Daily KDE-git updates
  • Some regular updates from upstream incl. haskell

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Annoucement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77. Else give the Review ISOs a spin, which include these packages update.

Our current supported kernels

  • linux49 4.9.315
  • linux414 4.14.280
  • linux419 4.19.244
  • linux54 5.4.195
  • linux510 5.10.117
  • linux515 5.15.41
  • linux517 5.17.9
  • linux518 5.18-rc7
  • linux515-rt 5.15.36_rt41
  • linux517-rt 5.17.1_rt17

Package Changes

A detailed list of all changes can be found here .

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

:arrow_right: 2022-05-23


Chromium / Google Chrome cannot save files to most folders (GNOME and Xfce)

This is an upstream bug with the package xdg-desktop-portal-gnome

In the meantime, you can try to remove the package xdg-desktop-portal-gnome (if feasible, without any dependency issues or conflicts), or wait for the bug to be fixed upstream.

Without any xdg-desktop-portal-* packages, Chromium and Google Chrome should correctly detect the environment and present either KDialog (KDE) or GTK file picker (GNOME, Xfce) upon saving and downloading files.

An alternative workaround, for now, is to intentionally click on the filename field, and then press Enter to save / download the file.

GNOME 42: theming and COSMIC packages changes, Bluetooth disabled by default
GNOME 42: Xorg Fractional Scaling

Please install gnome-control-center from the repo after this update and reboot.

pamac install gnome-control-center

gnome-control-center-x11-scaling is currently not available for GNOME 42, because Ubuntu is using version 41 for their current LTS and the patches have not been ported.

You can still use mutter-x11-scaling but will have to enable/disable fractional scaling via gsettings.
To enable fractional scaling after installation run:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

To disable fractional scaling run:

gsettings reset org.gnome.mutter experimental-features

See also here and here.

libkipi: Pamac fails to build the package from AUR
  • libkipi is a deprecated dependency for some KDE applications, and has been moved to AUR.
  • When using Pamac graphically, you can disable the update for libkipi, before removing it from your system.
  • When using Pamac from the terminal, you can proceed the update in multiple steps:
pamac upgrade --no-aur
pamac remove libkipi
pamac upgrade --aur
Timeshift: new rsync snapshots do not show
Wine: cannot be built locally


QEMU >= 7.0.0 changes split package setup

2022-05-09 - David Runge

With the update to qemu 7.0.0 the package has been turned into a more fine grained split package utilizing meta packages.

  • The qemu package is now virtually provided by the meta packages qemu-base, qemu-desktop and qemu-full.
  • The functionality of qemu prior to 7.0.0 is replaced by qemu-desktop
  • The functionality of qemu-headless is replaced by qemu-base
  • The functionality of qemu-arch-extra and qemu-headless-arch-extra is replaced by qemu-emulators-full
  • The meta package qemu-full provides all QEMU related packages (excluding qemu-guest-agent)


KeePassXC auto-type does not work

Upgrading KeePassXC from version 2.6.6 to 2.7.0 partially breaks the “auto-type” function. This is fixed upstream in version 2.7.1.

In in the meantime, to have it behave (and work) as it did with version 2.6.6, change the following option:

Tools → Settings → General → Auto-Type → uncheck “Always ask before performing Auto-Type”

Version 2.7.1, which did not make it into this batch of Stable Updates, works correctly, even with the above option enabled.

Desktop Icons (DING) Gnome extention and File Previews stop working due to a crash in sushi.

This has been fixed upstream in sushi version 41.2. To restore functionality you can manually upgrade.

sudo pacman -U https://archive.archlinux.org/packages/s/sushi/sushi-41.2-1-x86_64.pkg.tar.zst


Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild or remove it:
pamac build qt5-styleplugins
DSL/PPPoE may require downgrading 2 packages

First please check if new bugfix version 1.36.2-1.0 of NetworkManager improves things.

If it does not, downgrade to 1.34.0 (and restart network manager after) :

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

Bug report: FS#73948 - networkmanager 1.36.0 breaks DSL connection

Older dicussion: my-internet-connection-is-no-longer-working

mangohud (AUR) prevents Wine/Proton applications from starting
  • Consider disabling the mangohud overlay until the bug is fixed upstream.
VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst


Microsoft Teams does not open.

See this thread.


Is there any new release? cause this is a giga update !

Isn’t the date wrong? Shouldn’t it be 2022-05-23?

Nice, I just finished configuring timeshift and taking a snapshot. :wink:

Yay! Something in this update fixed the issue I had after the last update with swapping between my audio devices in plasma-pa.


After the update VirtualBox, OwnCloud and Birdtray could not be launched. An error appeared every time:

Cannot mix incompatible Qt library (5.15.3) with this library (5.15.4)

Downgrading qt5-base solved the problem.

…did NOT solve the problem. However, this will:


Good update on (so far) 2 systems. Hoped this might resolve a problem with the application launcher not being activated by screen edges on the Plasma desktop but the update did not.

Going to start another thread on this…

Installed the update. Got a bunch of 404 (maybe mirror not synced), but no errors.

After reboot i got a notification that my kernel is not supported (running 5.17).
I startet pamac again to check if there are some updates left and the system started a downgrade by itself?
Is it only me?

I have issues with libstdc++ and my graphics drivers are not loading (Failed to load kernel drivers). Thus, I had to roll back to the last timeshift snapshot.

You probably still have 5.16 installed which has been EOL for over a month and has been dropped from the repos.

That should only happen if you have Enable downgrade enabled in Add/Remove Software Advanced Preferences.

1 Like
  • nvidia-dkms och linux510-nvidia conflict, could not download.
    Now removed - nvidia-dkms and it start downloading.
    After reboot all fine.

Indeed. They both provide the same thing so there’s no reason to have both installed. Most prefer the precompiled kernel module (linuxXXX-nvidia).


I am sorry for my mistake. When I tested it worked but after a reboot other programs started showing the same problem.

You solution fixed all problems.

Thank you!

Ah thx, deinstalled the 5.16 and disabled downgrade in Preferences (was because of Firefox some weeks ago).

But how do i get the updates back?
Pamac insists that my system is up to date :worried:

What an untimely update! j/k

I was in the process of upgrading a somewhat neglected system, including EOL kernels, so having partially-synced mirrors at such a crucial point does not improve ones composure…

Then again, all’s well that ends well. No problems to report so far.

Sounds like both of you need to update your mirror list.

1 Like

I have already done it (several times), but unfortunately the only partly synced one was first in etc/pacman.d/mirrorlist.
Removed it and now it’s fine :wink:

thx for your help :hugs:

Hi, today’s update broke my KDE install

startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5KIOGui.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5Service.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5ConfigWidgets.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5ConfigCore.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5CoreAddons.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Gui.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Core.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Widgets.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5XmlGui.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5GuiAddons.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5WidgetsAddons.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Quick.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Qml.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5I18n.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5KIOCore.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Xml.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5Network.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5PrintSupport.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5IconThemes.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5KIOWidgets.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libQt5WaylandClient.so.5)
startplasma-x11: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /usr/lib/libKF5Solid.so.5)

I fixed it downgrading with:

sudo pacman -Syyuu

Does anyone know how to fix the above error?

Thank you.