[Testing Update] 2022-04-04 - Mesa 21.3.8, Blender 3.1.2, Xorg-Stack, Haskell, Python

Hello community,

here comes another testing branch update.

We are working on a low-spec Mini-PC coming soon …

  • We downgraded Mesa to 21.3.8. Please use: sudo pacman -Syuu
  • Blender is now at 3.1.2
  • Kernel got updated to 4.14.275
  • Some updates to Xorg-Stack
  • Some more updates to KDE-git, Haskell and Python

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux49 4.9.309
  • linux414 4.14.274
  • linux419 4.19.236
  • linux54 5.4.188
  • linux510 5.10.109
  • linux515 5.15.32
  • linux516 5.16.18
  • linux517 5.17.1
  • linux515-rt 5.15.32_rt39
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt16

Package Updates (Mon Apr 4 21:15:33 CEST 2022)

  • testing community x86_64: 345 new and 339 removed package(s)
  • testing core x86_64: 12 new and 13 removed package(s)
  • testing extra x86_64: 81 new and 81 removed package(s)
  • testing kde-unstable x86_64: 124 new and 124 removed package(s)
  • testing multilib x86_64: 10 new and 9 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-04-04


Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild it:
pamac build qt5-styleplugins
FIXED? VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

FIXED? DSL/PPPoE may require downgrading 2 packages

See my-internet-connection-is-no-longer-working and FS#73948 - networkmanager 1.36.0 breaks DSL connection

Please check if 1.36.2-1.0 of NetworkManager improve things, else downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst


New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic


Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

I am just curious. Why downgrade? Is there a regression? Also mesa 22.0.1 is already released.


I guess that the last release failed in the pipeline, but it has the new extra features (they probably broke):

21.3.8 passed in the pipeline:

21.3.8 looks like stable without the minor version change (No extra features).

1 Like

There are some regressions reported upstream


If even AAA gaming works fine with Mesa 22.0, than I still have to downgrade it? I’m using Mesa 22.0 in two AMD pc’s, both are fine.

Mesa 22 works well for me on Intel too. Is it necessary to downgrade it? @philm

You already answered your own questions. :wink:


I retract that statement. After waking from suspend, I am having graphical glitches, including flickering desktop wallpaper and faulty Plasma widgets. I will downgrade Mesa for now.

We published some REVIEW-ISOs. Please check: Release 202204051020 · manjaro/release-review · GitHub


I switched from Stable to this, everything seems fine so far, but sometimes after starting or restarting my PC the login screen is rendered in 4:3 in a very low resolution on both my screens.
But after login it seems to resolve itself. (Also sometimes after a shutdown an start the login screen is just normal 16:9)

Might your issue be related to mesa needing to be downgraded?

I have an issue with VA-API, vainfo gives me this:

libva error: /usr/lib/dri/iHD_drv_video.so init failed
vaInitialize failed with error code -1 (unknown libva error),exit

1 Like

@Morialo First install intel-gmmlib and then install intel-media-driver …both individually. To verify if things work, run vainfo.

Note that the mentioned approach didn’t work for me and I had to downgrade both the packages. See [SOLVED] iHD Hardware Video Acceleration Fails / Applications & Desktop Environments / Arch Linux Forums.

1 Like

Same as you re-installation didn’t help, I’ll wait and see if an update will fix, thanks a lot for the confirmation.

I have mesa 21.3.8-1 installed, also I didnt expirence any other issues like low performance in games,
its just sometimes when I start my PC that the login screen is 4:3 with a relatively low resolution, but after I login and the KDE loading screen finishes(or while it still loads not sure) it scales back to 16:9 4K as usual.

Also I think not 100% sure, Freetube broke after the update but reinstalling(or switching to the freetube-bin instead of freetube version from the AUR) fixed it. Buy maybe just killing freetube in the taskmanager would have been sufficient, not sure could also just be an AUR or freetube issue.

EDIT: running sudo pacman -Syuu didnt downgrade mesa(just nvm, node version management). So its not related to a more recent mesa version.

Can confirm: community.db for me also down with 403/4 errors (with the germany servers; worldwide servers are ok)

Update: community servers are back! :smiley:

1 Like

Same here. The file community.db ist listed in the servers file list (see manjaro.moson.eu for example) but a click on it gives a 404 error.

Hm, now it’s working again.