[Testing Update] 2022-05-04 - Kernels, Plasma 5.24.5, Systemd, Gstreamer, Pipewire, Firefox, Thunderbird

Hello community,

Another testing branch update with some usual updates for you.

FRXPSttaQAAKRH1
Don’t miss out on 10% discount on selected hardware by Star Labs. Visit their store today: Clearance – Star Labs®!

  • Systemd got updated to 250.5
  • Plasma got updated to 5.24.5
  • A few more GNOME 42.1 packages trickled in
  • Gstreamer got updated to 1.20.2
  • Pipewire got updated to 0.3.51
  • Firefox got updated to 100.0
  • Thunderbird got updated to 91.9.0
  • Usual Haskell and Python package updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Annoucement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux49 4.9.312
  • linux414 4.14.277
  • linux419 4.19.241
  • linux54 5.4.191
  • linux510 5.10.113
  • linux515 5.15.37
  • linux516 5.16.20 [EOL]
  • linux517 5.17.5
  • linux518 5.18-rc5
  • linux515-rt 5.15.36_rt41
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt17

Package Changes (Wed May 4 07:30:48 CEST 2022)

  • testing community x86_64: 441 new and 446 removed package(s)
  • testing core x86_64: 36 new and 36 removed package(s)
  • testing extra x86_64: 196 new and 293 removed package(s)
  • testing kde-unstable x86_64: 111 new and 111 removed package(s)
  • testing multilib x86_64: 20 new and 20 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

:information_source: GNOME 42 has arrived! :partying_face:

Gtk 4 theming and Libadwaita
Unfortunately, there will be no custom theming available for Libadwaita applications. However, once the Libadwaita Recoloring API is implemented, we should be able to add Maia to the color palette.

I suggest installing the adw-gtk-theme from our community repo to make all Gtk applications have a matching theme. In Tweaks, set the Legacy Applications theme to Adw or Adw-dark. I recommend setting the Shell theme to Default or another shell theme you prefer that has GNOME 42 support.

To automatically switch the system theme and legacy application theme when toggling between the Light and Dark style in Settings, install the Legacy (GTK3) Theme Scheme Auto Switcher extension (gnome-shell-extension-legacy-theme-auto-switcher).

Qt application theming
For Qt application theming, we have switched back to QGnomePlatform for GNOME 42. qt5ct and qt6ct (Qt Configuration Utilities) may be marked as orphans. If you want to use QGnomePlatform with the Adwaita Qt style, you’ll need remove or comment the QT_QPA_PLATFORMTHEME variable in /etc/environment. You’ll want both qgnomeplatform and qgnomeplatform-qt6 for Qt 5 and Qt 6 applications.

New Adwaita folder icon style
If you want the new Adwaita folder icon style with Papirus, you can use papirus-folders to set it:

For example, with Papirus-Dark:

papirus-folders -C adwaita --theme Papirus-Dark

Manjaro COSMIC status
For those using the Manjaro COSMIC packages, you will need to remove them. I’ve dropped them from the repos. Once System76 finishes their new Gtk 4 applications for Pop!_OS, I’ll see about adding them.

KNOWN ISSUES

If you’re not using GNOME

If you want to change the theme of Libadwaita applications on another Gtk desktop like Xfce or Cinnamon, you can use the following commands:

Light Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme default

Dark Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme prefer-dark

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-05-04

2022-03-12

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild it:
pamac build qt5-styleplugins
FIXED? VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

FIXED? DSL/PPPoE may require downgrading 2 packages

See my-internet-connection-is-no-longer-working and FS#73948 - networkmanager 1.36.0 breaks DSL connection

Please check if 1.36.2-1.0 of NetworkManager improve things, else downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

2022-01-03

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic

2021-12-31

Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

1 Like

i have theses errors in log

mai 04 19:45:31 gst-plugin-scan[1109]: type name '-a-png-encoder-pred' contains invalid characters
mai 04 19:45:31 gst-plugin-scan[1109]: g_type_set_qdata: assertion 'node != NULL' failed
mai 04 19:45:31 gst-plugin-scan[1109]: g_type_set_qdata: assertion 'node != NULL' failed
mai 04 19:45:31 gst-plugin-scan[1109]: type name '-a-png-encoder-pred' contains invalid characters
mai 04 19:45:31 gst-plugin-scan[1109]: g_type_set_qdata: assertion 'node != NULL' failed
mai 04 19:45:31 gst-plugin-scan[1109]: g_type_set_qdata: assertion 'node != NULL' failed
1 Like

Whenever I boot up and Firefox auto starts, it only displays other windows not itself i.e. if I open discord then switch to the Firefox window, it will display my discord window in Firefox with no functionality but after restarting Firefox it fixes itself. This results in losing stored tabs from previous sessions

If you have Plasma, change the starup to a new session.

I tried to install about 1000 fonts (OTF TTF and TTC) altogether and Dolphin crashed. But if I use fc-cache -fv to install them manually, it works. Also I install a few (<10) fonts and succeeded.

After the update several mouse buttons are no longer recognised in certain fullscreen games

So correct? GNU nano - v6.3-1
(since the last two…three updates)

/etc/nanorc.pacnew - line 291-298

## For quickly uppercasing or lowercasing the word under the cursor.
## (These effectively do a Ctrl+Right followed by a Shift+Ctrl+Left,
## and then pipe the selected text through a sed command.)
# bind Sh-M-U "eOce[1;6D|sed 's/.*/\U&/'
" main
# bind Sh-M-L "eOce[1;6D|sed 's/.*/\L&/'
" main

## For copying a marked region to the system clipboard:
# bind Sh-M-T "|xsel -ib
eu" main

after merge with nanorc, error in lines…292, 294, 298

Unfortunately, I’m not sure who the chef is here

nanorc itself? !!
maintainer Arch Linux?
or manjaro ?

Can’t find anything in the bug reports or git/gitlab

yep, nano itself GNU nano Editor - git - Commit

or not? hmm :crazy_face:

Having a browser autostart at system startup is not a good idea, and not the yopyu’re suppose to save tabs you don’t want to loose cause the browser isn’t meant to be open 24/7.

This would cause the lost of the browser tabs they’re trying to keep.

See:

https://www.techwalla.com/articles/how-to-save-multiple-tabs-on-firefox

Why don’t you save your favorite tabs into firefox itself ? That way you don’t have to keep firefox autostart at login…

Cheers, Eddy

2 Likes

Could not update. Getting this error. Not sure what to do.

Warning: installing libelf (0.187-1) breaks dependency 'libelf=0.186' required by lib32-libelf
Add lib32-libelf to remove
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing lib32-libelf breaks dependency 'lib32-libelf' required by lib32-mesa
Resolving dependencies...
Checking inter-conflicts...
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing lib32-libelf breaks dependency 'lib32-libelf' required by lib32-mesa

It appears your mirrors are not up to date leaving you in a partial upgrade state. See Pacman-mirrors - Manjaro

lib32-libelf 0.187-1 requires libelf=0.187 provided by libelf 0.187-1.

1 Like

comic plasma plugin works again :smiley::smiling_face_with_three_hearts::kissing_heart:

WARNING:

snapper 0.10.1 is broken.

$ sudo snapper --config home create-config /home
IO Error (fopen failed errno:2 (No such file or directory)).

$ sudo snapper list
The config 'root' does not exist. Likely snapper is not configured.

It can not create btrfs snapshot anymore. My guess: it does not work on encrypt disk?

Solution:
Downgrade back to old version 0.10.0 that has no issue.


Edit:
The new version 0.10.2 fixed this issue.

May want to report this upstream, as I don’t see an issue report

It seems to be missing some files of userfeedbackconsole

UserFeedbackConsole: error while loading shared libraries: libQt5Charts.so.5: cannot open shared object file: No such file or directory
$ pamac search --files libQt5Charts.so.5
/usr/lib/libQt5Charts.so.5 is owned by qt5-charts
/usr/lib/libQt5Charts.so.5.15 is owned by qt5-charts
/usr/lib/libQt5Charts.so.5.15.3 is owned by qt5-charts
/opt/cuda/nsight_compute/host/linux-desktop-glibc_2_11_3-x64/libQt5Charts.so.5 is owned by cuda-tools
/opt/cuda/nsight_systems/host-linux-x64/libQt5Charts.so.5 is owned by cuda-tools

qt5-charts might not be installed on your system but I’m not a KDE user.

1 Like

@Yochanan

The new version 0.10.2 is fixed.

1 Like

…now pushed to the testing branch.

1 Like