Cannot boot after update, previous kernels do not load


I just did an update to my system and after rebooting all I get is a black screen which I cannot get past. I have tried hitting ALT+F2, CTRL+ALT+F2 but nothing seems to be happening.

If I try to boot with a previous kernel from advanced options in GRUB, it says [FAILED] Failed to start Load Kernel Modules, and then it goes onto a blinking cursor where I cannot type anything.

I do have an NVIDIA card, so I don’t know maybe that has something to do with it, sounds similar to what is reported here:, but their error message was slightly different.

I don’t exactly know what I’m supposed to be doing here, so I would really appreciate all the help I can get to resolve this.


1 Like

Hi @Whale :wink:

Which kernel? Which is the current one?

What message exactly?

Me neither without information, but if I look into my glass globe, i believe i can see that the nvidia driver or the kernel is the problem. Believe I see that the extra-modules are not installed.

5.9.8-2 is the current one which it update to, this just gives me a black screen. The other options I have in GRUB are 5.8.18-1, and 5.7.19-2, both of which give me the failed to load kernel modules error.

Their message was failed to start light display manager

How would I go about installing these at this point?

Normally you can install it with:

sudo mhwd -i pci video-nvidia-455xx

That should add the extra modules for nvidia. If it is installed, then remove it and reinstall it:

sudo mhwd -r pci video-nvidia-455xx
sudo mhwd -i pci video-nvidia-455xx

Do this by booting a manjaro live disk and manjaro-chroot -a in a terminal if no tty is available.


Cool, thank you. I will try this soon and let you know how I get on or if I get stuck.

Hi, I have the EXACT same problem.

I got into bash by Ctrl-Alt-F2, logged into my account and did the following:

$sudo mhwd -i pci video-nvidia-455xx
Error: config ‘video-nvidia-455xx’ conflicts with config(s): video-nvidia-440xx

What should I do? :slight_smile:

Yea I’m getting the conflict error too, tried removing 440xx but then I get removing linux58-nvidia-440xx breaks dependency 'linux58-nvidia-440xx' required by linux-latest-nvidia-440xx

Then remove the meta package:

sudo pacman -R linux-latest-nvidia-440xx

and try again :wink:


Maybe we should do it to to our orevious kernel 57 instead?

I’ve upgraded from 5.7.19-2 to 5.9.8-2?

And you tried with linux 58, haven’t you upgraded actually to 59?

Yep just done that actually and then went ahead and removed 440xx. Ran the command to install 455xx and it is currently downloading. I’m really hoping it all goes well and doesn’t break anything else in the process!

@vljzlj Yes I have upgraded to 5.9

Mine’s downloading too. Hope this helps

Successfully installed video-nvidia-455xx


What now?

Successfully installed and booted :grinning:
Thank you @megavolt

I guess you would reboot and see if it boots up correctly

It worked for me too!

Thanks a lot man!

It would be good to try to understand what went wrong here to potentially avoid running into the same issue in the future. Every other update I’ve ever done has always gone smooth without any issues from what I could tell, so not sure what went wrong here.

@Whale @vljzlj

The problem was:

  1. You have installed Kernel 5.9 which does not support nvidia 440xx, therefore it can not boot.
  2. Older Kernel like 5.8 and 5.7 support 440xx.
  3. Now by using the new kernel 5.9 it does not work because no module is there. You have to upgrade the nvidia driver.
  4. Older Installaltions or if you didn’t use mhwd for installing, there is also installed linux-latest-nvidia-440xx which is a meta-package and blocks mhwd due the dependencies. This one have to be removed.

Have look here:

pacman -Sg linux59-extramodules | grep nvidia
linux59-extramodules linux59-nvidia-390xx
linux59-extramodules linux59-nvidia-450xx
linux59-extramodules linux59-nvidia-455xx
pacman -Sg linux57-extramodules | grep nvidia
linux57-extramodules linux57-nvidia-340xx
linux57-extramodules linux57-nvidia-390xx
linux57-extramodules linux57-nvidia-418xx
linux57-extramodules linux57-nvidia-430xx
linux57-extramodules linux57-nvidia-435xx
linux57-extramodules linux57-nvidia-440xx
linux57-extramodules linux57-nvidia-450xx
linux57-extramodules linux57-nvidia-455xx

$ pacman -Sg linux58-extramodules | grep nvidia
linux58-extramodules linux58-nvidia-390xx
linux58-extramodules linux58-nvidia-418xx
linux58-extramodules linux58-nvidia-430xx
linux58-extramodules linux58-nvidia-435xx
linux58-extramodules linux58-nvidia-440xx
linux58-extramodules linux58-nvidia-450xx
linux58-extramodules linux58-nvidia-455xx

I had this same issue, but after uninstalling the 440xx drivers, I am unable to install the 455xx drivers. When I run sudo mhwd -i pci video-nvidia-455xx, my machine returns a slew of error: failed retrieving file 'multilib.db' errors, follwed by error: failed to synchronize all databases. I receive a similar error when attempting to run sudo pacman -Syyu, which was my first response to the failure to boot.

I am having exactly the same issue. Could someone please help resolving it ? or @asorel were you able to figure out something ?

Thanks in advance!