NVIDIA drivers, boot to black screen

After the latest update, like many others, my system no longer boots. I’ve read that this is due to nvidia drivers. After GRUB menu, screen stays black. I have followed all steps here [Fix] System doesn’t boot, boots to a black screen, or stops at a message but still fail to boot. Below are errors from startx:

(EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the system’s kernel log for additional error messages and consult the NVIDIA README for details.
(EE) No devices detected
(EE) no screens found
(EE) Server terminated with error (1). Closing log file.

I also tried nkpro’s comment in the same thread.
Step 1 sudo mhwd -r pci video-nvidia returns “Error: config 'video-nvidia' is not installed!”.
In steps 3 and 4 my mkinitcpio.conf file already has MODULES="".
Steps 6 completed successfully though I am using linux54.
Step 7 returns Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:10de:06eb) Display controller nVidia Corporation G98M [Quadro NVS 160M].

inxi -G
Graphics: Device-1: NVIDIA G98M [Quadro NVS 160M] driver: N/A
Display: server: X.org 1.20.10 Driver: loaded: N/A note: n/a (using device driver) failed: nvidia tty:180x56
Message: Advanced graphics data unavailable in console for root.

I am not sure what to try next. I have read through several other threads but haven’t been able to resolve. Thank you for your help.

1 Like

Following this post Cannot boot after update, previous kernels do not load, I ran

pacman -Sg linux54-extramodules | grep nvidia
linux54-extramodules linux54-nvidia
linux54-extramodules linux54-nvidia-390xx
linux54-extramodules linux54-nvidiabl

Then following the “solution” there, I ran

sudo mhwd -r pci video-nvidia-390xx
Error: config ‘video-nvida-390xx’ is not installed!
sudo mhwd -i pci video-nvidia-390xx
Warning: no matching device for config ‘video-nvidia-390xx’ found!
>installing video-nvidia-390xx…
(continued with install until following errors)
unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-390xx-utils and nvidia-340xxutils are in conflict
Error: pacman failed!
Error: script failed!

I then tried to remove 340xx reference but also got similar does not exist messages

sudo mhwd -r pci video-nvida-340xx
Error: config ‘video-nvidia-340xx’ is not installed!
sudo mhwd -i pci video-nvidia-340xx
Error: config ‘video-nvidia-340xx’ does not exist!

Thank you in advance of any advice to get this resolved.


have you tried

sudo mhwd -a pci free 0300

To autoinstall the free driver for your nVidia-card?

Hello @kisun. Thank you for your comment! I have tried that command. When ran, it returns:

> Skipping already installed config ‘video-linux’ for device: 0000:01:00.0 (0300:10de:06eb) Display controller nVidia Corporation G98M [Quadro NVS 160M]

I get the same message when trying nonfree as well.

Ok, can you look if there is a file ‘/etc/modprobe.d/mhwd-gpu.conf’ ?

If so, take a look inside with

less /etc/modprobe.d/mhwd-gpu.conf

Can you post the output pls. (Only lines without ## )

If the file looks like this

Contents of /etc/modprobe.d/mhwd-gpu.conf
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

Then do what @Wollie said in this post.

/etc/modprobe.d/mhwd-gpu.conf file contents below:

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

I followed the post and removed blacklist nouveau and blacklist ttm, then ran sudo depmod -a. This command finished with no output. I rebooted, but unfortunately still continue to have the black screen.

I don’t understand why driver is “N/A” even though the drivers are installed. I am assuming that is the root cause of the black screen?

inxi -G
Graphics: Device-1: NVIDIA G98M [Quadro NVS 160M] driver: N/A

@kisun I really appreciate you’re previous responses. I’ve been scouring through this forum for a week trying to resolve with no luck. I am really hoping that I don’t need to do a new install and I’m not even sure that would fix it.

So then try

sudo mhwd -a pci free 0300


On boot I now get

[FAILED] Failed to start Light Display Manager.

I was able to get to TTY2 and got the same message as before when running sudo mhwd -a pci free 0300:

> Skipping already installed config ‘video-linux’ for device: 0000:01:00.0 (0300:10de:06eb) Display controller nVidia Corporation G98M [Quadro NVS 160M]

What says

ls -la /etc/X11/xorg.conf.d/
total 16
drwxr-xr-x 2 root root 4096 Jan  3 2019 .
drwxr-xr-x 5 root root 4096 Nov 28 2018 .
-rw-r--r-- 1 root root  266 Jan  1 2019 00-keyoard.conf
lrwxrwxrwx 1 root root   27 Jan  3 2019 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf
1 Like

There has been several topics during many months now - due to upstream changes - kernel wise and others - only a subset of the previous Nvidia drivers is maintained.

The maintained drivers is the latest drivers - currently 460xx and the older 390xx.

Essentially this means if your card is not supported by either of these packages you need to use one the opensource drivers. (xf86-video-nouveau - fbdev or vesa).

This may not be optimal - but it is how it is.

To come around to a working system you need to uninstall all nvidia packages. Doing so will - or should - remove the listings created by installing those packages which prevents loading the opensource drivers.

Start by listing installed nvidia packages

pacman -Qq | grep -e 'nvidia'

This will give you an idea of what packages to uninstall. You can use the above command - pipe the result to a text file

$ pacman -Qq | grep -e 'nvidia' > nvidia.txt

Edit the text file and remove reference to mhwd packages. Save the file and the pipe file into pacman

 $ sudo pacman -R - < nvidia.txt

After running this command check if the following files still exist - if they do remove then

  • /etc/modprobe.d/mhwd-gpu.conf
  • /etc/modules-load.d/mhwd-gpu.conf
  • /etc/X11/xorg.conf.d/90-mhwd.conf

reboot your system


Free driver (video-linux) is installed, but the system tries to load ‘video-nvidia’

1 Like
pacman -Qq | grep -e 'nvidia'

I successfully removed ‘lib32-nvidia-340xx-utils’, ‘linux419-nvidia-340xx’, and ‘nvidia-340xx-utils’.

I deleted the three files in the /etc/ directory and rebooted. On shutdown for the reboot, it froze with the message

[3675.239517] watchdog: watchdog0: watchdog did not stop!

I had to hold the power button to force the shutdown. But this watchdog issue seems like it is an error for another day. On power up, the screen now works!

@linux-aarhus thanks for the above solution! I appreciate you and @kisun’s help! Moving forward with Manjaro updates, do you suspect that this driver issue will happen with each update? Or should updates honor the opensource drivers and not attempt to install/use nvidia drivers? Basically I am wondering if this machine has seen the end of the road for itself as far as updates for it.

The system will not attempt to install any driver on its own - not even on updates.

The watchdog message - I think I saw disabling the watchdog as part of another script - maxperfwiz by members of the forum @cscs - and it can safely be disabled.

The opensource drivers should work reasonably with the hardware and if you are not having gaming requirements then I don’t think you will see much difference.

Thank you for the information @linux-aarhus. I am glad to hear that I can continue to update the system without ongoing driver problems. No gaming requirements for me, so I am happy with the opensource drivers.

Thanks for the tip on the watchdog error. I will look into how to disable it. Thanks again everyone!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.