Black screen after latest update (Couldn't exec startkde: no such file or directory)


I’m getting black screen after the latest update. On all kernels.
4.19 - 5.9

Using nouveau driver

startx (not working - Couldn’t exec startkde: no such file or directory)
startplasma-x11 (not working - $DISPLAY is not set or cannot connect to the X server)

Any help with this is appreciated


Hello @autotech :wink:

Maybe same issue here?


Are you saying that perhaps I need to install the nvidia driver?

It was working quite well with nouveau until this update.


@autotech idk, but would be worth to check your .xinitrc:

cat ~/.xinitrc

Could you post it here?


I looked over the .xinitrc, but I’m not sure about what I should be looking for.
Here’s a crude pic of .xtinitrc:

Thanks in advance.


I guess you need to change:




and replace startkde in the function get_session with startplasma-x11

I tried that, but I still get the same result. I’m starting to think that one of the updates didn’t install properly. To know which update is the culprit seems difficult.
I tried re-installing “plasma-desktop and sddm” but still nothing.


Well maybe an outdated mirror?

sudo pacman-mirrors -c Germany && sudo pacman -Syyu

Maybe choose your own country instead of Germany.

I also tried the mirrors prior to posting. I’m running out of tricks here. I’m sure others experienced this as well. But it seems like everyone has a different solution. It seems common that “startkde” doesn’t work after updates. In my case, there is still a lot of work to get to the bottom of this. I appreciate your help.


in the manjaro discord server i just helped someone solve this

mv ~/.xinitrc ~/.xinitrc.bak
$EDITOR ~/.zinitrc


export DESKTOP_SESSION=plasma
exec startplasma-x11

exit and run
it should work

after that we switched the display manager to lightdm

sudo systemctl disable sddm
sudo pacman -S lightdm lightdm-gtk-greeter
sudo systemctl enable lightdm


I tried editing the .xinitrc file, but still nothing.
It looks like my screens are not being detected.
I even installed the latest nvidia driver (MHWD) but still the same outcome.
Seems like there are still a few more tricks left to try. I know this can be resolved, it’s just a matter of knowing. I appreciate everyone who is helping so far. If there are indeed a few more things to try, hopefully we can solve this issue.


I think I might have to re-install a few things. The update must have borked something pretty bad.
I removed “quiet” from boot and got a core dump somewhere in the process.

I installed the latest Nvidia driver to check and see if that worked, but it made no difference.
I’m keeping the driver just for performance if I do get this thing going. The problem might need a massive re-install.
Meanwhile, does anyone know the proper commands to re-install everything from TTY without destroying user data or settings?
You help is appreciated.


Something like this should reinstall most of KDE

DONATOR=; DONATION=$(wget -qO- $DONATOR | awk '/##/{f=0} f; /Plasma5/{f=1}' | sed '/^>/ d' | awk '{ print $1 }'); sudo pacman -Syu $DONATION --needed

But its set to only reinstall missing things … it would need some tweaks if you want to force reinstall everything.

After installing the Nvidia driver, it no longer outputs “couldn’t exec startkde”.
Now it only claims: (EE) no screens found(EE)

I wonder what has changed. Re-installing most of KDE might help, but I think this problem might have a simpler solution if we know what’s going on. Any other way of checking logs?

I already checked the Xorg.0.log, but it doesn’t look like anything new.


I wouldn’t necessarily call this one solved, but I “chroot” using the latest USB image and backed up my home folder. Formatted and re-installed from scratch. Wasn’t all that bad, but I didn’t get a chance to export my Vivaldi passwords and Kwallet. Next time I’m going to export the wallet monthly.

In the end, my video card might be the problem, as I cannot install any version of the Nvidia driver without getting a black screen. Fixed by uninstalling the driver and sticking with Nouveau.

For future users who run into this same issue. Perhaps try everything that was suggested before re-installing. Your mileage will certainly vary and something on these posts might work for you.

Breaking and fixing is part of the adventure. Onto breaking the next update!
Thanks to all who tried to help. Much appreciated.