Black screen when playing Garry's Mod

After 10 minutes of normal game play system hangs, Black screen, last sound repeating in a loop

  Kernel: 5.15.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c4444d52-5d6c-4291-baef-69a9b2663d72 rw quiet apparmor=1
    security=apparmor resume=UUID=234570bc-a9a2-4436-9468-14e557ecc336
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: 970A-DS3P serial: <superuser required>
    UEFI: American Megatrends v: F1 date: 04/08/2013
  Message: No system battery data found. Is one present?
  RAM: total: 7.73 GiB used: 2.23 GiB (28.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD FX-6300 bits: 64 type: MT MCP arch: Piledriver
    family: 0x15 (21) model-id: 2 stepping: 0 microcode: 0x6000852
  Topology: cpus: 1x cores: 6 smt: enabled cache: L1: 288 KiB
    desc: d-6x16 KiB; i-3x64 KiB L2: 6 MiB desc: 3x2 MiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1505 high: 1986 min/max: 1400/3500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1422 2: 1986
    3: 1406 4: 1406 5: 1406 6: 1406 bogomips: 42212
  Flags: 3dnowprefetch abm aes aperfmperf apic arat avx bmi1 clflush cmov
    cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de decodeassists
    extapic extd_apicid f16c flushbyasid fma fma4 fpu fxsr fxsr_opt ht
    hw_pstate ibpb ibs lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor
    msr mtrr nodeid_msr nonstop_tsc nopl npt nrip_save nx osvw pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni
    popcnt pse pse36 rdtscp rep_good sep skinit ssbd sse sse2 sse4_1 sse4_2
    sse4a ssse3 svm svm_lock syscall tbm tce topoext tsc tsc_scale vmcb_clean
    vme vmmcall wdt xop xsave
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Cayman PRO [Radeon HD 6950] vendor: PC Partner Limited
    driver: radeon v: kernel bus-ID: 01:00.0 chip-ID: 1002:6719 class-ID: 0300
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Cayman/Antilles HDMI Audio [Radeon HD 6930/6950/6970/6990]
    vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aa80 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.19-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 763.85 GiB used: 179.39 GiB (23.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD3200AAKS-00L9A0 size: 298.09 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3E01
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500LM012 HN-M500MBB
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: <unknown> type: HDD rpm: 5400 serial: <filter> rev: 0002
    scheme: GPT
  Optical-1: /dev/sr0 vendor: ASUS model: SDRW-08D2S-U rev: A801
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 456.66 GiB size: 448.43 GiB (98.20%)
    used: 179.39 GiB (40.0%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: c4444d52-5d6c-4291-baef-69a9b2663d72
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: NO_LABEL
    uuid: A324-3A23
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb3 maj-min: 8:19 label: swap
    uuid: 234570bc-a9a2-4436-9468-14e557ecc336
  ID-1: /dev/sda1 maj-min: 8:1 size: 450 MiB fs: ntfs
    label: \xd0\x92\xd0\xbe\xd1\x81\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xb8\xd1\x82\xd1\x8c
    uuid: A06E2F366E2F051E
  ID-2: /dev/sda2 maj-min: 8:2 size: 100 MiB fs: vfat label: N/A
    uuid: 7E31-23E8
  ID-3: /dev/sda3 maj-min: 8:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/sda4 maj-min: 8:4 size: 296.97 GiB fs: ntfs label: N/A
    uuid: 823033FB3033F4AF
  ID-5: /dev/sda5 maj-min: 8:5 size: 576 MiB fs: ntfs label: N/A
    uuid: BAB48455B48415D3
  Hub-1: 1-0:1 info: Full speed or root hub ports: 5 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: MediaTek Slim Portable DVD Writer type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0e8d:1887 class-ID: 0802 serial: <filter>
  Hub-2: 2-0:1 info: Full speed or root hub ports: 5 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed or root hub ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Full speed or root hub ports: 5 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Hub-5: 5-0:1 info: Full speed or root hub ports: 5 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Hub-6: 6-0:1 info: Full speed or root hub ports: 2 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Hub-7: 7-0:1 info: Full speed or root hub ports: 4 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Device-1: 7-3:2 info: Elan Micro Gaming KB type: Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 04f3:152e class-ID: 0301
  Device-2: 7-4:3 info: [Maxxter] Optical gaming mouse type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 18f8:0f99 class-ID: 0301
  Hub-8: 8-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-9: 8-1:2 info: VIA Labs Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 2109:3431 class-ID: 0900
  Hub-10: 9-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 37.8 C mobo: N/A gpu: radeon temp: 57.0 C
  Fan Speeds (RPM): N/A
  Processes: 226 Uptime: 12m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1280 pacman: 1273 lib: 353
  flatpak: 0 snap: 7 Shell: Zsh v: 5.8 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.12

Hi @Piskojuy, and welcome!

As frustrating as that I imagine that is for you, I’m going to have to tell you we need more information for there to be a chance to figure out what’s going on. To that end, see [HowTo] Provide System Information, [HowTo] post screenshots and links and [HowTo] Increase your chances of solving your issue.

Hope you manage!

Ok, done

Does this happen only in the game, or other times as well?

only in-game

Hmmm. Well, to be 100% honest, I don’t see anything wrong quickly. But, I’m first to admit I’m not an expert and might be missing something, just because I don’t see it doesn’t mean it’s not there. We’ll have to wait and see if someone can tell us what’s going on with it.

P.S.: Have you tried a different Kernel version? Like 5.4 or 5.10, the previous two LTS versions.

haven`t tried other kernel versions, but i will try to install another kernel version

Do so, and see if that helps.

it worked for 20 minutes and than black screen

OK, ONLY other thing I can possibly think of, id trying another network driver, if the one you’re using wasn’t installed from the AUR?


Doesn’t look that way:

So let’s blacklist that one first:

sudo sh -c 'echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf'

Followed by installing the one from the AUR:

pamac build r8168-dkms

And rebooting. If that doesn’t work, follow @maycne.sonahoz’ advice about the journal.

The system journal might give some clue.

What is AUR and how is my network driver is linked to crashing?

Launch game from terminal and share output after it crashes.

AUR is the Arch User Repositor, and I’ve come across many problems caused by that specific driver, this might be one, might not.

This driver is available in Manjaro directly, in Manjaro Settings Manager → Hardware. No need to install it from external source. It does the blacklisting and all automatically, click install, done.

I am skeptical about changing the network driver for the game problem but that may not hurt. You can always uninstall it from Manjaro Settings Manager.

//EDIT: however I see it is using the radeon video driver, maybe amdgpu would be better. I think simply installing amdgpu-experimental package would be the simplest way to try, it will add everything to force its use.

sudo pacman -S amdgpu-experimental

Same. It isn’t guaranteed to help, but it shouldn’t do any harm either.

second command didn`t work for me, it sayed "Failed to query[]=thea-the-awakening-bin from AUR: Socket I/O timed out
Failed to query[]=python-migen-git from AUR: Socket I/O timed out
Failed to query[]=stereokit-git from AUR: Socket I/O timed out
Failed to query[]=xcaddy-bin from AUR: Socket I/O timed out
Failed to query[]=earthly-bin from AUR: Socket I/O timed out
Failed to query[]=jitsi-meet-nightly from AUR: Socket I/O timed out
Error :object not found : r8168-dkmspamac
Error :object not found : build

Also I have blacklisted my network driver by first command and I don’t know how to unblacklist it, help pls
Edit : blacklisting my network driver didn’t help, it still crashes
Edit 2 : I don’t know, why, but now the last Sound before crash is playing in a loop (like 1 second)

Monitor your system resources, and your CPU/GPU temperature, you might simply crash because your hardware is boiling hot. Also if you have any kind of overclock enabled, disable it as it may be also a common reason for crashes.

Hardware is in it’s normal temperatures, never even touched overclocking