[Stable Update] 2023-12-23 - Kernels, Grub, Mate, Deepin, Cinnamon, ICU, KDE Frameworks

Hello community,

We wish you all happy holidays and a happy new year. Our team will now slow down with our activities around Manjaro and will concentrate more on family and friends. Hope you do the same. 2024 will be awesome. There are so many things we will bring to the project and our community. So enjoy the last days of 2023 and have fun!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Most Kernels got updated
  • Grub got its stable release 2.12
  • Mate, Deepin and Cinnamon received updates
  • icu got renewed
    • this needed some rebuilds. Tell us if we missed some
  • KDE Frameworks is now at 5.113.0
  • Thunderbird is now at 115.6.0 and Firefox got updated to 121.0, which brings Wayland by default
  • Some core-dump issue was fixed in Bluez
  • Gamemode is at 1.8.1
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.303
  • linux54 5.4.265
  • linux510 5.10.205
  • linux515 5.15.144
  • linux61 6.1.69
  • linux65 6.5.13 [EOL]
  • linux66 6.6.8
  • linux67 6.7-rc6
  • linux61-rt 6.1.66_rt19
  • linux65-rt 6.5.2_rt8
  • linux66-rt 6.6.0_rt15

Package Changes (Fri Dec 22 00:59:43 CET 2023)

  • stable core x86_64: 36 new and 36 removed package(s)
  • stable extra x86_64: 1235 new and 1282 removed package(s)
  • stable kde-unstable x86_64: 272 new and 272 removed package(s)
  • stable multilib x86_64: 18 new and 18 removed package(s)

A list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-12-23

grub update

grub 2.12 may need manual post install by the user

With GRUB 2.12 out it is recommended to also install grub to your master boot record or EFI partition. On Manjaro grub gets only installed when you install it to your harddrive the first time. Only advanced users also keep their MBR/EFI in-sync as every package update of grub doesn’t update the installation on your MBR/EFI.

Depending on your system hardware and setup this may could cause an unbootable system on rare cases due to incompatibilities between the installed bootloader and configurations. After a grub package update it is advised to run both, installation and regeneration of configuration:

grub-install [plus the needed options depending of been EFI or BIOS]
grub-mkconfig -o /boot/grub/grub.cfg

For more specific information on grub-install, please refer to this guideline: [root tip] [How To] Primer on handling a grub package update

Additional information to that topic can be found here:


Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm


  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66


Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab


mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.


glibc-locales update requires manual intervention

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*


Changes to default password hashing algorithm and umask settings

2023-09-22 - David Runge

With shadow >= 4.14.0, Arch Linux’s default password hashing algorithm changed from SHA512 to yescrypt [1].

Furthermore, the umask [2] settings are now configured in /etc/login.defs instead of /etc/profile.

This should not require any manual intervention.

Reasons for Yescrypt

The password-based key derivation function (KDF) and password hashing scheme yescrypt has been chosen due to its adoption (readily available in libxcrypt, which is used by pam [3]) and its stronger resilience towards password cracking attempts over SHA512.

Although the winner of the Password Hashing Competition [4] has been argon2, this even more resilient algorithm is not yet available in libxcrypt [5][6].

Configuring yescrypt

The YESCRYPT_COST_FACTOR setting in /etc/login.defs is currently without effect, until pam implements reading its value [7]. If a YESCRYPT_COST_FACTOR higher (or lower) than the default (5) is needed, it can be set using the rounds option of the pam_unix [8] module (i.e. in /etc/pam.d/system-auth).

General list of changes

  • yescrypt is used as default password hashing algorithm, instead of SHA512
  • pam honors the chosen ENCRYPT_METHOD in /etc/login.defs and does not override the chosen method anymore
  • changes in the filesystem (>= 2023.09.18) and pambase (>= 20230918) packages ensure, that umask is set centrally in /etc/login.defs instead of /etc/profile

[1] yescrypt - scalable KDF and password hashing scheme

[2] umask(1p) — Arch manual pages

[3] PAM - ArchWiki

[4] https://www.password-hashing.net/

[5] https://github.com/besser82/libxcrypt/pull/113

[6] Add support for Argon2 by maandree · Pull Request #150 · besser82/libxcrypt · GitHub

[7] pam_unix: Support reading YESCRYPT_COST_FACTOR from /etc/login.defs · Issue #607 · linux-pam/linux-pam · GitHub

[8] pam_unix(8) — Arch manual pages

Arch Linux - News: Changes to default password hashing algorithm and umask settings


filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.

updates for linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module

R8168 driver not loaded on kernel 6.5 after testing update 2023-09-22

All 3 versions of network-r8168 drivers are working again following [Testing Update] 2023-09-27

  • linux65-r8168 8.051.02-7
  • linux61-r8168 8.051.02-5
  • linux515-r8168 8.051.02-4


LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match system theme

pamac-gtk 11.0.1 uses Gtk 4 that is not supported on Xfce or Cinnamon
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.

Previous stable update threads:


Hooray! I can finally remove export MOZ_ENABLE_WAYLAND=1 from my ~/.bashrc file!

Firefox 121.0, See All New Features, Updates and Fixes

On Linux, Firefox now defaults to the Wayland compositor when available instead of XWayland. This brings support for touchpad & touchscreen gestures, swipe-to-nav, per-monitor DPI settings, better graphics performance, and more.

Edit: I also removed export MOZ_DBUS_REMOTE=1, which had been required to open links from external applications in Firefox on Wayland, from the ~.bashrc file. Logged out & back in - links opened okay from a couple of apps, so I will assume that line in the file is no longer required.


A post was split to a new topic: Systems hangs after update on Plymouth boot screen

hello @Joshua-17

please open a thread for this issue. i suspect the following problem:
the broken update is using the new grub-version while your chroot-image is using the previous one. that’s my suggestion why chrooting troubles.

Good point. :thinking:

Will create a thread and also a usb stick with an updated iso image and retry the chroot process

5 posts were split to a new topic: Mpv: error while loading shared libraries: libvmaf.so.3

Cinnamon edition took error.

(2/4) Compiling GSettings XML schema files...
オーバーライドファイル“/usr/share/glib-2.0/schemas/99_manjaro-cinnamon.gschema.override”で指定されたスキーマ“org.nemo.preferences”のキー“bulk-rename-tool”の解析中にエラーが発生しました: 0-10:can not parse as value of type 'ay': このキーのオーバーライドを無視します。

2 posts were split to a new topic: Problem with quiterss: libicui18n.so.73 not found

I already moved your post to Support - Manjaro Linux Forum. Updated 23.1.1 ISOs are expected later today, as we are currently testing those.

1 Like

What about system that’s not EFI?

Then you will know how you installed the system - and subsequently know which command to use.

As non efi systems is unpredicable it is not possible to provide explicit guidance as you need to know which device you installed grub onto in the first place - and if you used BIOS/GPT - in which case it is not a device but a partition

Another great update. “It’s a Festivus miracle!”

1 Like

Just for clarification, when the wiki about reinstalling grub says “You need to be in chroot for this procedure”, I’m assuming this is just needed if rescuing a system rather than when booted into it as normal?

That is correct.



1 Like

Hello everyone,
after the update Grub still shows the version 2.06-4 (on reboot), although it should be 2.12. Is this correct?
Best regards

Check if your primary mirror is up-to-date.

pacman-mirrors --status

On unstable branch the grub version is

 $ pamac info grub
Name                  : grub
Version               : 2.12-3
Description           : GNU GRand Unified Bootloader (2)
URL                   : https://www.gnu.org/software/grub/
Licenses              : GPL-3.0-or-later
Repository            : core
Installed Size        : 50,2 MB
Groups                : --
Depends On            : sh xz gettext device-mapper
Optional Dependencies : freetype2: For grub-mkfont usage [Installed]
                        fuse3: For grub-mount usage [Installed]
                        dosfstools: For grub-mkrescue FAT FS and EFI support [Installed]
                        lzop: For grub-mkrescue LZO support
                        efibootmgr: For grub-install EFI support [Installed]
                        libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue [Installed]
                        os-prober: To detect other OSes when generating grub.cfg in BIOS systems [Installed]
                        mtools: For grub-mkrescue FAT FS support
                        update-grub: Script to update Grub Menu on Linux Kernel updates [Installed]
                        libusb: For grub-emu USB support [Installed]
                        sdl: For grub-emu SDL support [Installed]
Required By           : grub-btrfs grub-theme-manjaro
                        manjaro-tools-iso-git update-grub
Optional For          : --
Provides              : grub-common grub-bios grub-emu grub-efi-x86_64
Replaces              : grub-common grub-bios grub-emu grub-efi-x86_64
Conflicts With        : grub-common grub-bios grub-emu grub-efi-x86_64
Packager              : Mark Wagie <mark@manjaro.org>
Build Date            : fre 22 dec 2023 15:12:41 CET
Install Date          : lør 23 dec 2023 07:30:33 CET
Install Reason        : Explicitly installed
Validated By          : Signature
Backup files          : /etc/default/grub /etc/grub.d/40_custom

Hello linux-aarhus,
the version 2.12 is installed:

[snydar@snydar-manjaro ~]$ pacman-mirrors --status
Local mirror status for stable branch
Mirror #1   OK  00:11   Germany  https://ftp.gwdg.de/pub/linux/manjaro/
Mirror #2   OK  00:11   Germany  https://mirror.alpix.eu/manjaro/
[snydar@snydar-manjaro ~]$ pamac info grub
Name                          : grub
Version                       : 2.12-3
Beschreibung                  : GNU GRand Unified Bootloader (2)
URL                           : https://www.gnu.org/software/grub/
Lizenzen                      : GPL-3.0-or-later
Paketquelle                   : core
Installierte Größe            : 50,2 MB
Gruppen                       : --
Hängt ab von                  : sh xz gettext device-mapper
Optionale Abhängigkeiten      : freetype2: For grub-mkfont usage [Installiert]
                                fuse3: For grub-mount usage [Installiert]
                                dosfstools: For grub-mkrescue FAT FS and EFI support [Installiert]
                                lzop: For grub-mkrescue LZO support
                                efibootmgr: For grub-install EFI support [Installiert]
                                libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
                                os-prober: To detect other OSes when generating grub.cfg in BIOS systems [Installiert]
                                mtools: For grub-mkrescue FAT FS support [Installiert]
                                update-grub: Script to update Grub Menu on Linux Kernel updates [Installiert]
                                libusb: For grub-emu USB support [Installiert]
                                sdl: For grub-emu SDL support [Installiert]
Benötigt von                  : update-grub
Optional für                  : --
Stellt bereit                 : grub-common grub-bios grub-emu grub-efi-x86_64
Ersetzt                       : grub-common grub-bios grub-emu grub-efi-x86_64
Konflikt mit                  : grub-common grub-bios grub-emu grub-efi-x86_64
Packer                        : Mark Wagie <mark@manjaro.org>
Erstelldatum                  : Fr 22 Dez 2023 15:12:41 CET
Installiert am                : Sa 23 Dez 2023 11:25:03 CET
Installationsgrund            : Ausdrücklich installiert
Validiert von                 : Signature
Dateisicherungen              : /etc/default/grub /etc/grub.d/40_custom

But it still shows version 2.06-4 on reboot.

Sorry if I bother someone here with my question, but I need to have a confirmation on this before to make this upgrade. Regarding grub, those magic lines after upgrade and before reboot are this?

Thank you in advance.

sudo grub-install --efi-directory=/boot --no-nvram
sudo grub-mkconfig -o /boot/grub/grub.cfg

Or this one are more complete?

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo grub-mkconfig -o /boot/grub/grub.cfg

I have put sudo before because I don’t understand how to go in chroot after upgrade and before reboot and don’t use a live USB. Or I must do in console su and after that those command without sudo. Can someone tell me what is the correct procedure ?