[Stable Update] 2023-10-13 - Pipewire, Mattermost, Qt5, Haskell, Python

Hello community,

Another stable branch update with some usual package updates for you.

Get the lastest SoftMaker Office with ChatGPT buillt-in. You will find our Special Offer here!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • PipeWire is now at 1.0-rc1
  • Mattermost got renewed to 9.0.1
  • Qt5 is now updated to 5.15.11
  • Usual Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Our current supported kernels

  • linux419 4.19.295
  • linux54 5.4.257
  • linux510 5.10.197
  • linux515 5.15.133
  • linux61 6.1.55
  • linux65 6.5.5
  • linux66 6.6.0rc4
  • linux61-rt 6.1.54_rt15
  • linux64-rt 6.4.6_rt8
  • linux65-rt 6.5.2_rt8

Package Changes (Tue Oct 10 03:53:50 CEST 2023)

  • stable core x86_64: 7 new and 7 removed package(s)
  • stable extra x86_64: 1591 new and 1585 removed package(s)
  • stable multilib x86_64: 7 new and 7 removed package(s)

All changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-10-13


glibc-locales update requires manual intervention

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*


Changes to default password hashing algorithm and umask settings

2023-09-22 - David Runge

With shadow >= 4.14.0, Arch Linux’s default password hashing algorithm changed from SHA512 to yescrypt [1].

Furthermore, the umask [2] settings are now configured in /etc/login.defs instead of /etc/profile.

This should not require any manual intervention.

Reasons for Yescrypt

The password-based key derivation function (KDF) and password hashing scheme yescrypt has been chosen due to its adoption (readily available in libxcrypt, which is used by pam [3]) and its stronger resilience towards password cracking attempts over SHA512.

Although the winner of the Password Hashing Competition [4] has been argon2, this even more resilient algorithm is not yet available in libxcrypt [5][6].

Configuring yescrypt

The YESCRYPT_COST_FACTOR setting in /etc/login.defs is currently without effect, until pam implements reading its value [7]. If a YESCRYPT_COST_FACTOR higher (or lower) than the default (5) is needed, it can be set using the rounds option of the pam_unix [8] module (i.e. in /etc/pam.d/system-auth).

General list of changes

  • yescrypt is used as default password hashing algorithm, instead of SHA512
  • pam honors the chosen ENCRYPT_METHOD in /etc/login.defs and does not override the chosen method anymore
  • changes in the filesystem (>= 2023.09.18) and pambase (>= 20230918) packages ensure, that umask is set centrally in /etc/login.defs instead of /etc/profile

[1] yescrypt - scalable KDF and password hashing scheme

[2] umask(1p) — Arch manual pages

[3] PAM - ArchWiki

[4] https://www.password-hashing.net/

[5] https://github.com/besser82/libxcrypt/pull/113

[6] Add support for Argon2 by maandree · Pull Request #150 · besser82/libxcrypt · GitHub

[7] pam_unix: Support reading YESCRYPT_COST_FACTOR from /etc/login.defs · Issue #607 · linux-pam/linux-pam · GitHub

[8] pam_unix(8) — Arch manual pages

Arch Linux - News: Changes to default password hashing algorithm and umask settings


filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.

updates for linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module

R8168 driver not loaded on kernel 6.5 after testing update 2023-09-22

All 3 versions of network-r8168 drivers are working again following [Testing Update] 2023-09-27

  • linux65-r8168 8.051.02-7
  • linux61-r8168 8.051.02-5
  • linux515-r8168 8.051.02-4


LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam
Steam crashes at launch with libgudev 238 · Issue #9805 · ValveSoftware/steam-for-linux · GitHub

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match system theme

pamac-gtk 11.0.1 uses Gtk 4 that is not supported on Xfce or Cinnamon
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.

Previous stable update threads:


Same thing again as with the last two Stable updates: upon logging in again after rebooting, my Plasma desktop was completely screwed up, and I had to restore a backup.

I suspect Plasma was not properly shut down — even though it appeared to be — and it’s probably because of one of the applications I always have open. So I guess I’m going to have to find out which application it is. :face_with_diagonal_mouth:

6 posts were split to a new topic: Why hasn’t been curl updated to latest version 8.4.0?

Are you talking about the desktop layout? I used to have the same problem, apparently caused by a single widget: Event calendar. Its initialization is kinda weird that it likes to resize itself to some numbers it want and it pushes other widgets out of their place.

1 Like

No, it’s the desktop initialization.

I have two panels — a thin one at the top that spans the entire width of the screen and holds various widgets, among which the global menu, and a slightly thicker short and floating one at the bottom, which holds the pagers and the icons-only task manager. The Plasma theme I’m using is transparent, but supports the blur effect. :point_down:

Upon logging in, I only got the top panel, empty, without blur. The bottom panel wasn’t there, and although the mouse could be moved, right-clicking the desktop had no effect.

This has been the case after each of the last three Stable updates.

I also use this, and I’ve not had the issues. So I guess this:

…means it’s time for the Great Bug Hunt of 2023. If only you could offer a reward on Issuehunt…

1 Like

I did have issues with the global menu when I used it. But apparently only some apps like gedit not using it and hence hiding the menu from me completely.
Might be Kvantum then also. It is recommended to not have it enabled upon updating and switch back to deafults, also including desktop layout before the update.
Hope my thoughts help.
[This is intended to help Aragorn’s bug hunt, not my feedback on this update]


For global menu support in gtk-based applications, you need to install appmenu-gtk-module. However, some gtk apps don’t have a menu they can export — e.g. pamac, timeshift, et al.

That’s only when updating Plasma to a newer generation. But 5.27 is the last of the 5.x series, and there wasn’t even an increase in the maintenance level now — we’re still on 5.27.8.

I appreciate it, but I think it’s a matter of something keeping Plasma from shutting down while pretending that it did shut down. :thinking:

A post was merged into an existing topic: Why hasn’t been curl updated to latest version 8.4.0?

Yes, always. :wink:


Minor issue: Konsole has an obligatory frame now. I was unable to find an option to disable the frame on its own, it’s bundled with the titlebar removal, so I did that, reluctantly.

System tray is broken:
can’t change volume
can’t change screen brightness

1 Like

Probably a theme issue. Working fine with the default Breath theme.

1 Like

For example, the Matchama Kvantum theme which is no longer supported; causing a few problems of late.

My simultaneous output audio sink (for both displayport audio outputs) stopped working with this PipeWire update - playback crashes.
Neither pulesautio module-combine-sink nor pipewire native libpipewire-module-combine-stream works.

I’ve downgraded pipewire alsa, pulse and audio to 0.3.80 and it works again.

1 Like

probably at the time, the exact vulnerability was not disclosed and curl devs took their time in getting it ready. as soon as it was relesed it was available from arch and unstable branch.

as member of a stable branch you should realize “stability” and “having latest patches” are mutually exclusive, having latest-greatest be it security or bug fixes, are of no use if those new changes lead you show-stopping regressions. this is the gamble you should take when are on a rolling-relase model distro. closer you are to the unstable branch the sooner you get all the latest stuff, closer to the stable branch, you get the resonably tested stuff,

you just cant have both!!!


All true.

I also acknowledge that releasing raw data prematurely can be counter-productive; but as information was already out there, it was probably still relevant to the thread in question.

Electron broke for me, every application causes a core dump (electron, electron24, electron25).
Tried reinstalling e.g. pipewire, the electron packages and the ones using them (code, obsidian, mattermost-desktop).


(No debugging symbols found in /usr/lib/electron25/electron)
[New LWP 17221]
Core was generated by `/usr/lib/electron25/electron /usr/lib/code/out/cli.js /usr/lib/code/code.js'.
Program terminated with signal SIGBUS, Bus error.

#0  0x00007f7c1f49c22a in  () at /lib64/ld-linux-x86-64.so.2
#1  0x00007f7c1f4810d4 in  () at /lib64/ld-linux-x86-64.so.2
#2  0x00007f7c1f4826b1 in  () at /lib64/ld-linux-x86-64.so.2
#3  0x00007f7c1f47c715 in  () at /lib64/ld-linux-x86-64.so.2
#4  0x00007f7c1f47b4e1 in _dl_catch_exception () at /lib64/ld-linux-x86-64.so.2
#5  0x00007f7c1f47cb75 in  () at /lib64/ld-linux-x86-64.so.2
#6  0x00007f7c1f498150 in  () at /lib64/ld-linux-x86-64.so.2
#7  0x00007f7c1f494cd3 in  () at /lib64/ld-linux-x86-64.so.2
#8  0x00007f7c1f49643e in  () at /lib64/ld-linux-x86-64.so.2
#9  0x00007f7c1f4952a8 in  () at /lib64/ld-linux-x86-64.so.2
#10 0x0000000000000003 in  ()
#11 0x00007fff307db8f6 in  ()
#12 0x00007fff307db913 in  ()
#13 0x00007fff307db92c in  ()
#14 0x0000000000000000 in  ()

Any ideas?

edit: updated kernel to 6.5.5, no changes
edit2: I’m on X

I tracked down the problem, I noticed no audio output available. I then investigated pipewire, removed pulseaudio etc. and while installing pipewire-git it failed due to a avcodec issue.
→ reinstalling ffmpeg solved the issue.
However, I completed the switch to pipewire afterwards (installing pipewire-pulse, manjaro-pipewire and stuff).

I’m having issues updating icon themes from KDE System Settings.
Error transferring [loooong-pling.com-url]
(However their site pling.com seems to be up. I shut down Postmaster as well to try.)