Problems updating

I use manjaro linux with the xfce DE and for roughly a month I have not done any updates recently I ran:

sudo pacman -Syu

which did not work so per the instructions on the manjaro ([Stable Update] 2023-10-13 - Pipewire, Mattermost, Qt5, Haskell, Python - #2 by philm) forum I instead ran:

sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

which worked the problem is after restarting my computer I get an error:

error: file `/wrong` not found.

Press any key to continue...

in the GRUB menu I am given two options one called Manjaro Linux (Kernel: wrong) and another called Manjaro Linux (Kernel: directory) which gives the same error

I would appreciate any help

help I followed these instruction [HowTo] Recovering from an interrupted update/upgrade and now I am seeing this:

Seems like you might have a bad entry in /etc/fstab

… now with the updated info … it might still be the case, with mounting failing.

You will need access to the system somehow. By chroot, etc.


Thanks for your reply, this is the output of manjaro-chroot -a and the fstab file in question. I am new to this and do I do not know what to look for if you could point out an issue or point me to a resource I could use to try to fix it myself I would really appreciated it, as for what you mean by “mounting failing” could you clarify?

==> Mounting (ManjaroLinux) [/dev/nvme0n1p2]
--> mount: [/mnt]
--> mount: [/mnt/boot/efi]

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=3077-D02F                            /boot/efi      vfat    umask=0077 0 2
UUID=304ed894-b2cb-454b-ba43-bfffb9ad218f /              ext4    defaults,noatime 0 1
UUID=c4d0b91b-c5fc-4741-8a32-eafad561e4de swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/sda1    /hdd    ext4    defaults    0    0

… and now compare to the UUID’s from output of

sudo blkid

By the way:

This is not smart, rather use UUID or label as /dev/sda1 is not reliably the same partition, always.


The output of sudo blkid:

/dev/loop1: BLOCK_SIZE="262144" TYPE="squashfs"
/dev/nvme0n1p3: LABEL="swap" UUID="c4d0b91b-c5fc-4741-8a32-eafad561e4de" TYPE="swap" PARTUUID="d5067299-b144-144b-8294-f0da5d2f6ed6"
/dev/nvme0n1p1: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="3077-D02F" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="b0ebd32f-b70c-6249-a09b-f4045fcb6375"
/dev/nvme0n1p2: UUID="304ed894-b2cb-454b-ba43-bfffb9ad218f" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="root" PARTUUID="f85ad3da-9765-3f4b-afc7-d1c0de8007e5"
/dev/sdb2: SEC_TYPE="msdos" LABEL_FATBOOT="VTOYEFI" LABEL="VTOYEFI" UUID="7CDB-00D9" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="66cc8833-02"
/dev/sdb1: LABEL="Ventoy" UUID="7CAB-0091" BLOCK_SIZE="512" TYPE="exfat" PARTUUID="66cc8833-01"
/dev/loop2: BLOCK_SIZE="262144" TYPE="squashfs"
/dev/loop0: BLOCK_SIZE="262144" TYPE="squashfs"
/dev/mapper/ventoy: BLOCK_SIZE="2048" UUID="2023-09-19-08-52-05-00" LABEL="MANJARO_XFCE_2302" TYPE="iso9660" PTTYPE="dos"
/dev/sda1: UUID="d52cfe93-a014-49ed-aa4d-8eeabc75ccf2" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="35dd2527-01"
/dev/loop3: BLOCK_SIZE="262144" TYPE="squashfs"

I still do not see what is wrong with the fstabs file.

Thanks for pointing that out I will look into it if I get my system running again.

Have you deleted manually some snap files?

If yes, boot a live ISO, boot with manjaro-chroot into the system and disable all of the snap mount units in /etc/systemd/system/


I tried disabling mount points and after restarting all I got was a blinking cursor after re enabling them that was still all I got, I cannot remember if I set it up but would an application like timeshift help in this situation?

If you would have saved a snapshot before the incident - yes.