[Stable Update] 2023-06-04 - Kernels, Gnome 44.1, Plasma 5.27.5, Python 3.11, Toolchain, Firefox

Its not trivial … you manually installed python311 as a foreign package and now you need to deal with the dependencies problem.
Users would normally have python and it would be upgraded normally.
python311 however is something else … it doesnt exist in the repos or the aur.

If you have many many lines of ‘exists on filesystem’ related to python … that may also indicate you at some point abused pip by doing ... sudo pip ....

Can you open a console login with ALT+F2 (or CTRL+ALT+F2)? If you can, then check the logs for problems:

journalctl -b

(scroll down to see all logs. Press q to quit)

1 Like

Before this update python311 was a regular AUR package.

No, I did not.

AUR is not directly connected to or supported by manjaro.

That package is third party and its existence has nothing to do with this update.

Unless you have the hardware that needs those firmware modules, don’t worry.
I deleted a load of firmware that I don’t need and I see those messages every time my kernels are rebuilt, but it doesn’t cause any problems.

1 Like

This problem from the previous update disappeared by itself with the current update. It is the second time that this problem appears with an update, and disappears with the next one.

Gnome Google Account not yet working
Please fix it!!

I pushed some more extramodules to the update. seems they got missed when the kernels got updated. Affected kernels were 5.4 and 5.15 series.

1 Like

5 posts were split to a new topic: PHP segmentation fault

All stable mirrors are down ???

1 Like

Update went ok, system is still working. But after the update VRR is no longer working on my monitor…

I’m using Gnome with X11 and this statement in xorg.conf
Option “VariableRefresh” “true”

I have been running it like that, for getting VRR to work. And it has worked fine up until now.

I was thinking it was a Gnome issue, and it propably shiftet over to wayland but that was not the case. Still thinking it was gnome I ran my cinnamon desktop instead (Cinnamon only uses X11 and is using it’s own compositor (muffin). But VRR still does not work.

I’m wonderring what package update broke VRR and would just like to downgrade it. I also have a system backup but would like to try something else before i pull that trigger.

I would suspekt it to be an xorg or mesa update that is the problem.

Thise where the only xorg pakages updated:
xorg-setxkbmap 1.3.3-2 1.3.4-1
xorg-xcalc 1.1.1-1 1.1.2-1
xorg-xdpyinfo 1.3.3-4 1.3.4-1
xorg-xinput 1.6.3-3 1.6.4-1

And thise the only mesa pakages:
lib32-mesa-demos 8.5.0-1 9.0.0-1
lib32-mesa-utils 8.5.0-1 9.0.0-1

My specs:

Running stable Manjaro
AMD CPU Ryzen 5 1600AF
Driver: Mesa
Kernel: 6.3.5
Desktop Gnome and also have cinnamon.

Any solution or suggestion is highly appreciated.

I’ve opened a separate topic for this issue, as it’s very severe and messages in here seem to flood in: 2023-06-05 update broke gnome-shell

If you still have the issue, please check in in 2023-06-05 update broke gnome-shell. I’ve opened a separate topic for this issue.

1 Like

I deleted the /var/temp/openrazer folder and it did a clean rebuild.

I found myself in the same position.
Disabling gpu acceleration worked as a quick workaround.
But i found another post about the same issue in the arch forum: https://bbs.archlinux.org/viewtopic.php?pid=2098015#p2098015
Doing an:

# rm -rf ~/.config/google-chrome/Default/GPUCache

fixed the problem for me. Now chrome start as usual without any graphics glitches


i’m using plasma and i noticed that the last stable update affected mouse cursor movement speed - this update restored it to what it should be, but i first had to adjust the speed in system settings (no need to enable adaptive speed)

After the update VLC and Smplayer stutter with fullscreen videos.

Same here for Xfce, Monospace Font Selection got reset to “empty”

Why didn’t the new Lutris version make it into this update? I know it landed on testing a few weeks ago.

Its kind of important because of this issue.

Although python311 has not been in the AUR for a few weeks (since Arch upgraded to python 3.11) you can still uninstall it, using you AUR helper or pacman.
You need to uninstall it before starting this system update.

Always read the wiki post at the start of these announcements, before upgrading.
AUR python311 is mentioned in [HowTo] Re-install packages after a Python upgrade (short version)